Tomato v111 Shibby RT-N66U no working 5GHz

Discussion in 'Tomato Firmware' started by Werner, Jul 30, 2013.

  1. Werner

    Werner Networkin' Nut Member

    First of all, thanks for your work Shibby. But since my update to v111 the 5Ghz is not working anymore...

    I first updated without clearing the NVRAM. But then my iMac lost it's 5GHz connection and reconnected using 2.4GHz. I first thought my iMac was the problem, so I restarted it and checked the config.
    But then I noticed that my Linksys E2000 (which is in Ethernet Bridge mode connected to my RT-N66U on 5GHz) also lost connection.

    Then I did a full NVRAM reset and reconfigured everything. But still no 5GHz. Both the iMac and Linksys E2000 cannot see the SSID at all (Range is about 2m).

    Then I thought maybe the VPN build I used was corrupt or something, so I flashed it with the AIO version. But still the same problem...

    Then I noticed a strange thing: My iPad Mini can see (didn't try to connect) the 5GHz SSID. But my iMac and E2000 still can't.

    Any idea what's going on? I can flash back to 110, but maybe Shibby can see what going on if I execute some console commands. Thanks in advance...
  2. Werner

    Werner Networkin' Nut Member

    More then 24 hours and 90 views passed, but not a single (helpful) reply?
  3. shibby20

    shibby20 Network Guru Member

    can you show us screen of your wireless configration? I have not any problem with 5GHz on my RT-N66u.

    btw v112 was out.
  4. Daky

    Daky Network Guru Member

    Same here, all works good on v112 (on v111 as well)
  5. Werner

    Werner Networkin' Nut Member

    I just updated to 112, but that didn't solve my problem.
    Made two screenshots of the web config.


    Both pages have almost all settings at default values. And the strange thing is, I didn't even change settings between updating.

    Also note: There are no other 5GHz networks around that might interfere with the signal. I am currently the only 5GHz user in this area.
    Also note: Did you read about the iPad being able to find the 5GHz SSID, but my iMac and Linksys E2000 are not. That's pretty weird if you ask me...

    I think Shibby can find out more by giving me some Terminal commands. Then I will post the output of those commands here.
  6. Werner

    Werner Networkin' Nut Member

    Just to be sure I pressed the Save button on both Settings pages and rebooted the router. And now the 5GHz network seems to be back. So I guess version 112 did fix the issue I was having.

    I will keep checking things, and I will keep you informed.
  7. shibby20

    shibby20 Network Guru Member

    1) select channel (for example 161).
    2) try not use a "space" in SSID. Change SSID to RT-N66U-5Ghz
  8. Victek

    Victek Network Guru Member

    It's the 5GHz LED on?... I noticed in latest builds that MAC address for 5GHz is lost..
  9. Monk E. Boy

    Monk E. Boy Network Guru Member

    I've noticed some issues with RT-N66s if I don't hit the "Default" button under MAC address for every interface, which usually changes them to different values (and then save the new values, obviously). Prior to assigning default MACs in this fashion I usually see two or more interfaces are listed with the same MAC address. If both wireless interfaces had the same MAC I could see some devices getting confused.
  10. Werner

    Werner Networkin' Nut Member

    Since I updated to 112 the 5GHz network is working like before. But I did check the MAC address settings, and they were wrong like you guys expected… Even after a full NVRAM clear. Also pressing DEFAULT on the 5GHz interface gives me a different starting number (62) then the rest of the addresses (60). After I hit save the number 62 magically transformed into 60 :)

    I made some screenshots again: and

    I think there are some bugs in the MAC address part. I am sure for the 5GHz address starting with 62 when pressing default, and then turning into 60 after pressing Save.

    Also I created a 2.4 Virtual Wireless and pressed the DEFAULT button for the MAC address, and then it filled in the 5GHz MAC Address starting with the 62.
  11. macgyver

    macgyver Reformed Router Member

    I also noticed the same behaviour for eth2 creating same virtual MAC on 5GHz and other anomalies in this thread:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice