Tomato Version 1.0 Now Available

Discussion in 'Tomato Firmware' started by Reiper, Dec 4, 2006.

  1. Reiper

    Reiper LI Guru Member

    Here's 1.00... More fixes, more features, and now plays nicely with Buffalos. Enjoy! :)

    * Fixed "all day" restrictions always blocks regardless of the day of week setting.
    * Fixed several problems with the Basic Networking page.
    * Fixed a problem with WRT54G v1 that may have caused problems with WDS.
    * Fixed PPPoE timer may not reset.
    * Fixed DHCP client may not renew when used with some ISPs.
    * Fixed a memory leak in UPNP.
    * Added support for Buffalo WHR-G54S/WHR-HP-G54S.
    * Added a real-time (well, almost) bandwidth monitor. This functions a little differently in that you can use it without the rstats program and data is pulled and stored via JavaScript on demand. Since this doesn't run all the time, the initial 5 minutes (@ 60s avg - it will look flat) of data is taken from rstats if available.
    * Added a chart for bandwidth distribution per QOS class (outbound).
    * Added an Expire Early button in Advanced/CT to flush conntrack of connections that are idle for more than 15 seconds (for debugging).
    * Added an "all computers except the following" option in Access Restriction. Keep in mind that this is not the same as an "allow". Even if a computer is exempted from one restriction, it's still checked for other restrictions.
    * Added an option to block wireless access to the GUI. Note - This will only work if the client is connected directly.
    * Added an option to change the color scheme for the GUI.
    * Added a backup/restore, "first day of the month" option, and "excluded interface" option In Bandwidth Monitor. All interfaces that produce stats (except loopback) are now shown unless excluded.
    * Enabled support for mixed WPA/WPA2.
    * Resetting of classification when changing QOS settings is now optional. If enabled, it's now instant and will reset even idle connections.
    * /jffs2 has been renamed to /jffs, and /misc to /rom. If you have scripts that use these, don't forget to change them.
    * Upgraded busybox to 1.2.2, dnsmasq to 2.35.
    * Other minor/internal changes and code cleanup.

    Get it here!
  2. purephase

    purephase Network Guru Member

    Upgrade went successful. Haven't used it much to see if there are any issues, but so far so good. Thanks!
  3. JensG

    JensG Network Guru Member

    I'm currently using v0.09.

    Can I upgrade to v1.0 without having to reset and set up everything again?
    Can I download a v0.09 configuration file to v1.0?
  4. der_Kief

    der_Kief Super Moderator Staff Member Member

    I think it should work. But the safe way is to flash, 30sec reset button and set everything up again !

  5. lwf-

    lwf- Network Guru Member

    I see that it now works stable with Telia, good job and thanks a lot!
  6. Reiper

    Reiper LI Guru Member

    Does anyone know what the "Shutdown" does in Version 1.0?? I did this and went to the router to see what happened and the power light just blinks. Unplugged and plugged back in no problems. Just wondering what you gain by using the shutdown feature over just power cycling the router?
  7. computerfreek

    computerfreek Network Guru Member

    after upgrade from 0.9 bata

    I upgraded to ver 1 and now my DSL will not connect pppoe .it says connecting but never happens . I tested my DSL with a 2nd router with dd-wrt and it in fine. Can someone please tell me where to download an old ver like 0.9 for now till this bug is fixed. also i did a full reset after upgrade and still the same thing will not connect.

    the unit is a wrt54g ver 2

    Thank you
  8. GeeTek

    GeeTek Guest

    The older versions should still be on your hard drive where you saved them and flashed them from before.
  9. computerfreek

    computerfreek Network Guru Member

    I checked but it must have got deleted as it was on my desktop

    I checked but it must have got deleted as it was on my desktop.

    If anyone has ver 0.9 bata the bin for wrt54g please send it to me or a downlaod link to it .

    send to sales (at)

    Thank you

  10. NateHoy

    NateHoy Network Guru Member

    If you can't find the old 0.09 firmware PM me with an email address and I can send it to you. I have it on the hard drive of my Linux box.
  11. GeeTek

    GeeTek Guest

    I just Yahoooood it to you.
  12. computerfreek

    computerfreek Network Guru Member

    Thank you geetek and others for sending ver 0.9 it worked great and now PPPoe is working fine ... Is this the right place to submit this BUG for pppoe ? it looks like even after a hard reset with ver 1 and also flashed it 2 times with ver 1 it is not working for pppoe. just hope the bug fix comes out soon.

    Thank you very much to all
  13. NateHoy

    NateHoy Network Guru Member

    I'd start a new thread, but yes, this forum is as close to an "official" forum for Tomato as you'll find. Attaching the bug report to a generous Paypal donation to noxxic [at] (the author's address) couldn't hurt, either. :thumbup: (grin)
  14. digitalgeek

    digitalgeek Network Guru Member

    I have flashed (without a reset to factory) and had no problems my dsl just kicked in and continued. I even started some BT dls, and poaked arround remotely. I looked at the new graph (love it), I looked at the new colour scheme... cool (kept the orignal tomato look) over all everything looks great! I will have to flash my second router later (when I get home from work). Luv this tomato... keep up the good work. :)
  15. myersw

    myersw Network Guru Member

    Don't think the author hangs out on this forum the way others do. Best to email him. Readme info on official site says following:
    To report a bug or for questions about this firmware, send an email to
    Sorry to hear about the bug as I use DSL PPPoE as well. I'll probably still try. Have a backup router if it fails.
    Love the firmware.
  16. computerfreek

    computerfreek Network Guru Member

    Cool if you do test it with your DSL pppoe let us know if it worked for you as i have a 3 dsl modem i can test it with. I like to see if it works for others so i can fix mine..

    Or if anyone has already tested pppoe with ver 1 please give us an update . Thank you.

    Also i did send an email with logs to him and i hope this gets fixed. Soon !

  17. computerfreek

    computerfreek Network Guru Member

    Well maybe it has to do with the router mine is a ver 2 . and i know with testing other firmwares that sometime this gets messed up on VER 2 routers..

    Can you please let me know what router you have and ver you have ?

    As I have 7 other routers here i can play with ?

  18. nsumner

    nsumner LI Guru Member

    Really this should be a new topic but... On my Buffalo WHR-HP-G54 I am running PPPoE without any problems. I installed the update and was connected to the internet again immediately.
  19. Shirakawa

    Shirakawa LI Guru Member

    Stupid question: will it work with an AG241V2 ?
  20. MadPriest

    MadPriest LI Guru Member

    Upgraded from 0.9 version.
    So far - works fine
  21. digitalgeek

    digitalgeek Network Guru Member

    I have know completed the update on both routers! I have not had any problems (nor have the wireless devices) PPPoE, QOS... Tomato Rocks!
  22. pharma

    pharma Network Guru Member

    It's good to know the problem Computerfreek had may infact not be a BUG as other people have no problems running PPPoE! :rolleyes:
  23. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    The AG241V2 is a different beast and nothing like the WRT54 series.
  24. shadow2k6

    shadow2k6 LI Guru Member

    Computerfreek: I had this problem once even on the 0.9 version. I tried everything to fix the problem and ended up re-loading 0.9 and re-entering all my previous values. I will not be able to test 1.0 on my router until Thursday, but I suspect if you load 1.0 again and then clear nvram and then re-enter your values it should then work fine. Once again, not sure why this happened but it never happened again for me.
  25. jeffjs

    jeffjs Network Guru Member

    1.0 CPU Load

    Is the CPU load working for anyone?
  26. Reiper

    Reiper LI Guru Member

    Mine almost always shows 0.00/0.00/0.00 but it has done this for all of the versions (since version 0.03 for me).
  27. spyderco

    spyderco Network Guru Member

    This firmware is a Blast ! :D

    Upgraded my Tomato 0.09 v3 wrt54g, without clearing nvram.
    went smooth :)
    Using ADSL, PPPoE , static ISP IP address
    Nice to have different skins, now I can differ my routers by there look'n feel :)

    - has anyone upgraded a wrt54gl yet ?
    - has anyone upgraded a cables l2tp connected wrt54gl yet ?

    Load isnt working on mine either.
  28. RTSAnime

    RTSAnime Network Guru Member

    load works fine for me. Confirmed that it matches the numbers uptime gave me. Load should almost always be 0 for these boxes as there isn't usually a program trying to run. (Load is an moving average of the run queue length)
  29. digitalgeek

    digitalgeek Network Guru Member

    I can't figure out the load, I am always seeing 0.00/0.00/0.00, ocassionaly the the 5min might jump to 0.03 or even 0.05... either were have a realy amazing firmware or something is wrong... I tend to believe that its the amazing firmware as I don't have any problems with lock ups... in fact since I started use tomato I have reset my dsl modem once.

    the was a thread on low ram once... just to clarify... I am always running at 500 to 800 KB and never (as I said above) have any lock ups or significant lag.
  30. der_Kief

    der_Kief Super Moderator Staff Member Member

  31. shari

    shari LI Guru Member

    can someone post a screenshot of the port forwarding site of v1.0 please. or email to

  32. computerfreek

    computerfreek Network Guru Member

    Well after working with the developer and some test firmware my setup is working. But not fixed yet . 1.0 works but not with the DSL modem i had on there i change the dsl modem and all is good . It seem that my speedstream 5360 modem is not working on 1.0 works fine on 0.9 . On 1.0 it like it is not even seeing it on the line no lights at lighting up or anything just like if it was not pluged in. But this westel modem works fine on 1.0 . if i plug the 5360 in it's just like it is dead on the line . even after erase of the nvram and flashing it 10 times.

    But the developer was very very helpful and worked with me and sent me a few test firmwares lastnight to try and fix this .

  33. jeffjs

    jeffjs Network Guru Member

    I found where to change the skins: Administration/Admin Access/Color Scheme.

    This is cool!
  34. shari

    shari LI Guru Member

  35. computerfreek

    computerfreek Network Guru Member

    Screenshot hope this is what your looking for uif not let me know this from ver 1.0


    Attached Files:

  36. shari

    shari LI Guru Member

    thanks computerfreek. It's still the old way. thanx anyway
  37. computerfreek

    computerfreek Network Guru Member

    I have the same thing on my main router i have to run DD-wrt to forward out to other ip's other than my subnet. It's a nice setup and i hope it gets into this firmware as i do use it on my main router.I need this very much as i have 5 ip's and then a DSL line too . And sometimes i need to forward out to the DSL or one of the 5 ip's.

  38. njeske

    njeske Network Guru Member

    Got 1.0 up and running on both my routers without wiping NVRAM. Everything seems to be working great so far. The only thing I noticed was that after the routers rebooted it took longer for the WDS link to come up. Maybe just a fluke, but I'll watch for it next time I need to reboot.
  39. snajgel

    snajgel Network Guru Member

    I have read about that wrt54g dosent pass trough the GRE protocol. Does anybody know if it works with this firmware?
    I'we set up a win2003-box with pptp enable, I can acces to it on the lan, but cant acces i from the outside.
  40. PsychoD

    PsychoD Network Guru Member

    About flashing and the settings. I mailed this question to Jon a few weeks ago and this is the answer:

    Me: When upgrading to a new tomato version, I normaly just upgrade using
    the latest firmware file and reboot the router. Is this OK? The reason I
    ask is because I remember dd-wrt, where one has to do a factory default
    reset before and after the upgrade and no restoring of config files or
    similar is allowed.

    Jon: That's fine.
  41. Reiper

    Reiper LI Guru Member

    Maybe it is the "geek" in me but I always do the factory reset before and after a flash. To me it just seems like it "cleans things up". Of course I always want to reboot the router after making changes which I know you don't need to do with Tomato... Old habits die hard! :)
  42. dvaskelis

    dvaskelis Network Guru Member

    The router will pass it through, but that only helps if you initiated the "connection" from the inside going to the outside. For the other way, while the user interface doesn't allow you to forward it to a specific IP destination behind the NAT firewall, I bet you can do it from the command line... it's protocol 47, right?

    On the bright side, the QoS screens have it.
  43. myersw

    myersw Network Guru Member

    Tomato v1.0 on wrt54gl v1.1 using ADSL and PPPoE

    Just upgraded my wrt54gl v1.1 with Tomato V1.0. Went without any problems. Have AT&T ADSL service using a Speedstream 5360 modem. Similar to another post where they had problems. Was a different provider.
    While I agree with folks about resetting nvram after upgrade and reenter everything and do a power cycle, I have never had to with Tomato. Have with most others I have tried. Been using Tomato since v.03. Previously was using Thibor 15c, also great firmware, and DD-WRT. DD-WRT v23sp1 was not stable for me which is what drove me to Thibor. Had a wrt54gs at the time, hum guess I still do. Also had a wrt54g v1.1 which I ran Thibor+Tofo on (was donated to Jon for debug on wrt54g v1) so was aware of the author of Tomato . Have never had a problem with any version of his firmware.
  44. Etienne49

    Etienne49 Network Guru Member

    switched from dd-wrt SP2 to tomato

    Hello !
    dd-wrt is a good firmware. Bryan Slayer is doing an impressive work on it. But it seems like tomato much more meets my needs.
    So bye bye dd-wrt !
  45. snajgel

    snajgel Network Guru Member

    I have forwarded port 1723.
    How should I do in the QoS screen?
  46. ch0815

    ch0815 Network Guru Member

    Works perfect on my WRT54GL 1.1. Thx
  47. Wirelezz

    Wirelezz LI Guru Member

    SAme HERE

    Yeh same here. I returned my buggy SRX400 and took my 54GL out of the closet .
    Threw this Tomato software on it and works like a charm! I luve it !
  48. dvaskelis

    dvaskelis Network Guru Member

    I don't know what your implementation is exactly, but GRE (protocol 47) <> TCP/UDP (protocol 6/protocol 17), so forwarding port 1723 over TCP or UDP doesn't have anything to do with GRE.

    QoS has GRE as a protocol in the drop-down.
  49. Devileyezz

    Devileyezz LI Guru Member

    Same here.
    I have Thibor 15c running.

    So, shall I hold reset button for 30 seconds... come back, login to the thibor interface, go to upgrade firmware.. navigate to code.bin (tomato), and click on upgrade. Wait for it to get done.

    Then, pull out the power of the router. Press and hold reset.. and around the 30th second, push power back in? And then configure the new tomato interface, and then reboot.. and then go ahead?

    Is that what I should be doing to go from Thibor15c to Tomato 1.00?
    What if I don't like Tomato? How do I go back to thibor?

    WRT54GL v1.1
    Also, will wireless be stable on this?

    PS: Yeah, DD-WRT can go bye bye. Spent 2 months trying to make it stable, never did.
  50. Reiper

    Reiper LI Guru Member

    After you've loaded Tomato onto the router you can just go to Administration,Configuration,Restore Default Configuration, Select Erase all data in NVRAM... instead of holding the reset button in.

    Also I've never had an issue with the wireless with Tomato! :)
  51. johnny2002

    johnny2002 LI Guru Member

    I got the same problem first, and it works after "switch off and then switch on" instead of "reset".
  52. bleagh

    bleagh Network Guru Member

    There are times, specially when changing to completely different firmwares, that you cannot connect to the router until resetting it. I have even had times after loading a completely different firmware, that I could do anything at all until I turned the router off. After loading the firmware the power light was blinking and the router was completely unresponsive. Even pressing the reset did nothing.

    In such cases the best way to reset the router is:

    Unplug the router, press and HOLD the reset, plug the router in while continuing to HOLD the reset, contiue to HOLD the reset for 30 seconds after the router is plugged in (turned on). Then release the reset.
  53. ontguy

    ontguy Network Guru Member

    Upgraded to Tomato 1.0 from 0.9, did a software clearing of the NVRAM and a reboot. It works well!!

    In previous versions I had trouble with the Connect on Demand setup for my PPPoE connection (at times it wouldn't connect at all); that seems to be fixed now. I'm testing out Qos this version round.
  54. Devileyezz

    Devileyezz LI Guru Member

    What about before?
  55. Reiper

    Reiper LI Guru Member

    I always do a NVRAM reset before and after a firmware flash. Bleagh recommendation of unplugging router, pushing the reset button, plugging in the router while still holding the reset button, and letting go after 30 sec will also reset the NVRAM (handy if you can't get to the web interface).

    However, by doing the NVRAM reset in the web interface (again assuming it is accessible) you can save ware-and-tare on that poor reset button!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice