Tomato wireless rate drop in client mode

Discussion in 'Tomato Firmware' started by uha666, Jan 21, 2014.

  1. uha666

    uha666 Reformed Router Member


    I recently changed from using dd-wrt on my routers to using Tomato because of stability appears to be better, i was having trouble using dd-wrt because of constant rate drops.

    But in my redesign of my home network i encountered the following problem that makes my wifi speed drop to 2Mbps and stay there until i disconnect and reconnect again.

    My current setup is the following:

    #Router 1 - Normal ADSL ADB router with SSID XXX and WPA security with no ethernet clients (only wifi)

    IP Range - 192.168.1.X
    DHCP Enabled
    Firewall Enabled
    UPNP Enabled
    QOS Disabled
    WMM Disabled

    #Router 2 - Tomato powered Linksys WRT150N firmware tomato-K26-1.28.RT-MIPSR1-116-Mini (Also tried K24 with same effect) with SSID YYY and WPA security with Router 3 attached via ethernet.

    Connected to Router 1 via Client mode
    IP Range - 192.168.2.X
    DHCP Enabled
    Firewall Enabled (actually i can't tell in tomato lol)
    UPNP Enabled
    QOS Disabled
    WMM Disabled

    Default settings apart from the client mode and change in ip range nothing else was changed.

    #Router 3 - SMC router WBR14G2

    Connected via ethernet to Router 1 to serve as Access Point
    DHCP Disabled
    Firewall Disabled
    NAT Disabled
    UPNP Disabled
    QOS Disabled

    The problem occurs when i connect via wireless to #Router 3 i start downloading a file and suddenly the download rate drops to 2-1Mbps

    If i connect via ethernet to #Router 2 i get max speed and no drops.

    I tried 3 different routers connected via ethernet to router 2 and they all generate the same problem.

    The only solution i found is that when i place the IP of #Router 2 in the DMZ (demilitarized zone) of #Router 1 and the problem doesn't occur.

    My question is, is there any extra config i need to do on Router 2 or 3 so that i don't have to place the ip in the DMZ? Also why does this happen is it a firewall problem?

    Been battling this for a week with no success. Has anyone else encountered this problem?

    Best Regards
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice