TomatoVPN loses Port number on Start

Discussion in 'Tomato Firmware' started by zzz1545, Jan 31, 2011.

  1. zzz1545

    zzz1545 LI Guru Member

    I installed TomatoVPN 1.27vpn3.6. I am trying to configure a Static Key VPN Server to connect to with my Macintosh or PC. The configuration is:
    VPN Tunneling -> Server 1 -> Basic:
    Start with WAN: checked
    Interface Type: TAP
    Protocol: UDP
    Port: 1193
    Firewall: Automatic
    Authorization Mode: Static Key

    VPN Tunneling -> Server 1 -> Advanced:
    Poll Interval: 0
    Respond to DNS: not checked
    Encryption Cipher: Use Default
    Compression: Adaptive
    Custom Configuration: <Empty>

    VPN Tunneling -> Server 1 -> Keys:
    Static Key: <An OpenVPN Static Key V1 generated from the command "openvpn --genkey --secret filename">

    Every time I push the "Start Now" button, the VPN Tunneling -> Server 1 -> Basic -> Port field goes blank and the log says:
    Options error: Bad port number: 0
    VPN_LOG_ERROR: 822: Starting VPN instance failed...

    I have tried with port numbers 79, 600, and 6000. I made sure that none of the port numbers I've tried are in a Port Forwarding range.

    Can anyone give be a suggestion on why the port number keeps getting wiped out?

    Getting to this point is been really difficult for me. Is there a TomatoVPN Static Key tutorial I can check out to see if I'm doing any of this remotely correct?

  2. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    Sounds like your NVRAM is corrupted. This often happens if you don't wipe NVRAM after upgrading firmware. You should erase the nvram (thorough) from the web GUI (administration->configuration) and configure from scratch by hand.
  3. zzz1545

    zzz1545 LI Guru Member

    That solved my problem.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice