too less memory?

Discussion in 'HyperWRT Firmware' started by VladTepes77, Nov 11, 2005.

  1. VladTepes77

    VladTepes77 Network Guru Member


    I've a question regarding my memory of my WRT54G v3.1. Yesterday i flashed it from the original 4.20.8 (de) firmware to the HyperWRT + tofu9. I did a hard reset before and after flashing it.
    Entering via telnet and checking meminfo I got a very similiar output to my actual one:
            total:    used:    free:  shared: buffers:  cached:
    Mem:  14807040 14213120   593920        0  2068480  6119424
    Swap:        0        0        0
    MemTotal:        14460 kB
    MemFree:           580 kB
    MemShared:           0 kB
    Buffers:          2020 kB
    Cached:           5976 kB
    SwapCached:          0 kB
    Active:           5532 kB
    Inactive:         4448 kB
    HighTotal:           0 kB
    HighFree:            0 kB
    LowTotal:        14460 kB
    LowFree:           580 kB
    SwapTotal:           0 kB
    SwapFree:            0 kB
    So, I entered the following commands:
    erase nvram <enter>
    reboot <enter>

    Indeed it restores the factory defaults, but I still get the same out when checking meminfo.
    My questions for now:
    Is it normal to have this amount of memory used?
    I have no heavy traffic on my connection..
    Secondly, my commands order should have the same effect as erase nvram; reboot <enter> or am I completely wrong? I don't think so, but who knows.

    Thnx in advance and sorry for the inconvenience, I know it might be a silly question, but I searched through the posts and I didn't find anything related to this specific topic.

    Have a nice day:)
  2. gaster

    gaster Network Guru Member

    I have a G V3 and a G V4. The V4 is running Thibor's HyperWRT and the V3 runs Tofu9.

    Here are my numbers:

    first the V3:
    totalram=14807040, freeram=3940352, bufferram=1736704;

    then the V4:
    totalram=14815232, freeram=3231744, bufferram=1732608;

    I have more free RAM on mine, but you have a larger buffer size.
    Maybe the buffers aren't really holding anything right now, but are just reserved in case they are needed so it's no big deal.
    I'm not really sure though.

    One thing I don't understand about mine is the difference in total memory. They should be the same. oh well, they both work and are stable so I won't complain.

    I think nvram erase;reboot then the enter key is correct. I did that exact command on mine before setting them up too.
  3. VladTepes77

    VladTepes77 Network Guru Member

    So, I tried some settings...
    First of all I tested erase nvram;reboot...quite after rebooting i checked the free memory, as "expected" (desired) free memory about 3,5MB...after configuring the router, the free memory size shrinked to 1, I reseted the router again and looked for the reason. Here my results:
    Activating DDNS costs me about 400Kb.
    Wireless MAC-Filter about 300Kb.
    HTTPS and Remote Access via HTTPS about 1MB.
    Weird thing happened when setting the Start IP addres for DHCP to another value, it costs me abou 300Kb.

    Is this a usual behaviour? Nevertheless I'm now happy to have about 1,5MB free memory, it's OK, just wondering...

    Update: I might have found the reason: here it goes
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice