Tried to go from Alchemy to Linksys and now LAN ports dead

Discussion in 'Sveasoft Firmware' started by FelixTCat, Dec 20, 2005.

  1. FelixTCat

    FelixTCat Network Guru Member

    I tried to go from an old version of Alchemy to the latest linksys firmware for my WRT54g V1 using Linksys flash utility. It said the update was complete sucessfully but now the LAN ports are dead.

    I can still access the router via the wireless network but get no response to pings from the LAN side.

    Can you suggest any ways to fix this brick ?. Should I try reflashing a firmware via the wireless network ?
  2. NateHoy

    NateHoy Network Guru Member

    Re: Tried to go from Alchemy to Linksys and now LAN ports de

    Yikes. Well, that would probably be your only way, if the wired clients are well and truly dead.

    Here's what I'd suggest, in order, checking for function each time. Obviously, if one works, stop there and call it good.

    1. Unplug router, plug back in. I'm sure you've tried this one.

    2. Change out patch cables (again, you've probably done this, but just in case - I've done FAR dumber...)

    3. Press the reset button for >30 seconds.

    4. Unplug router, press reset button, plug back in while holding reset button, hold reset button for >30 seconds.

    5. re-flash aftermarket firmware over wireless, once you have a solid signal (keep the PC and router close, don't move or touch anything while it's going on, no nipping off to microwave your dinner, turn off and unplug any 2.4Ghz cordless phones, line your room with heavy duty aluminum foil, eat your vegetables, and pray the Interference Gods treat you well). DD-WRT Mini Generic might be good as it's very small. Then if that works, you can play with how to get the Ethernet ports working, then erase NVRAM, before you go back to factory.

    Others may have better suggestions, but that's what I've got for starters.
  3. NateHoy

    NateHoy Network Guru Member

    Re: Tried to go from Alchemy to Linksys and now LAN ports de

    Oh, and one other thought... Are the lights lighting up on the LAN ports when you plug in a cable? Could it be that you are getting a connection, but no DHCP?

    Try an IPCONFIG /RELEASE , IPCONFIG /RENEW cycle if there are any lights at all, just to see what comes up.

    If nothing that way, try hardcoding as the TCP/IP address in a client, and see if you can get to or at least ping the router that way.

    Don't forget to reboot the client, or from Windows XP do a "repair connection" just to make sure you don't have something silly like a bit of erroneous cached information or something there.
  4. ofbarea

    ofbarea Network Guru Member

    Re: Tried to go from Alchemy to Linksys and now LAN ports de

    You can also try flashing to Tofu11, then erase the NVRAM.
  5. NateHoy

    NateHoy Network Guru Member

    Re: Tried to go from Alchemy to Linksys and now LAN ports de

    Tofu would most certainly work. Any firmware that allowed a command line would do fine for playing with the Ethernet ports and figuring out why they are shut down.

    However, IMHO, if I were to need to do a firmware upgrade over ( :eek: ) wireless, I'd pick the smallest and lightest firmware I could. The less time spent in that oh-so-delicate "transfer in progress" state over a fragile wireless link, the better.

    Not that Tofu is inordinately huge, or inherently bad - I run Tofu 10 myself, so I'm a Tofu fan big time. But smaller is better when depending on wireless. At least IMHO.

    Either way, though, that's a last resort. A manual reset button NVRAM erase is simpler and has lower chance of brickage.
  6. FelixTCat

    FelixTCat Network Guru Member

    Tried the Unplug, Numerous times.
    Changed out patch cable but went back to first one (thats how I got myself in this mess to start with, wired update)
    Tried the reset button >30 seconds both while unpowered and powering up. Also tried running ping while powering up to see if I got any response.

    LAN lights are coming on and seem to indicate a connection but I get no ping response or ip assignment. I have also tried setting the IP address of the laptop to (and .2) to see if that helped. No dice.

    I will try DD-WRT MINI Generic this evening once I shut down my other router JUST to make sure that the flash utility doesn't jump to the good wireless router in the middle.
  7. FelixTCat

    FelixTCat Network Guru Member

    OK, I tried WRT-V23 Mini (over wireless) and I was able to get the LAN ports working again BUT as soon as I loaded the WRTV23 54G my LAN ports stopped responding again.

    The LAN lights are on but it will not respond to pings and I do not get an IP via the LAN connection.

    If it matters I also noticed that my current time is scorched on the status screen. I don't know if it was like this before or not.
  8. NateHoy

    NateHoy Network Guru Member

    Ummmm. Did you try an ERASE NVRAM in case there's a stuck value out there hosing you up?

    Otherwise, well, I dunno what to say. Dang. Maybe someone smarter than me'll come up with something, but I'm tapped out. Sorry.
  9. FelixTCat

    FelixTCat Network Guru Member

    I did not but how do I ERASE NVRAM ?

    Also, is it normal for the Diag light to be on when running the mini version ?
  10. FelixTCat

    FelixTCat Network Guru Member

    I flashed back to v23mini. My LAN ports were still dead. I went to the Administration page and in the CMD parameters I entered Erase nvram.
    After that I still had no LAN ports (tried 30 sec reboot etc) so I figured what the hell and flashed Tofu 11 through the web interface over the wireless connection.

    It worked and when the router rebooted I now have my LAN connections back. I went to the admin / factory defaults page and selected clear nvram, restore factory defaults then hit the restors button (this is all in tofu11). The router rebooted and it seems to be working fine now.

    Thanks for the help, if you have any advice for me please add it on.
  11. NateHoy

    NateHoy Network Guru Member

    Yeah. Stay with Tofu! Don't mess with success! It's better than the native stuff anyway.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice