Tried to upgrade to Alchemy V1 twice and bricked it twice

Discussion in 'Sveasoft Firmware' started by ShapeGSX, Jul 9, 2005.

  1. ShapeGSX

    ShapeGSX Network Guru Member

    I have a V3 WRT54G with the version 4 firmware. I tried to upgrade to Alchemy V1 twice using the web interface for firmware upgrades. Both times I ended up with the message "Upgrade are failed" in red on the screen. I used a wired connection. I even set it to half duplex/10M.

    The only way to revive it was to set an IP address of on the computer with a mask of and a gateway of and run tftp. Took me a little while to figure that one out. :)

    So why did the upgrade fail on me?
  2. supercomp

    supercomp Network Guru Member

    I don't think Alchemy 1 Final is compatible with WRT54G V3.
  3. ShapeGSX

    ShapeGSX Network Guru Member

  4. supercomp

    supercomp Network Guru Member

    Wierd. I downloaded Alchemy V1 Final and the README file said it wasn't compatible with V3.

    I have WRT54G V3, so let me know if you get it working.
  5. jmgrant

    jmgrant Network Guru Member

    WRT54G v3.1 w/v4.00.7 Firmware

    I just bought a new WRT54G v3.1 w/v4.00.7 firmware, at Best Buy, for testing and an engineering study. I have tried a half dozen times to load Alchemy v1.0, and bricked it every time! I can do a recovery with the Linksys v4.00.7 firmware and everything seems fine.

    I have gone through as much of the Sveasoft site as a basic registration will allow, and can't find squat. I sent a PM to James, but no reply.

    I have heard some really good things about the Sveasof firmware and truly want to deploy this software for the community network I am designing, but this level of support is unacceptable.

    If anyone can point me in the right direction, I would really appreciate it.

  6. jagboy

    jagboy Network Guru Member

    right now your best bet would be dd-wrt. but the firmware out for the wrt54g. but the firmware that is aviable for the wrt54gS's and wrt54g's are not compatabe with the wrt54gv3.1 maybe it is a hardware change. or it is the 4.00.7 firmware i dont think that it will let you downgrade, or switch to a 3rd party firmware.
  7. jmgrant

    jmgrant Network Guru Member

    WRT54G v3.1 / v4.00.7 Firmware - Update

    I looked around for an older Linksys firmware but couldn't find one. I then began trying some of the other firmwares - including the one suggested by jagboy.

    No success, until I tried one called Freeman. Turns out it is a fork of the Sveasoft Talisman Basic firmware. It loaded fine, suggesting that Talisman would probably do the same. But it doesn't seem to include all the features.

    Now if I could just get James to answer my email, I'm sure I'd be set.

  8. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    Alchmey will work with version 3.0 hardware although people are reporting similar issues when flashing. Be careful with 3.1 hardware versions as there are rumors indicating it may contain a newer broadrom chip as the original v 3.0 chip had problems. And there is no word on if it works with Alchemy. Talisman has been reported to work with the 3.1 hardware though.

    For the record, Talisman has all of the features of Alchemy plus more. Talisman is based on Alchemy code with tons changes made to the interface and backend modules. Most noteable:

    dnsmasq in place of dhcpd
    Bird instead of Zebra for WDS
    Extensive use of ebtables instead of iptables
    IPv6 support
    RW parition if enabled
  9. jmgrant

    jmgrant Network Guru Member

    WRT54G v3.1 / v4.00.7 Firmware - Update

    Disman_ca is correct, but I was speaking to the other features that have yet to be released or have been removed so that more targeted versions can be created. For example, hotspot, mesh, and OEM.

    Sorry if I confused anyone.
  10. ShapeGSX

    ShapeGSX Network Guru Member

    I'm the original poster. My WRT54G is a CDF8, which is version 3.0. Though the Hardware version says v2.0 under the sysinfo page. So that confuses me. :?

    "Upgrade Are Failed"
  11. jmgrant

    jmgrant Network Guru Member

    WRT54G v3.1 / v4.00.7 Firmware - Update

    ShapeGSX, when did you buy it? I just got mine and it, too, is a CDF8 and says "v.3" on the label. Based on the information I have, I suspect it is the newer v3.1 hardware. As for the sysinfo page, mine also says v2.0, so you can see the descrepancy already.

    If you just got yours, chances are it is a v3.1, also, and is why Alchemy will not load. I am guessing that Linksys only prints the major version number and not the updates. It also appears that Linksys doesn't do a good job of keeping everything in sync, as far as labeling goes.

    No matter what I try, Alchemy will not load on mine. As I stated, I found the "released" version of Freeman and it seems to be working. I'd really like to try the mesh, hotspot, and OEM versions of Talisman, but they don't seem to be available.

    I agree, it is all so confusing.

  12. Morpheus

    Morpheus Network Guru Member

    Do not take any notice of what version number is in the sysinfo page it is Incorrect. Go by Serial Nombers.

  13. MagicBerthy

    MagicBerthy Guest

    Just to tell you I have a V2 router and get the same message than you, trying to upload the Alchemy 1.0 firmware...
    I have revert to linksys 4.20.6 but I miss the WDS...

    Any clue from anyone to have this firmware correctly installed ?
  14. polarisdb

    polarisdb Guest

    Last week I bought (2) WRT54GS's at Best Buy with serial numbers starting with CGN3 (v 2.0).

    One of them successfully flashed Alchemy 1.0 on the first try, and the other was bricked every time I tried to flash Alchemy even though I got a message stating that the upgrade completed successfully. The only Sveasoft firmware that I could get to work on the second unit was Talisman.
  15. kujoe

    kujoe Network Guru Member

    I have a linksys router model WRT54GS v.3 router. Is this really a version 3 of this model number? When I go to the linksys site they don't even have any downloads for it. They only have up to v.2x

    Anyhow, I tried to get alchemy 1.0 loaded onto it, the firmware upgrade said that it was successful, but then its just gone. It just bricks it. How can it say it was successful if it bricks it? Shouldn't it say unsuccessful? Then it only gives a Flashing power light and no wlan light. I tried multiple times and it bricked it each time. So I did the jumped pins 5 and 6 (yes 5 and 6 as 15 and 16 didn't do jack. pins 15 or 16 to the antenna didn't work either)to make it pingable and used tftp to replace with the original 4.70.6 firmware version from linksys.

    My question is, is alchemy compatible with my particular router or not? They list WRT54GS as compatible, but they don't list version numbers. Since Alchemy bricked my router, would talisman work? Can I trust it? I'm tired of fixing a bricked router... :p

    Any help is appreciated :)
  16. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    Yes talisman will work. The success message is generated by the cgi script and is not always 100% correct. I suggest when you flash, just sit back and relax. Usually you can tell it is really finished when the router's power LED stops blinking, or just wait for a minute or 2. There router sometimes takes a little longer to finish loading.
  17. kujoe

    kujoe Network Guru Member

    Well, apparently I can't upgrade to Talisman. When I try it gives me the error message "Upgrade are failed". I need some of the functionality that I can't get in the stock firmware. I guess I'm screwed, as I don't have enough money to get rid of this router and switch it for something else... any ideas anyone?
  18. grcore

    grcore Network Guru Member

    This is a key point. Just because the upload says "successful", let the thing sit for a while, preferrable until it reboots itself. The upload continues after the successful page.

    Let it sit for a few minutes!

  19. kujoe

    kujoe Network Guru Member

    Yeah, but I can't even upgrade to Talisman because it says "Upgrade are Failed".
  20. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    Skip the gui and use TFTP for Talisman to bypass the "upgrade are failed" message. Again, be patient, sit back and wait a while once you start the flash. It is important to note that Talisman is the only Sveasoft version after Satori which you can tftp(bin file size constraint).

    Sveasoft firmware is model specific for TFTP, the only difference is the code base lock if you are using "authentic" sveasoft files. I believe "Freeman" has removed this and can be used on any hardware model using the TFTP method.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice