Trouble entering into admin screen of router

Discussion in 'Tomato Firmware' started by mbourd25, Mar 22, 2007.

  1. mbourd25

    mbourd25 LI Guru Member

    Hi gang, need some help with a Linksys WRT54G-CA ver 3.0. Someone just gave it to me because it never worked. I try to go in so I can upgarde the firmware to tomato but to no success.

    I enter the admin page,, but I get the error that cannot find server. I tried the reset button, no success.

    Is their a way I can get into the router's admin pages or another way to flash the firmware to tomato?

  2. digitalgeek

    digitalgeek Network Guru Member

    you might have to follow the brick recovery instructions. there are several things you can try...

    if you have a red flashing light on the you router: try setting your IP to manually, then try to ping (If there is no lights at all, you may have other irrecoverable problems)

    If the ping is successfull than you can enter the following command at a (Win)DOS prompt tftp -i PUT code.bin

    code.bin can be a factory firmware or the Tomato firmware.

    after the tftp is successfull, resest you router. You should be able to access the routers config page. Goto to the administration section and clear nvram before configuring the router.

    if the ping fails you can try short pin 16 on the processor to ground(on the antenna block) (these pins depend on your model), reboot and try ping follwing the instructions above.

    failling all of the above you may need to look in to a "JTAG" cable. ("The Hairy Daughter" method)
  3. NateHoy

    NateHoy Network Guru Member

    Just to confirm on this - you pressed and held the RESET button for at least 30 seconds with the power on, right? What you are looking for is a full factory reset, not a simple "reboot" of the router, which a momentary push of the RESET button would give you.

    1. Power up the router (without any computers or Internet connected) and wait for lights to settle down a bit.

    2. Push in the reset button and count slowly to at least 30.
  4. mikester

    mikester Network Guru Member

    I'm afraid to ask why it's called "The Hairy Daughter" method... ;-)

    Just to add a note here for Natehoy, a while back ago I posted about a problem with the firmware not staying after reboot. Unit would reboot with the WAN light flashing.

    Turns out the unit was defective and after a LOT of BS from Linksys (i.e. on phone for days, took them a month to "cross ship" a new one, then they lost the one I sent back...) they finally replaced it under warranty. Left with a funny taste in my mouth...
  5. mbourd25

    mbourd25 LI Guru Member

    Hi gang, I tried to un-brick the router with your instructions and to no success. Is thei another way I could try to unbrick the WRT54G router?

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice