Trouble with BEFW11S4v2 upgrade

Discussion in 'Other Linksys Equipment' started by NetArch, Sep 15, 2006.

  1. NetArch

    NetArch LI Guru Member

    I know I should replace this wireless router, but this is for a non-profit...

    When I try to upload the image "befw11s4v3.2_v1.45.10_fw.bin" to an S4v2 wireless router, I get a message saying something like the image is corrupted (I don't have the exact message with me here at work). I tried downloading the file again from the Linksys website, but I got the same message.

    Is there an MD5 or SHA hash against the correct binary so I can verify my copy is good?

    I tried using both Firefox and IE to do it, but I didn't try tftp from the command line. Are there any known issues trying to apply the firmware from a browser rather than tftp?
  2. Beftus

    Beftus Network Guru Member

    By the looks of it you're trying to flash a BEFW11S4v3.2 firmware onto a BEFW11S4v2 router. I'm not sure but it could be you're barking up the wrong tree here, they could be incompatible...

    Upgrading through the web interface usually works for me (BEFW11S4v4 WRT54GLv1.1).
  3. mungewell

    mungewell LI Guru Member

  4. NetArch

    NetArch LI Guru Member

    It's the right version...

    Beftus, mungewell's right - according to the Linksys readme, it's good for hardware versions v3.2, v3, v2.1 and v2. I double-checked before trying it again because I was thinking the same thing. Of course, it's possible that Linksys' own documentation is wrong...

    mungewell - I get the same sum from md5sum.exe for win32, so I know that's not the problem. Like I said, I tried the gui approach using both FireFox ( with NoScript allowing javascripting from the box), and with IE 6.0.2900.2180.xpsp_sp2.050301-1519CO). Tonight I'll run down to the site and try using Linksys' tftp v1.255 from the win32 command line and see if it works.
  5. NetArch

    NetArch LI Guru Member

    Way to check hardware version?

    Is there a cgi bin file that reports the hardware version of this router? I did find a case where the mfg sticker had the wrong WAN MAC address, so I guess it's theoretically possible that this isn't v2 hardware...

    Or any visual clues on the motherboard if I take this puppy apart?
  6. NetArch

    NetArch LI Guru Member

    tftp from command line worked

    Well, I can't explain it other than tftp from the command line worked the first time I tried it. Go figure...

    Now if I can figure out why two of the three WAP11's in the network preriodically go to sleep...
  7. NetArch

    NetArch LI Guru Member

    Quick followup: tftp from the command line worked. No clue why the router-based tftp procedure didn't work, but at least I got the firmware loaded and running.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice