trouble with ssh and rdp

Discussion in 'Tomato Firmware' started by Ven0m, Feb 10, 2010.

  1. Ven0m

    Ven0m Addicted to LI Member

    I'm trying to access my home computer, which is behind WRT54GL running Tomato 1.27, and just can't do it.

    I've followed the instructions here:

    When I get to the part where I login with the "laptop", I hit connect, and nothing happens - no error, just a brief hourglass and then back to normal cursor with the option of hitting connect again.
    Occasionally I'll get an error saying I'm already connected to the host (since the laptop is trying to connect to itself).

    I then followed the instructions here:

    Same result as above.

    After all that, I tried simply forwarding port 3389 in Tomato... This didn't work either. I try to connect remotely, but get an error saying I can't connect.

    I do have remote assistance and remote desktop checked/enabled and at least one user has remote access. I'm running Windows XP Pro x64 SP2. How do I check if my remote desktop port is indeed 3389? Also, I have the windows firewall service disabled (since I use a different one), could this be causing problems?

    I'd appreciate any help with this.
  2. TexasFlood

    TexasFlood Network Guru Member

    Your PC firewall could be blocking access. I forward RDP on both the default port of 3389 as well as some alternate ports. I think the port is defined in
    If you run the following on the PC you're trying to RDP to, you should see listening and established connections on port 3389 and the ID of the owning process
    netstat -ao|findstr 3389
  3. Ven0m

    Ven0m Addicted to LI Member

    Thanks for your reply.

    I checked my firewall, and there were a bunch of rules. However, I added another one to explicitly allow incoming TCP for RDP (port 3389). I looked at that reg entry you posted and my RDP port is indeed 3389. I still can't RDP into my machine though...
  4. vibe666

    vibe666 Network Guru Member

    can you RDP to it from another machine inside your LAN?

    i.e. from at home, removing ssh from the equation,

    it's quite possible it's just not working at all for whatever reason, but not related to the ssh connection. you won't know for sure until you can confirm it's working locally for you.
  5. Ven0m

    Ven0m Addicted to LI Member

    Sorry, I should have mentioned... I can SSH into my router. It might not have been apparent from my original post.

    I just tried RDPing from LAN, and I am unable to do that. Same symptom, it attempts to connect, I get a brief hourglass, nothing happens, then I have the option of hitting the Connect button again.
  6. TexasFlood

    TexasFlood Network Guru Member

    Might want to try temporarily disabling the firewall and retest. If that works then you'd know it was the firewall and could concentrate on figuring out the proper rule. If that doesn't work, well, I don't think that helps a lot, but something to try, :grin:
  7. Ven0m

    Ven0m Addicted to LI Member

    Tried that, didn't work.

    Also have tried RDP'ing into other computers and it works fine. It seems it is just my home computer I can't connect to.
  8. TexasFlood

    TexasFlood Network Guru Member

    Did you try running "netstat -ao|findstr 3389"? Do you see something listening on port 3389?
  9. Ven0m

    Ven0m Addicted to LI Member

    I did try it, I saw nothing. There is a very long delay though (between me typing the command and hitting enter, and getting the prompt again).
  10. TexasFlood

    TexasFlood Network Guru Member

    Well that's weird. What if you just type "netstat -a", is there a delay? On my 32 bit Windows XP SP2 PC there is only a small delay on "netstat -a|findstr 3389" and none with "netstat -a".

    Also out of curiosity, can you ping that PC from the router or anything else on the LAN? The reason I ask is a PC here recently got some sort of worm and until I removed it one of the symptoms was that PC could connect to the Internet but did not respond to any connection attempts from the LAN or inbound port forwarding. Probably has nothing to do with it, just came to mind and thought I'd throw it out there.
  11. Ven0m

    Ven0m Addicted to LI Member

    No delay when typing netstat -a, things start showing up immediately.

    Can't ping it from the LAN, but I think that is because my firewall is blocking some ICMP stuff.

    EDIT: just checked Echo Reply Out in my Firewall's ICMP rules and now I can ping this machine from the LAN.
  12. TexasFlood

    TexasFlood Network Guru Member

    Well, if there is nothing listening on port 3389 then there is some sort of fundamental problem. If it ain't listening, it ain't gonna answer.
  13. Ven0m

    Ven0m Addicted to LI Member

    I checked my Terminal Service and it was started, but set to manual. I changed it to Automatic, rebooted, and saw it was "started."
    After that, I downloaded versions 6.0 of Terminal Services from MS, installed, rebooted. Still nothing listening on that port, however.

    Since this version of windows (xp pro x64 sp2) is basically windows server 2003 sp2, is it possible it has something to do with their "SNP" stuff? I saw a KB article about it but wasn't sure if it applies to me.
  14. vibe666

    vibe666 Network Guru Member

    i had a problem like that when i built a machine using a custom ISO i got off the net (think it was Tiny7, but not sure now, there's so many. :)).

    i ended up rebuilding the machine with a regular windows disk as i could never figure the problem out. it looked like everything should be working, it just didn't. i'm guessing that some part of the OS that RDP was relying on had been removed at some stage during the customisation of the installation.

    if you're running a custom built version of windows like that then maybe that's your problem?

    i'm running the regular version of windows 7 ultimate (x64) now on the same box and RDP is working fine on it both locally and via SSH. unless you can get it working locally though, it's never going to work via SSH.
  15. TexasFlood

    TexasFlood Network Guru Member

    Could be, not sure. I'm not familiar enough with that version of XP nor do I have a test platform to try things on. Now maybe once I get my vmware environment set up, :grin: , but don't think I'll be much help to you now. At least you know it's something on the PC side, almost certainly not Tomato related. So at least you're barking up the right tree now, so to speak, :biggrin: . Good luck.
  16. Ven0m

    Ven0m Addicted to LI Member

    Thanks for the help.

    The version of windows is a normal (non-custom) install.

    Ok a slight change now...
    When I do netstat -ano I see something listening on port 3389.
    However, when trying to RDP into the machine, I still get the exact same symptoms. Now I'm confused. Would this indicate a tomato/port forwarding misconfiguration or something similar?
  17. TexasFlood

    TexasFlood Network Guru Member

    If you can't get it to respond from another box on the LAN, that traffic is on the same subnet no port forwarding is involved. Only traffic coming in from the WAN is touched by port forwarding. Don't mean to sound like a broken record but still thinking it must be a problem on the PC itself if it can't be accessed from the LAN.
  18. vibe666

    vibe666 Network Guru Member

    ditto. get it working on the LAN first and it should work fine over SSH.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice