Troubleshooting internal switching of RT-N16

Discussion in 'Networking Issues' started by teredactle, Dec 31, 2013.

  1. teredactle

    teredactle Reformed Router Member

    Is there a way to troubleshoot and understand what's going on internally on the RT-N16?

    Up until 2 days ago, I was getting the speed I am paying for, 10Mbps. I have a TP-Link DSL modem, and the RT-N16 plugged into it, with various wired and wireless clients.

    Two days ago I started just getting 1Mbps from all the speed test sites. I connected my laptop directly to the DSL modem and my speed test was near 10Mbps. Connected the RT-N16 back, and 1Mbps, from wired and wireless clients.

    With the network, I get normal speed (laptop to NAS, NAS to media player, etc). Seem there is an issue on how the RT-N16 deals with the speed from the DSL modem.

    I'm running the latest Easytomato firware; it's awesome but I'm not familiar with tools to figure out exactly the issue here.

    My DSL modem TD-8616

    Downstream / Upstream
    SNR Margin
    :10.9 / 6.8db
    Line Attenuation
    :25.0 / 13.2db
    Data Rate
    :10304 / 792kbps

    Thanks in advance!
  2. teredactle

    teredactle Reformed Router Member

    So a bit more info. I have tried to isolate this issue further without any luck.

    I tried my portable Linksys router WRT54GC, and a friend's Dl-604. In both cases I wanted to connect those to the TP-Link modem and see if I can get the 10Mbps to the endpoints; however, neither of those routers could authenticate on PPoE to the DSL modem; very, very strange. These of course are very old routers, could the PPoE code not work? I think this is a standard, it's questionable why neither could connect over PPoE and I confirmed the correct login/pwd combination several times.

    Again, if I connect my laptop to the TP-Link modem I can connect over PPoE and when I run a speed test, I get near 10Mbps.

    One thing to note, is when I plug in my laptop to the DSL modem, I need to manually set the speed of the NIC to 10 Half Duplex, otherwise it won't auto negotiate properly (I believe this is the issue with the Linksys and Dlink routers - as the LAN light on the DSL modem never light ups for these, but on the RT-N16 it does light up).

    This is driving me nuts, short of buying a new RT-N16... does anyone have a suggestion please??
  3. teredactle

    teredactle Reformed Router Member

    So thanks for viewing, although I expected some sort of suggestion, not sure why noone bothered.

    In any case, I decided to replace the DSL modem after more troubleshooting; despite my laptop getting the right speed, the router was having issues with the DSL modem; put in the newer TP Link (same model , but v7), it resolved the issue. Weird but solved!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice