Trying to get Wireless Bridge To work .. can someone help?

Discussion in 'DD-WRT Firmware' started by LordBanshee, Dec 31, 2005.

  1. LordBanshee

    LordBanshee Network Guru Member

    Who can help me get a Client Bridge Working with a WRT54G using DD-WRT v23

    My main router (that has the internet connection) is a belkin 125 wireless G.

    I have tired every single how-to i found on the internet and i can not get it working at all. To me it seems that the WRT54G can not or will not connect to the belkin after everything is done and said.

    for example i have tired these (but also some others online)

    Anybody willing to help me out it would be great.

    this is how i want it to work

    -> = wired
    ** = wireless
    ... = same as above or below

    internet -> Belkin ** WRT54G ->computer1
    ....................... ** laptop1
    ....................... ** computer2

    My settings i tired most recently
    my main router the belkin IP is, SSID = Banshee

    in my WRT
    Setup/Basic Setup Tab
    -Wireless Steup
    ---Internet Connection Type = Disabled
    ---STP = Disabled
    -Network Setup
    ---Local IP Address =
    ---Subnet Mask =
    ---Gateway =
    ---Local DNS =
    ---DHCP Type = DHCP Server
    ---DHCP Server = Disabled

    Wireless/Basic Tab
    ---Wireless Mode = Client (also tired Client Bridge)
    ---Wireless Network Mode = Mixed
    ---Wireless Network Name (SSID) = Banshee

    I am tring to get the wired Connection(WRT) to work first. If i set the computer to DHCP as you would think that the belkin will give it an IP it never finds one. If i set and IP manually it only connects to the WRT with no internet.

    Also right now i am not useing any security to get this to work but once it is working i am using mac filtering.

    any help?

  2. cgondo

    cgondo Network Guru Member

    do you use the same channel?

    How aobut oging to the Site survey and do a site survey. Once it picks up the Belkin's wireless then there is a button called Join. Click it.
  3. jpstoppa

    jpstoppa Network Guru Member

    Under "Wireless" >> "Wireless Security" make sure you enter the right encryption method. Also under "Wireless" >> "Advanced Settings" change "Authentication type" to shared key. And boost your power a bit. I use a setting of 80 and the signal is great 3 floors down.
  4. Sumi

    Sumi Network Guru Member

    this is not "makeable". unfortunetly, if you put your wrt in client mode, it can only be connected on cable.. no wireless furthermore...

    however, when setting it to client mode, please use a netmask of instead of on the client side.

    oh and one more little thing: if you wish to stay on the same subnet with your belkini (192.1681.x), use client bridge mode, since client mode won't allow you to be on the same subnet.

    anyway nextime buy an accesspoint instead of a router:)
  5. cgondo

    cgondo Network Guru Member

    why do you need to use .128 mask?
  6. LordBanshee

    LordBanshee Network Guru Member

    i have been trying it with a cable only, basicly this:
    internet (wired to) belkin (wireless to) WRT (wired to) computer
    (*note* Did not buy the WRT for this purpose. It used to be my old router but if I can get it to work as wished, I can save some money right :) )

    Still doesn't seem to work. Is there any info I can post more to help you guys help me?

    1) There is no encryption
    2) Yes I hit the join button in the survey,
    3) Both channels are "6" and both SSID are "Banshee"

  7. Longs

    Longs Network Guru Member

    I got mine working as you described - My main router's a Netgear and my client bridge (WRT54G V4) is running DD-WRT generic mini and has an XBox plugged into it.

    I have both routers on the same subnet, both have DHCP enabled, are set as gateways. I set the IP address ranges (assigned to computers by the netgear) up to 128 and set the WRT to 129.

    Since the WRT will already be behind your Belkin's firewall, uncheck security features like "block WAN requests" and those types of settings.

    Mine's working with WPA-PSK
  8. LordBanshee

    LordBanshee Network Guru Member

    Maybe my Belkin doesn't like to work this way?

    It seems that the WRT can not link to the belkin. As the only time the WLAN blink is when i hit join (or reboot) and then it is always green.

    You think if it was connecting wirelessly it would be blinking some what :(
  9. Sumi

    Sumi Network Guru Member

    set belkini to, with an ip address of and set wrt to with an ip address of

    in status - wireless , can you see the client link?

    happy new year:) kind of, i'll never drink again:) omg
  10. LordBanshee

    LordBanshee Network Guru Member

    I believe i tried that when you said it in your last post but I'll try again later.

    In the Status/Wireless/Survey I see my belkin. and i hit join and this is where i think nothing happens.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice