Trying to use wrt54gL as client bridge for xbox360

Discussion in 'Tomato Firmware' started by taiketsu, Dec 16, 2008.

  1. taiketsu

    taiketsu Addicted to LI Member

    I know there have been other posts about this, but all of them had slightly different issues or configurations that couldn't help me.

    Anyhow, I recently purchased a D-link DIR655 as my router, and now I'm trying to convert my older wrt54gl into a wireless bridge for my xbox360 in the next room.

    After configuring the wrt54gl by hardwiring it to my PC, I am able to use it to connect to the internet, by way of a wireless connection to the DIR655. The problem is when I disconnect the wrt54gl from the PC, and connect my PC back to the DIR655, the wrt54gl is no longer found on the network. To be more specific, I tried connecting to the but it wasn't be found.

    Furthermore, when I move the wrt54gl to the xbox360, I can't establish a connection.

    Here is how I configured the wrt54gl:

    I have Tomato 1.22 installed and reset to default settings. The router is set on "Wireless Client" mode, with WEP 64-bit. I have the desired key typed into key 1.

    DHCP server is unchecked. The signal is configured as "Mixed".

    These are the only changes I've made, but I'm not really sure what else I should change to get this to work. Please HELP!! I'm a newb at this and I've been up 2 nights trying to get this working!
  2. taiketsu

    taiketsu Addicted to LI Member

    More info:

    On the DIR655 the settings are as follows:

    Wireless Settings:

    Wireless Network Name: My SSID
    Mode: Mixed 802.11n, g, and b
    Auto Channel Scan enabled
    Wireless Channel: 6 - 6.437GHz
    Channel Width: Auto 20/40Mhz

    Wireless security mode: WEP 64bit
    Key1: 17B799CDB7

    Network Settings:

    Router IP:
    Subnet Mask:
    Device Name: dlinkrouter
    DNS Relay is enabled

    DHCP Server is enabled
    DHCP address range: to
    Broadcast is enabled


    Connection Type : DHCP Client
    QoS Engine : Active
    Cable Status : Connected
    DNS Status : Online
    Network Status : Established

    MAC Address : 00:04:4B:06:7C:97
    IP Address :
    Subnet Mask :
    Default Gateway :
    Primary DNS Server :
    Secondary DNS Server :


    MAC Address : 00:21:91:E5:E2:D9
    IP Address :
    Subnet Mask :
    Auto IP Address:
    Default Gateway :
    Primary DNS Server :
    Secondary DNS Server :
    DHCP Server : Enabled

    Wireless LAN

    Wireless Radio : Enabled
    802.11 Mode : Mixed 802.11n, 802.11g and 802.11b
    Channel Width : 40MHz
    Channel : 1
    Secondary Channel : 5
    WISH : Active
    Wi-Fi Protected Setup : Enabled/Configured
  3. taiketsu

    taiketsu Addicted to LI Member

    For the wrt54GL under Status>overview:


    MAC Address: 00:1D:7E:E7:8E:7C
    Connection Type: DHCP
    IP Address:
    Subnet Mask:
    MTU: 1500


    Router MAC Address 00:1D:7E:E7:8E:7A
    Router IP Address:
    Subnet Mask:
    DHCP Disabled


    MAC Address: 00:1D:7E:E7:8E:7C
    Wireless Mode: Wireless Client
    B/G Mode: Mixed B+G
    Radio Enabled
    Security: WEP
    Channel: 1 - 2.412 GHz

    The configuration for the wrt54gl under Basic>Network

    WAN / Internet

    Type: DHCP
    MTU: Default 1500


    Router IP Address :
    Subnet Mask:
    Static DNS: All
    DHCP Server is unchecked


    Enable Wireless is checked
    MAC Address 00:1D:7E:E7:8E:7C
    Wireless Mode: Wireless Client
    B/G Mode: Mixed

    Channel: 6 - 2.437GHz

    Security: WEP 64-bits

    Key1: 14B799CDB7
  4. taiketsu

    taiketsu Addicted to LI Member

    Multiple posts on wireless bridges have mentioned disabling DHCP. I went in the linksys to change to "DHCP" to "Static" in the Basic>Network, but I completely lose my connection.

    I used the same IP address the dlink was listing when I was using the DHCP setting.

    Any help would be much appreciated. If I'm asking the wrong questions, please feel free to direct me to a post or article. I'm all out of answers.
  5. bripab007

    bripab007 Network Guru Member

  6. taiketsu

    taiketsu Addicted to LI Member

    That has already been done. I do appreciate the reply, though.

    As I mentioned before, I can run the linksys as a wireless client after configuring it on my PC. I know this because I can connect to the internet with my PC hardwired to the linksys.

    The problem is when I unplug the linksys from my PC, and plug it into the Xbox360, I can't get a connection going.

    And when I hook the linksys back up to my PC to reconfigure through, the browser does not recognize the address unless I reset the whole thing.

    When I read multiple guides, this sounds like such a simple process but it has been anything but that. What am I missing here?
  7. bripab007

    bripab007 Network Guru Member're LAN appears to be on the subnet, as dictated by your DIR-655, but you've configured your WRT54GL to be on the subnet...try giving the WRT54GL a 192.168.0.x address (, maybe?). This will then be the address of the WRT54GL's web gui, not
  8. taiketsu

    taiketsu Addicted to LI Member

    I tried doing this, earlier, but I didn't experiment any further because I couldn't get back into the wrt54gl's tomato gui after making the change - the browser would not recognize the new address.

    I get a message about releasing my computer's dhcp ip, or something like that while it's resetting, but I lose my connection after making the change.
  9. taiketsu

    taiketsu Addicted to LI Member

    Okay, I just tried your suggestion again, and this is what the gui displays as it resets the ip:

    The router's new IP address is You may need to release then renew your computer's DHCP lease before continuing.

    When the waiting period ends, the browser attempts to reconnect to the new ip address but nothing comes up. Also, I lose my connection the network.
  10. bripab007

    bripab007 Network Guru Member

    Okay, well, lemme get this straight...your main router is the DIR-655, correct? And it's acting as your LAN's DHCP server, assigning DHCP licenses on the subnet, correct?

    Do you have something else on that subnet that already has a lease for the address? If so, then you'll have an IP conflict between whatever that device is and the WRT54GL that you're trying to get on the LAN as a client. You need to assign an IP to the WRT54GL that is not already taken.

    In fact, instead of assigning a static IP to the WRT54G, just let it get a DHCP'd license from the DIR-655, so it'll probably take something like or whatever. That's where you'll need to go to access the web GUI.

    The other thing to do is to temporarily turn off the wireless encryption on the DIR-655 (and the WRT54GL client device) to simplify things until you get this figured out (why are you using WEP encryption, anyway?).

    EDIT: One last thing: I just remembered, there might also be a setting on the DIR-655 by default that segregates your wireless clients from your wired. After you try the above suggestions, you may want to look into that.

    EDIT #2: I just noticed in your second post (that's what you get for posting so much info. that I didn't feel like reading all of it :biggrin: ) that your WRT54GL got an IP of from the DIR-655, so that is where you would've gone to get to the web GUI of the WRT54GL.
  11. tievolu

    tievolu Network Guru Member

    That's because your PC is now on a different subnet from everything else. You need to do what Tomato tells you and release/renew your PC's IP.

    If you've configured the PC statically, change the IP to something in the new subnet.

    If you're using DHCP and Windows you can open up a command prompt and issue these two commands:

    ipconfig /release *
    ipconfig /renew *

    Or you can right click on the connection icon in the systray and click "repair".
  12. taiketsu

    taiketsu Addicted to LI Member


    Not that I know of. The setup I'm trying for consists of a PC directly connected to the main router (DIR655), which is supposed to wirelessly connect to the Xbox through the linksys configured as a wireless client.

    Now, for configuration and testing purposes, I have the PC connected directly linksys as wireless client, which gets an internet connection through the DIR655.

    According to the DIR655 gui's log, this is exactly what is happening.

    I forgot to mention this, but I have temporarily disabled encryption. If not WEP, which encryption should I use? I only picked WEP 64bit because I read somewhere that less encryption equals less lag. Please correct me if I'm wrong.

    Hmm, I'm not sure where to look for this one, but I've spent so much time on this, I might as well. Do you have any clue what this setting is called or what category is might be under?

    Sorry for posting so much info, but I'm a newb at this so I didn't even know where to start! I thought posting more info would be better than not posting enough. Thanks so much again for reading through all my crap trying to help.

    According the the DIR655 gui, the ip is assigned to PC. At one point, when my linksys was hardwired to the PC, the DIR655 gui assigned the linksys a ip. I tried typing this address into the browser but it sent me straight to the DIR655 gui.
  13. taiketsu

    taiketsu Addicted to LI Member

    Thanks for the reply. I tried your suggestion, and followed tomato's instructions before pressing the "continue" button. Cmd prompt lets me release the ip, but it can't renew.

    I received this message:

    An error occurred while renewing interface
    Unable to connect to your DHCP server. Connection has timed out.
  14. tievolu

    tievolu Network Guru Member

    You could set the IP statically to a 192.168.0.x address, and then at least you could check the bridge WRT's GUI to try and see what state it's in with regards to the link to the other router. Without checking the GUI you can't tell whether this is a problem with contacting the DHCP server, or a problem with the bridge link itself.
  15. bripab007

    bripab007 Network Guru Member

    Yeah, I forgot that when you have the thing in wireless client mode, it is going to to actually have a couple of IP addresses, one for the WRT and one for the device connected to it.

    I would probably still recommend giving the WRT a static address like (outside the .100-199 range reserved for DHCP clients), as then you'll always know what it is, rather than having to guess or check.

    I've also got a DIR-655, but I'm using it as a gigabit switch/802.11n wi-fi access point, with my Tomato'd WRT54G as my main router/DHCP-DNS server/etc. I've never had any problem connecting my DD-WRT'd Fonera running wireless client mode to the DIR-655, though, and I'm using WPA2/AES encryption (this is the type of encryption you should be using, by the way).

    So, with your PC connected to nothing else but the WRT54GL in wireless client mode, you should configure Tomato to use for its static IP, turn off DHCP server...and then...ya know should be using Wireless Ethernet Bridge mode, not Wireless Client mode. I'll have to go back and re-read what you've tried so far, and I apologize for not being more clear myself because I never use Wireless Client mode, only Wireless Ethernet Bridge mode, but I mistakenly use the two terms interchangeably sometimes.

    I bet all your problems go away if you do what I've just described.

    EDIT: This first paragraph explains the difference (using DD-WRT's parlance, where they say "Wireless Bridge" instead of "Wireless Ethernet Bridge" and "Client Mode Wireless" instead of "Wireless Client"):
  16. taiketsu

    taiketsu Addicted to LI Member

    Are you referring to the WAN ip or the router ip? I attempted to change both statically but adjusting either results in no connection.

    When I change the WAN ip to static instead of DHCP, I lose my connection to the network, but I can still enter the gui. I've tried to change the wan ip to the same ip the main router assigned when the linksys was on DHCP, but it doesn't seem to like the static setting at all. I've left it as DHCP under bripab007's suggestion so I can at least connect to my network from my PC.

    When I change the ROUTER ip from to 192.168.0.x, I lose my connection to the network, and I can't access the gui with the newly assigned address. I have to hard reset the linksys to regain access. As I mentioned above, I tried releasing and renewing the dhcp during this process but to no avail.

    I'm starting to get the feeling that this is a problem from the xbox's end. When I test the connection using the Xbox, it fails to detect the network with the linksys plugged in as a wireless client. But when I connect the linksys to my PC, it can connect perfectly as a wireless client with the initial settings I've described. However, my xbox does connect to a hardwire ethernet connection just fine, so I've eliminated the possibility that the problem is in the hardware or wires. All this leaves is the configuration.

    Of course, I've tried to detect my network with Xbox's default "automatic" network settings. Then I tried manually assigning an ip (, gateway (, and subnet ( to the Xbox. That didn't work, either.

    I, then, tried to use to configure port forwarding for the xbox in the DIR655 by opening tdp 3074 and udp 88, 3074, but that didn't work. I even tried adding that to the DIR655's DMZ. That hasn't worked.

    Any other suggestions?
  17. bripab007

    bripab007 Network Guru Member

    It's not a problem with the Xbox, as I've used use Wireless Ethernet Bridge mode to connect 360 to my DIR-655 w/o a problem.
  18. taiketsu

    taiketsu Addicted to LI Member

    My goodness! You pegged the problem bripab007!! It was a complete breeze after I changed that one setting.

    I only used the Wireless Client mode because several DD-wrt tutorials seemed to suggest that this was the correct mode to use, as the word "client" seemed to be thrown around a lot.

    I'm accessing the WRT remotely but my signal strength falls in the low 30's. I tried raising the transmit power to see if that would make a difference but that doesn't seem to help. The WRT is about 25ft from the DIR, separated by a wall and a closet full of clothes. I'm just wondering if this is this the signal strength I should expect?

    Thank you soooo much for your help and patience for reading through my mess of a post.
  19. bripab007

    bripab007 Network Guru Member

    My WRT54G is right next to my DIR-655 wi-fi access point, and Tomato reports a Received Signal Strength Indicator (RSSI) of -27dBm, a noise of -90dBm for a quality of 64.

    My neighbor's wi-fi router is picked up in Tomato with an RSSI of -84dBm, a noise rating of -88dBm and a quality of 4.

    So, if your RSSI is in the low -30s, I don't think there's anything wrong with that (the lower the negative number of the RSSI, the better, I'm assuming).
  20. taiketsu

    taiketsu Addicted to LI Member

    My approximate readings are as follows:

    RSSI -63 dBm
    Noise -95 dBm
    Signal Quality 32

    I guess the numbers just seemed low, but the most importantly, the connection is stable and reasonably fast. Thank you, again, for answering all my questions. Please seek me out on xbox live some time. SN: Opposing thumbs
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice