Turning a WRT160N into a WAP?

Discussion in 'Cisco/Linksys Wireless Routers' started by phodge, Dec 22, 2008.

  1. phodge

    phodge Addicted to LI Member

    My WAP54g running HyperWAP for several years finally died, so I saw an opportunity to upgrade to something with better security and N technology. Before purchasing the WRT160N, I read the user guide and felt like I could disable DHCP and NAT and emulate a WAP. So far, it's not been that simple. I already have a Sonicwall TZ150 firewall (FW) so don't need most of the WRT160N's functionality.

    Below is a simplistic view of my network. I have a switch hanging off the FW with two other PCs, VoIP, NAS, and a printer that are not depicted:

    CableModem > FW > WAP > Laptops & Wii

    I have static IPs for all network devices and all are mapped to MACs within the FW.

    So far, I've not come across that magical combination to turn the WRT160N into a WAP. I can access the unit's setup pages via wifi and local network, but still get an internal IP from that unit, not from the FW.

    Ideally, I want the FW to provision IPs to keep everything on the same network. Can I do that with this model?

    Thanks in advance for whatever help you can provide.
  2. ifican

    ifican Network Guru Member

    log into the 160 and makes its lan ip in the range of the FW, make sure the dhcp server is shut off, plug the FW into a lan port on the 160 and not the wan port. This should give you the functionality that you are looking for.
  3. phodge

    phodge Addicted to LI Member

    That worked! Specifically, I:

    - Disabled DHCP Server
    - Disabled NAT
    - Disabled Dynamic Routing
    - Left Internet Connection Type "Automatic (DHCP)"
    - Specified a static IP that was already in the FW with the appropriate MAC for the LAN.

    There are three MACs showing in the WRT160N. I used the one for the LAN, though the FW allowed connections for the router and wireless MACs as well. Strange.

    I have one minor issue with the laptops not using assigned static IPs in the FW. They're using IPs from a dynamic range, but the Wii console is using as assigned static IP. Perhaps a FW reboot will fix this.

    Thanks again for your help!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice