Two problems with Wrvs4400n, please help me.

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Dinon, Dec 3, 2007.

  1. Dinon

    Dinon LI Guru Member

    1. I have problem with high frequency noise. My had is going to explode. I've returned 6 routers to my resseler and all were noisy. This seventh too but reseller does not want take it back more.

    My latest model is mnufactured 2007.07.15.

    I think, it has to do something with the routers overheating because when the router is cold, there is no high frequency noise.
    I could try put some heatsinks on some chips and other components in routers box. Do you think would it be possible to do it? Because I do not want disassemble it now (I'll try return it one more time), could anyone tell me, what size of heatsinks can I put into routers box, if any?

    2. After upgrading to firmware 1.1.03-ETSI on my WRVS4400N. I have FTP problems too. I've tryed reset router to factory defaults, reflash firmware, I've played with QOS, rebooting and I have no solution. I cannot use older firmware because it was not stable.

    Pleas, help me.:sick: Thank you very much.
  2. DocLarge

    DocLarge Super Moderator Staff Member Member

    What high frequency noise are you referring to? Nothing like this has ever been reported before. A little more clarification about this problem from your testing would help...

    Regarding your other problems with this unit, you seem to be suffering from the "linksys gremlins." :) For some reason, just holding the reset button doesn't set the unit back to factory default as expected. As a result, little "anomalies" start showing up in your configuration (i.e., reset button doesn't clear configuration, wireless dropouts, dhcp doesn't work, etc...) and you keep going through a cycle of "factory resetting" but it never seems to fix the problems...

    Here's my approach:

    1) Disconnect "all" cables (including power)
    2) Hold down reset button, plug in power and keep holding reset button (at least 60 secs; pressing the reset button repeatedly for 10 -15 seconds can also help expedite clearing of memory)
    3) When system comes back up, configure router "via" ethernet cable; assign the computer's NIC the default ip scheme of 192.168.1.x; go into wegui and select "factory default"
    4) When system comes back up, configure router "via" ethernet cable; assign the computer's NIC the default ip scheme of 192.168.1.x again; set your configuration for the router
    5) If dhcp server issues an ip address, the router is functioning properly; if it cannot issue an ip address, the configuration is still error prone
    6) Repeat steps 2 and 3 until router can issue addresses via dhcp
    7) Once the router is issuing dhcp addresses, the router "should" be functioning and free of errors; now you can reconnect devices to WAN and LAN ports.
    8) Change the ip address from default ip scheme to whatever scheme you normally use

    Using the above method, my WRVS4400N has been running 7 days, 22hrs, and 43 minutes with no wireless dropouts, ftp errors, or voip loss. Additionally, the dhcp server works without any issues either. I've even been streaming "youtube" and doing some torrent downloading, to include large LAN transfers; still going strong.

    Try this before you return it :)



    I've just reset my WRVS4400N to try reverify it works. As of now, the router is issuing ip addresses via dhcp.
  3. Dinon

    Dinon LI Guru Member

    Thank you for your reply but it did not help me. FTP problem still exists with firmware 1.1.03. I cannot download/upload from/to interrnet, file listing and file transfering to cca 2090 bytes is OK than data connection is interrupted.:angry: Firmware 1.0.16 is OK but WIFI is unstable.

    Here is link with dscussion about high frequency noise but no solution:
  4. DocLarge

    DocLarge Super Moderator Staff Member Member

    I've just sent this information off to our developer point of contact to see what he knows about this. I've got a 1st generation WRVS4400N and I've never experienced this phenomenon. Still, that obviously doesn't mean the problem isn't real, it just makes me glad I got mine earlier :)

    Being that this whining is significant, there's always a possibility this flaw "may" be linked in some way to the other woes you're having with it...

  5. scuba4

    scuba4 LI Guru Member

    I have the same problem with FTP since the new firmware is flashed. I made the initial procedure 2 times, the problem consists.

    Greetings from Vienna
    Leon Berger
  6. DocLarge

    DocLarge Super Moderator Staff Member Member

    I got a reply back and the "linksys development team" (not linksys tech support) is aware of the problem. :)

    My only guess here is that the people suffering from this whining and ftp problem must be related to the most recent batch of wrvs4400n's coming out. I got one of the first ones that came out and I'm not experiencing any of those symptoms.

    As far as the process I've outlined in one of my earlier posts, I've repeated the procedure. I had a wireless dropout in 4 hours the first time, but after redoing the following steps, I've been up for 24hrs so far with no problems using my VOIP (vonage), FTP, or torrentz. I'm getting ready to download a 12GB torrent to see how it holds up. I'll let you know...

  7. Dacsman

    Dacsman LI Guru Member

    My unit has the same issue, there is a high pitch whining noise that emits from the unit. I have seen complaints about this problem on other web sites. Thankfully my unit is far enough away from me I do not hear it.
  8. DocLarge

    DocLarge Super Moderator Staff Member Member


    I'm still downloading right now and there is no whining coming from my wrvs4400n even though I'm downloading, using the voip router (rt31p2) I have attached to it, along with ftp'ing into from my other internet connection. I've yet to here a "peep" out of it with all the thrashing I've got going on. If I get right next to it, all I'm hearing is a "barely" audible hiss, nothing more...

    I think we may have to chalk up the problems you guys are having as a round of "shoddy" worksmanship as of late :(

  9. Dinon

    Dinon LI Guru Member

    Nonfunctional FTP transfer is only a firmware problem so it is no so bad. But that noise is tragedy.:mad: I tryed 7 routers and all were noisy. This last piece is a little better. At least I can find a place in my home for the router where I do not hear it from.

    P.S. DocLarge, thank you for your infos directly from linksys developers.
  10. BumMan

    BumMan Guest

    I'm having the exact same FTP problem since upgrading to the new firmware.

    This router costs a lot of money and is marketed as a business router. I've had various problems with this since I purchased it 2 weeks ago. This is totally unacceptable for a product such as this.

    Linksys and Cisco both need to get their act together. The only thing I can think of is that they're outsourcing their programming to India and it's causing these problems.
  11. DocLarge

    DocLarge Super Moderator Staff Member Member

    Do you guys have serial numbers for your routers, or better yet, how about version numbers? I want to run these by the development team, if possible...

  12. Dinon

    Dinon LI Guru Member

    My Wrvs4400n has this sn: so8107502465

    P.S. I am already a little nervous because when I need FTP I must revert to firmware v1.0.16 but there is unstable WIFI so I cannot stay with it so I flash back to v1.1.03.:mad:
  13. scuba4

    scuba4 LI Guru Member

    SNR: SO8007402104, manufactured 04/07
  14. swiego

    swiego LI Guru Member

    I have the same high-pitched whining sound when the router has been on for more than a few minutes. I've seen it mentioned on several other forums, just not so much here, but it's definitely real and exists. It's a pain when you sit next to it. It's been this way since I got it, but my expectations of this product have been so low that I hadn't even bothered to write about it when more basic things don't work.

    My serial # is SO8006804564 and I think it's one of the earlier models too.

    As an aside, I've had terribly unstable wifi since upgrading the firmware. It just sort of bugs out every hour or so, then comes back a couple of minutes later. Direct connection over gigabit are completely unaffected, but all wifi connections (regardless of device connecting to it, from different laptops to a PDA to a iPhone) just die.
  15. Toxic

    Toxic Administrator Staff Member

    if any of you are concerned I would honestly raise a call with linksys and see if you can get replacement units under warranty/RMA terms.
  16. Dinon

    Dinon LI Guru Member

    Do anyone know whether it will be released a new firmware for wrvs4400n in the near future? If no, I think I will have to return my router because I strongly need functional FTP connections.:angry:
  17. goozerin

    goozerin LI Guru Member

    i have the same problem with my nas ftp server behind the router
    port forwarding to ftp ports are on (single and range port forwarding) and if i want connect via internet to my ftp server it takes a long time and then come the ftp login window and after i can see the folders but if i want download a file i get a permission denied.........if i switch the router firewall and ips off all is ok

    damm linksys has so good routers but the firmware isnt good sorry i like dd wrt but there is no chance to get this fw for wrvs4400 :-(
  18. DocLarge

    DocLarge Super Moderator Staff Member Member


    I've sent this link to one of the developers to see if they can ask questions regarding the manufacturing date of your 4400n's to one's manufactured prior to yours. Swiego sent me a PM saying that he's tried the reset procedure I've listed and is running alright so far; I'm waiting to hear back from him.

    As for me, I'm using ftp without fail. I'm using Ipswitch FTP Server software and it's functioning as expected (good). I'm attaching a shot of my port forwarding and you'll see the forwards I have for my ftp. I was using the ftp on my Nas at one point and it worked fine also. I'll set it up again over the weekend and see if I can replicate it, because there was a point where I could also log into the ftp but I couldn't access "certain folders" and this was based on behavior of the Nas and "not" the router...


    Attached Files:

  19. goozerin

    goozerin LI Guru Member

    i do the same config in my port forwarding settings but i can connect to my ftp server but i cant download any files "permission denied" but has all rights in my nas system?? i use the nas from synology 107j.

    with my dlink router and port forwarding 20-21 all is ok i can connect and download with the same user only wrvs4400 has you have firewall ddos protection and ips on??

    and i found out if you make some configs on the router via wlan sometimes the router didnt take the configs it is better if you use a wired connection for config the router :)

    ok maybe the next fw will be better.....:)

    IT Systemengineer Ba. of Science, MCSE, CCNA,CNA next CCNP
  20. Dinon

    Dinon LI Guru Member

    I am extremely disappointed with Linksys now. I'll give them a chance to repair FTP problem to the first week of 2008. If there will be no solution for me, I'll return my router and I try it with another manufacturer. I've never had so big problems with any network hardware like with this Wrvs4400n. I work with networks a few years now. It is my seventh Wrvs4400n which I will have to return probably. :angry: I think it could be the best SOHO or medium office router in the world but the firmware must be much better.
  21. goozerin

    goozerin LI Guru Member

    yep this firmware sucks also for me.........i think dlink has also good 300mbit routers for a low price and the fw is really good :)

    in dd wrt board i saw that maybe brainslayer will support also wrvs4400n routers with his dd wrt open source firmware so maybe we wait a little bit :)

  22. DocLarge

    DocLarge Super Moderator Staff Member Member


    yes, I have IPS, DOS and the firewall enabled as well. Again, I'm using a "software ftp." I've been playing with quickvpn most of the afternoon so I haven't switched ftp services over to my NAS yet. That will be next...

  23. swiego

    swiego LI Guru Member

    My wireless connection has stabilized since doing the reset procedure doclarge posted elsewhere. At least the router is stable now. I have not had any FTP issues.

    I'm still struggling to get QuickVPN to work and wireless transfer performance is still incredibly slow so I can't say I'm terribly happy with this router still.
  24. DocLarge

    DocLarge Super Moderator Staff Member Member


    just for giggles, try quickvpn 1.0.28 and see what that does. I'm finding this version to be the most consistent. Wireless transfers for me are quite fast with this router. I can move a gigabyte of information in only a few minutes. Outside of its little quirks (having to fight resetting it), it's much more stable now.

  25. swiego

    swiego LI Guru Member

    I tried it and made some progress with XP SP2 though Vista is still very skittsh. It gets stuck during authentication more often than not. I've decided to call it SlowVPN in light of close to a year of dealing with this program; anything with the limitations and headaches this thing forces upon its uses does not deserved to be called Quick anything. I'm also struggling with SlowVPN's not passing of netbios packets, and its poor support of Vista long after every other VPN system I use has stabilized their clients for the new OS.
  26. DocLarge

    DocLarge Super Moderator Staff Member Member

    By design, quick/slow vpn has never passed netbios traffic :( From the sign of things, it looks like it's not going to be addressed anytime soon...

  27. scuba4

    scuba4 LI Guru Member

    I made die initial procedure during the last 2 hours, after setting up the router again (and again and again...), the router seems to work correctly, but if I try to send or receive a file via ftp, the transfer was failed.

    Sometimes I cannot get a directory listing from the webserver, sometimes I get one, but a up- oder download is not possible.

    After changing the router to a D-Link DI-524, the ftp transfer (up- and download) was ok.


    Greetings from Vienna
  28. DocLarge

    DocLarge Super Moderator Staff Member Member


    what firmware version are you using?
  29. scuba4

    scuba4 LI Guru Member


    I tried many hours today to get a ftp transfer with with Linksys router, no way :mad:
  30. Pallieter

    Pallieter Guest

    FTP transfer problem

    I connect using PASS and send a STOR command, there is some traffic (the the file is created with 0 bytes), than I get the 150 back and the big wait starts ... no result. If I connect my PC without the router inbetween, that problem is not there.

    My WRVS4400N currently has Firmware Version: V1.1.03-ETSI on the STAR 9202.
  31. Dinon

    Dinon LI Guru Member

    I have exactly the same problem and I think there is no fix for it now. At least I cannot do anything to repair it.:angry:
  32. scuba4

    scuba4 LI Guru Member

    Buy another router (D-Link or Netgear) :wink:
  33. blake_

    blake_ LI Guru Member

    I would seriously reconsider your Netgear suggestion.
  34. Dinon

    Dinon LI Guru Member

    I think I'll return it after the holidays and try D-Link.:sad:
  35. Painless

    Painless LI Guru Member

    same here

    I cannot use FTP as well (firmware 1.01.03)...
    (I've tried all posted 'solutions': resetting, restoring factory settings, unplugging power for a long time etc. etc).

    And my router makes the VERY VERY annoying high pitch sound as well..
  36. DocLarge

    DocLarge Super Moderator Staff Member Member


    I'm at a loss. I don't have any of these issues so we can close the book on this one because I'm convinced this problem resides with the latest WRVS4400N's. I'm using FTP right now to access the ftp share on my Netgear ReadyNAS NV+ with "zero" issues.

    I think I may spring for another one next month to see what this "whining" noise is you guys are talking about...

  37. swiego

    swiego LI Guru Member

    Well I can replicate the FTP issues now and I also have the high pitched whining. I think mine is one of the early, early batches, its one year anniversary is just days away. So I don't think the issue is with later batches having problems. Rather, it's probably more a matter of doclarge having the only functioning wrvs4400n ever made. You should sell yours on eBay as a freak copy that actually works, you could make thousands :)
  38. DocLarge

    DocLarge Super Moderator Staff Member Member


    I may ship it out to the highest bidder. :)

    I did a reset the other day for posterity sake and it's rolling. How about this; maybe I should make a copy of my config and email it out to some of you guys and then check the differences. Howsabout that?

  39. Painless

    Painless LI Guru Member


    I don't think that will solve it, since I have tried Ftp'ing even after a clean reset to factory defaults, holding the reset button for >60secs etc. and it didn't even ftp with those minimal (factory) settings.. I reverted back to version V1.00.16, and ... Problem solved..
  40. DocLarge

    DocLarge Super Moderator Staff Member Member

    Has anyone else reverted back to 1.0.16 yet and seen if the FTP problem still exists other than painless?

  41. Dinon

    Dinon LI Guru Member

    Yes, I've tryed firmware v1.0.16 and FTP was OK. But I cannot use it because WIFI was unstable.
  42. Painless

    Painless LI Guru Member


    I've tried it 2 times.. each time the same result: 1.01.03 = No FTP, back to v1.0.16 = FTP works perfectly
  43. Reby

    Reby LI Guru Member

    Hi guys,

    I thought I would chip in with a couple of comments on this thread. I was actaully looking for some FW release info, when I came across this discussion.

    Good new is, FW is on its way for the WRVS4400N. I have a mail in my inbox from Linksys saying that FW for this device is high prio and the aim was to post it before 2008. My dealings with Linksys cirlced around the 1.01.03 release and teh DHCP problem, many have experienced, when no cable client is online. In any case, chances are the FTP issue may also get fixed?

    Second, the noise. My router emits the same kind of noise, it is a high-pitched noise at around 15 KHz. I have the same problem with my charging station for the Logitech diNovo Edge keyboard I am using to write this message. The answer is capacitor or chip build quality. I have heard this noise coming from many laptops, chargers and the 4400N router in particular. As supplys and vendors change over time, it is not strange that some "old" shipments of this product do not exhibit the symptom.
    There are 4 solutions - 1) get a replacement and get lucky (seeing someone has tried 7 boxes, chances are slim). 2) get a 4400N after Linksys identifies the component and makes a rev. 2. 3) change brand (like some of you have done). 4) live with it.

    I am going for option 4 for the moment, because I like the router and the functionality. There are issues (DHCP, FTP and sound), but I am betting on FW fixing teh first two in teh near future. In regards to the noise, I am waiting to see what comes around the curve from Linksys.

    I hope this is of value, in any case I am looking forward to that new FW!
  44. DocLarge

    DocLarge Super Moderator Staff Member Member


    This firmware is still under development. It was supposed to be due earlier this month, but I'm guessing the holiday's took priority :)

    It won't be available as a beta until after the "group" has crushed it...

    We'll let you know...

  45. Girion

    Girion Guest

    I have the same whining problem.

  46. swiego

    swiego LI Guru Member


    We got fed up. The constant wifi dropouts during very, very expensive online training yesterday was the last straw. The WRVS4400N was tossed in the trash (literally) and replaced with a $59.99 router from Best Buy, a DLink type. It's wonderful, no dropouts, no high pitched whine, every feature works as advertised. All I can say is that it's going to be great, being able to spend more time working and less time troubleshooting the most unreliable, undependable piece of equipment in the office.
  47. DocLarge

    DocLarge Super Moderator Staff Member Member


    I'll take that WRVS4400N for observation if you still have it...

  48. rhody401

    rhody401 LI Guru Member

    Any word on the new firmware?

    This is killing me. :( Have had 2 of these in service for more than 2 months now, and cant ftp.

    Is there a beta - do you want more folks testing the beta?

  49. goozerin

    goozerin LI Guru Member

    i like linksys routers but the fw of wrvs4400n is really buggy. the wrtg54gl router from links. is really better.

    first i have a wlan dhcp problem. every time i start my pc with wlan i dont get a ip from my router. then i put a cable into it and what happen after i get a ip for my cable?? i get a ip for my wlan :)

    hope the next fw will be better. any news when the new fw is released?

    my ftp works only if i place my nas in dmz.

  50. Reby

    Reby LI Guru Member

    I got to agree with rhody401 - 2.5 months have passed since the "FW from Hell" was posted.

    One might understand that this particular router is not the highest priority for Cisco, but customer size and impact needs to be evaluated against badwill.

    DocLarge, you seem to know a lotta stuff - any word from the rumor mill?
  51. Aviator256

    Aviator256 LI Guru Member

    Mine has started buzzung as it gets hot. Sounds like a soft bee. I moved some equipment around and it seemed to stop for the moment. It may be because I unplugged it and it had a chance to cool a bit. I noticed that the unit gets real hot. I think I may need to put a small fan near it. There also seems to be a new problem showing up. Not sure. The syslog will begin to oscillate showing WAN MAC and LAN MAC. This is part of another message I wrote today.
  52. rhody401

    rhody401 LI Guru Member

    A lot of people seem to have the buzzing sound. Mine have all been quiet.

    I'm still amazed by the lack of action from the company...
  53. DocLarge

    DocLarge Super Moderator Staff Member Member

    The developers responsible for this unit have been notified of this "whining" sound; as of yet, there's not remedy for the situation being some who own this unit (like myself) are not experiencing this problem.

    By the way, this doesn't mean that the problem doesn't exist...
  54. rhody401

    rhody401 LI Guru Member


    Is there a router you suggest that has similar functionality to this one? (to replace it) I don't care so much about the VPN, but wireless N, gigabit switch, and some of the other security features are a must.

    I need to do something about this in the next week, it's costing us too much extra time.

  55. Reby

    Reby LI Guru Member

    While questions are being asked - any news on a firmware release that might fix a few ftp and DHCP issues?
  56. astute

    astute LI Guru Member

    I also have the same FTP problem. I also tried the new firmware, the 1.1.06 firmware which does a lot of good but doesnt fix the ftp problem or the QoS problem.

    I really do need the new firmware for QoS and wifi improvements. But i also NEED ftp. Shutting down IPS kills all internet traffic. Next to that i have a very early european batch, no whining sound, just the fw problems.
  57. goozerin

    goozerin LI Guru Member


    Where did you download FW 1.1.06 because ive only the 1.1.03 FW?

    Looking Forward. thank you

  58. GalacticLink

    GalacticLink LI Guru Member

    Any new information/fix yet?

    Any new information/fix yet?

    I have suddenly started having the same problem with FTP. I have also said in other places that mine has that high pitched wine.

    But a little more information I can give.

    I just recently switched a couple days ago to Cable 10Mb internet and only now do I have problems with FTP. I can switch back to my DSL 3Mb OR take the router out of the loop (on cable) and everything works perfect.

    I do not have problems with ALL FTP connections though. But I would say more than half of what I have tried & even less luck if I connect outside a browser and use either of my usual FTP clients. It will lose data transfer immediately after 2.7KB of data has been transferred when getting directory listing or file data (both download & upload).

    The easiest examples have been trying to download ubuntu iso's
    from .edu addresses listed under the US mirrors. Less than half of the FTP links will start downloading. And if I connect manually to the ones with ftp client access the same servers will either stop getting data or work, just like from browser links.

    The intolerable part is both my hosting & work data transfers will not work now unless I switch back to the DSL connection or take the 4400 out of the loop.

    for a public example. trying to download one of the test files from (my DSL ISP) will stop after 2.7KB when going through the router AND cable but not if I direct connect to my cable modem.

    Does anyone have ideas now that I could try?
  59. davidpw

    davidpw LI Guru Member

    This FTP problem is interesting. I have had no problems with FTP or the whining (wonder if they are related?) A tried a couple of FTPs (>100M) and the transfer was fast and without problems.

    Somewhere else in this forum someone mentioned how a special procedure to ensure that all variables are erased to factory defaults. Has anyone with the FTP problem tried this proc?
  60. GalacticLink

    GalacticLink LI Guru Member


    Update. I was not willing to give up on this. After trying rate controls, firewall, IPS settings. I decided to try going back to firmware 1.00.16 since I still had my config file & firmware for that.

    Lo and behold all FTP works again. Also I have found my ping go down to my main/gaming servers by 5-10 and my download speeds now max out a bit higher as well. On Cable ISP with 1.00.16 I can now max out with powerboost/speedboost help to 20000kbps on when 15 minutes before (and ALL previous tests) with 1.1.03 I could only max out at 16000. And non boosted transfers are a bit more stable at holding 10000, my sustained max speed.

    Looks like I will be keeping this firmware in use until at least next update. I will miss a few small things in 1.1.03 in the meantime but nothing critical (mainly the MAC/IP static addressing)
  61. goozerin

    goozerin LI Guru Member

    any news about the next new fw for wrvs4400n?

    any news about the next new fw for wrvs4400n?
    Maybe someone knows more :)?

  62. astute

    astute LI Guru Member

    To clarify a bit, the 1.1.06 FW version I have, is the one I received after complaining to the helpdesk about my QoS and ACL problems (considering making your own services which doesn't work in 1.1.03 in QoS)

    It is as far as I know an alpha, so very early release.
    This also means that a fix is gonna take a while if they are just at alpha right now. :thumbdown:
  63. jazzmak

    jazzmak Guest

    Worst router ever: WRVS4400N

    I have bought the router for a small branch after quite good experience with RVS4000's stability and features. I though I have learned how to solve some quirks of always-beta Linksys firmwares.
    This was bad mistake which cost us a lot.
    1. Router was completely blocking out debian machine's IP when I port forward to it. So I had to add second IP and then third and so on (IPS turned off)!
    2. Router locked up completely in the middle of the night or whenever.
    3. Router had problem save some settings using Opera browser.
    4. Router also emitted high pitched noise.
    We tried latest firmware (1.01.03) as well as older one. We tried resetting it numerous times. We tried everything.

    After one week strugling with it I replaced it with WRT54GL using Tomato firmware.
    Its light years ahead of Linksys firmware. It does what its supposed to. Perfectly responsive. Intuitive. Rock solid. Innovative. Full-featured. I call that bussiness class.
    We use OpenVPN instead of IPsec. IPS, gigabit swith and pre-N wi-fi are not worth troubles with this worst router I ever have my hands on.
  64. astute

    astute LI Guru Member

    I also heard the wining sound today. Never really thought it was the router. The router is between a lot of power adapters, of which all of them can make a high pitched sound.

    The fun thing is, maybe some people here are not experiencing that problem because they simply can't hear it. My 60 year old father couldn't hear it for example.
    It's the kind of sound that is in the high pitched frequency that some people, mostly older people, but also people that damaged their hearings somewhat, can't hear.
  65. DocLarge

    DocLarge Super Moderator Staff Member Member

    I've got 1.1.06 but haven't been able to load it due to my routers still being in storage. The information regarding what changes have been made isn't available as of yet via our sources, but we're expecting to hear any day now. In the interim, those who've managed to acquire 1.1.06 will just have to continue "trial and error testing" until something definitive is announced.

    As I've personally stated, my wrvs4400n doesn't whine, but it might be due to mine being from an older batch...

  66. blake_

    blake_ LI Guru Member

    Any chances of a link? I've got my router acting as an access point only in G-mode seeing as it's such a piece of useless trash.
  67. blake_

    blake_ LI Guru Member

    Yeah it's sort of like the noise I hear when a CRT is running. High pitched whining that only some people notice.
  68. astute

    astute LI Guru Member

    Well Jay,

    I have loaded it as I have written before but I wasn't able to tell a difference. Do you have an alpha or a beta?
    What i can say is that ACL has been improved and the wireless has gotten a bit better but mostly I think was the same as with 1.01.03 version and I am not keeping my hopes up on any miracles.

    Also the helpdesk guy from the business desk told me they are too busy to actually test the firmware with other tasks and Linksys development is heavily understaffed.
  69. Guardian914

    Guardian914 Guest

    Issues beyond issues with this WRVS4400n

    I bought this WRVS4400n assuming it would be a quality product, since it was $180, named 'business class', and with previous Cisco experience. However, this product is the biggest piece of junk I have ever used.

    First of all, I have the same issue with the high pitched whine. After speaking with some tier 1 newbie I was able to get an RMA, and they sent me a refurb unit, and it has the same problem.

    Second, the wireless is completely unstable; After 5-6 days, I cannot connect wireless to the router at all, although wired, it's working OK. Rebooting the router solves the issue. I tried switching authentication/encryption from WPA-TKIP to WPA2-AES, however the same issues.

    SO, just for fun, I bought a WPC4400n adapter, assuming my problems might be due to some strange incompatbility with my mini-PCI Dell 1370 card (Broadcomm).

    Funny, the new adapter is even worse; I can't even get an IP via DHCP!! I have to force a static! I'm assuming the connectivity issue will begin after the router has been powered up for a few days.

    * Update* - I downgraded to 1.0.16, and now DHCP is working.. let's see if the WPC4400n adapter and the WRVS4400n can live happily together without rebooting the router every 4-5 days..

    Please inform whomever your contact at Linksys/Cisco is, that this router needs urgent attention, and existing customers need replacement revisions.

    The high-pitched whine is annoying, but the fact that I can't use the intergrated radio, and have to resort to connecting a spare 350AP from work in order to have wi-fi in my home, is mind numbing.

    I configure, deploy, and recommend Cisco products on a daily basis at work, and after my experiences with this product, I'm beginning to think Cisco sends all their rejects that they can't fire for whatever reason, to work for their Linksys division.

    I doubt a simple firmware upgrade can fix the gremlins with the WRVS4400n, as the high pitched whine issue makes me think there's a hardware defect as well...
  70. astute

    astute LI Guru Member

    If Linksys keeps quiet and doesnt come with a new FW soon it might be time to put up a website to collect autographs for a recall of the unit and make them replace it with something similar.

    Get some posts on Slashdot, Engadget and the likes and collect as many attention as possible. maybe Linksys will learn they can't just **** with customers like this.
  71. blake_

    blake_ LI Guru Member

    You can return them for a full refund, just ring Linksys for a RMA number and promptly return to supplier.
  72. astute

    astute LI Guru Member

    Sadly enough this is not an option in The Netherlands where the supplier never needs to take it's products back. Especially not when its older then a year.

    What they do is probably ask me to send it to them, and they send an exactly the same refursbished model with the same problems back because the problems are the product and the product is functioning withing their specifications.
  73. rhody401

    rhody401 LI Guru Member

    Astute: I posted a similar comment and it was removed
  74. DocLarge

    DocLarge Super Moderator Staff Member Member

    Sorry I've missed the flow of conversation (still moving)

    I have 1.1.06 but haven't been able to load due to my hardware still being in storage. I'm still waiting for the notes about the "fixes and finds" regarding the new firmware.

    I'm in the works of trying to acquire a second WRVS4400N so I can see what's going on with the "whining" sound. The posts regarding this sound are becoming more consistent which means this isn't an anomaly as believed initially.

    Outside of the linksys testing team finding out anything else at this time, there's nothing more that we can do but wait for the developers to run down the "gremlins" as one poster put it :) . Again, my unit has worked fine with 1.1.03, specifically with ftp. I guess that makes my unit the anomaly, but I'm willing to acquire another unit to see what's really going on for posterity's sake :)

  75. astute

    astute LI Guru Member

    Sounds like a very good plan. Especially for the 1.01.03 FTP errors(that are also back in the 06 firmware, even though I'd figure this being a big problem and should've been on the top of the to-do list).
    Considering the whining, it can not be that it is caused by software. It's very much an electrical whine, not a mechanical.
  76. SirSycho

    SirSycho LI Guru Member

    This router is terrible!!

    well I should start off by saying that I've RMA'd my router once before. The first time it had the high pitch whine along with a diag light that would never turn off, I could never get ping or anything so it got RMA'd. That was December 2007.

    My replacement now has very similar problems although it still functions a little bit with some coaxing. Coaxing involves unplugging it for a couple minutes, plugging it back in, waiting for the diag light to turn off (usually 2-10 minutes) and then it routes for a few minutes to a week and then breaks again. First wireless will drop out completely and then nothing works, can't get to the admin page, can't ping it... In addition to that, if I make any change that requires the router to reset itself, it never comes back online, I have to unplug and replug it (sometimes more than once).

    Linksys sent me the beta fw which I will post below (use at your own risk), but it seems to have totally broken my router (which, in all fairness, I believe was already broken).


    I'm a huge Cisco fan but labling this device as a business-class router is such crap it makes me want to scream... The best thing about it thus far is the 3 year warranty.
  77. blake_

    blake_ LI Guru Member

    OK let's see if this bricks my router too. Sort of hope it does so I can go and get one of the Apple 11n routers instead.

    Edit: Believe it or not, I can now download torrents at faster than 80kb/s when using 11n mode. Still not game to use it for anything more than a AP though.
  78. _Dejan_

    _Dejan_ LI Guru Member

    Im try this firmware but I can't save changes in WAN settings. All other functional ok... Now I will try reflash it...
  79. rhody401

    rhody401 LI Guru Member

    The new beta x version has the same behavior for me, too.

    (no ftp)

  80. goozerin

    goozerin LI Guru Member


    Maybe it would be good if someone can tell Linksys about the FTP Problem because at this Moment the new FW is only in Beta and they can close this FTP Bug?

  81. astute

    astute LI Guru Member

    Just got of the phone with them, and they know about it.
  82. _Dejan_

    _Dejan_ LI Guru Member

    Ok now Im find what is wrong with my router.
    So if I update FW to this new by laptop with Vista + Firefox with USB LAN card and setup it then I can't save WAN settings. Then Im update it from my server which have Server 2008 + Firefox from Marvell LAN card and configure it then work ok. Very strange...
    FTP for me work ok(In all FW). So I have FTP server and I can connect and download files(Im try max 600MB file) to it from any other location and I can connect and download If I use WAN IP for connect to FTP server from my location...
  83. goozerin

    goozerin LI Guru Member

    Has anyone the new fw 1.6 for wrvs4400n?

    where can i download because with the fw from rapidsharelink someone has posted here i cant upgrade my router? he said wrong version?

  84. _Dejan_

    _Dejan_ LI Guru Member

    after few days testing this 1.01.06 version I must reboot it everyday, because router totaly frezze...
  85. rhody401

    rhody401 LI Guru Member

    I'm not having that (lockup) behavior. For me, 1.01.06 greatly improves speed for some types of file transfers(p2p, etc). But FTP is still blocked.

    Since updating from the 10/31/07 version, I can no longer connect via pcanywhere from one pc to another, within my LAN. To connect from the PC at one end of the office to the other (plugged into the same router), I now have to use the outside IP and go through a forwarded port. Previously, I could use the pc's internal static IP ie and port.

    Hopefully this will help the coders to make the next one better.
  86. goozerin

    goozerin LI Guru Member


    Yes the new FW runs very good and fast on my Router but i have only the FTP Connection Problem. Hope the Coders will fix them? And if i turn IPS off i cant connect to the Internet?

  87. rhody401

    rhody401 LI Guru Member


    If you turn IPS off, it seems to break DNS. If you have something connected to the internet, it keeps working....(IRC, etc) But it won't let you make any new connections.

    An addition to my above issue: I can't pcanywhere from one pc to another within my network, if one of them is wired and the other is wireless. (The laptop is wireless and on N, the desktop is wired directly to the same router) This started with the beta fw. I forgot that detail :)
  88. astute

    astute LI Guru Member

    Well, all these problems are official PKI's right now.

    Now I am busy on getting the unit returned, kind of sick and tired of having to wait for them to bring new firmwares out. JUST FIX IT ALREADY LINKSYS.
  89. roustabout

    roustabout Guest

    hardware mod

    So, everyone seems to be using a pretty different firmware than I'm on - I installed the V1.1.03 after the original firmware locked. Initially, I had a lot of locks with 1.1.03 as well, rolled back to the recovery firmware.. still a lot of locks.

    PUt the device aside (I bought it for 160 at compusa, so it's nonreturnable) and went back to my old router until tonight.

    I pulled it apart for a look. The heatsink is a) tiny b) off-center c) fastened with glue!


    Pulled the stock heatsink, replaced with a heatsink from an old video card.
    Scraped out a chip-size open space in the adhesive, used a real thermal compound.
    Added ventilation holes over the new sink and over the wireless card.
    Dumped the piece of tin covering the wireless card.
    Clipped the tin around the old heatsink, to leave the new one completely open (and to make room for it)

    Powered the router up, it wasn't locking.

    Reinstalled the 1.1.03 firmware, told bittorrent to go to town - and so far, at least, it isn't locking up on me.

    So, for those of you who are returning this rather poorly designed box repeatedly, you might consider a heatsink upgrade. by now, the router would have locked last weekend. I'm happily on the balcony using the wifi now, and I do like some of what the router can do.

    I'm also pricing real routers, though, Cisco 877w and 857w. This unit feels to me like a bit of a toy. I may even talk the boss into buying me a real router.

    I realized as I was using this router - well, I do like a lot of what it has. GigE would be nice. but if I'm interested enough, I can do an 857 for around 320, and at that point I have the real IOS - I like the Linux syslog messages this generates and all that, but I have a feeling this box may be being asked to do more than it can.
  90. astute

    astute LI Guru Member

    It's gone awefull silent over there at Linksys.

    I tried returning it or getting it replaced but everytime they keep forwaring it to another department so I still haven't been able to get rid of it.

    I hope they un-beta the driver quickly and got everything fixed up...if they haven't gotten anything before the end of March it would be an outrage.

    (also, yea, the heat-controll and build quality has gone backwards of Linksys products the past years, but I guess that is the price you gotta pay when you want more speed and functions for the same amount of cash.)
  91. rhody401

    rhody401 LI Guru Member

    I emailed yesterday with my concerns.. even THAT was frustrating.

    It has a place you can click to contact the company, an email form comes up. You type it up and click submit...

    Then it tells you they no longer accept emails, and wont reply. (yes, AFTER you send it) It also asks you to hit submit again to send it anyways.

    Then a screen comes up and tells you again that they won't answer the email form that they offered on the site, thanks you for sending the email, and gives you a case/reference/tracking # for the issue.

    I know they outsourced just about everything, but is there anyone left in charge to take a look at the bigger picture, quality control, and customer experience? It's looking more and more like a company in serious trouble.

    This is unacceptable.
  92. Reby

    Reby LI Guru Member

    Reply from Linksys


    I thought I would share this with you. I did reply to this mail and got no answer back, despite keeping the incident number in teh heading as you should.

    Note the date of the mail and the expectation setting of a fix.

    I complained about the DHCP bug and FTP issue btw.


    From (Linksys - name removed) 12/18/2007 06:37 AM
    Dear MR ,

    First of all thank you a lot for contacting the Linksys Business Support.
    The problem that you are reporting is a well known, high priority, bug of this particular firmware release.
    The behaviour of this bug is exactly how you described it ... the DHCP server is not enabled when no cable dhcp client host is connected.
    There is a schedule already for this issue to be fixed, the firmware should be delivered before 2008, so check the firmware download
    page for the WRVS4400N regularly.

    At the moment the only workarounds are:
    1) set only static IPs,
    2) disable DHCP on the device and setup another host as DHCP server,
    3) fall back to the previous firmware release.

    For any further question please don't hesitate to contact us again.

    Best regards,

    (name removed)
    Business Support Engineer
    Linksys - A Division of Cisco Systems, Inc.
    Tel.: +44 207 660 0121
  93. robhol

    robhol Guest

    I want the original firmware back manufacturing date 06/2007 does anyone know which one it is?
    I upgraded to the latest from linksys homepage but discovered that i dont get an IP from the router so the DHCP is disabled if a cable isnt connected to the router. As told in previous post.
    Then i cant ping other computers at the network and dont find the computers.
    Cant believe how linksys can have a firmware like that out at the homepage. And its a known problem then they should have the archive available at least.
    Does anyone know where i can find older firmwares? Have just found broken links.
  94. goozerin

    goozerin LI Guru Member

    sorry but for a ...

    Sorry but for a Business Router the Time for a NEw Full Functionally FW takes to long.

    MAybe Linksys doesnt like Business Customers?? ;-)

    It is a shame to bring a Super Business Router on the Market with a beta FW....

    And Linksys nows that Business Customers needs FTP and DHCP Functions (not all) :)

    DLINK has also good Bus. Routers.

    So Long.
  95. rhody401

    rhody401 LI Guru Member

    If you really cant find it on their site or ftp (if you can ftp) ha, email me.

    I have all the old versions going back to 2006

    For some reason, I havent replaced these routers yet. I'm holding out and checking each day, in hopes that Linksys does or says SOMETHING about this issue.

    I love the router, but wish it would work:)

    I noticed something else: If you go to the LIVE CHAT on the linksys website, and put this model in, it tells you that this is a model that they don't support via chat. To call an 800 # or your dealer. This is a new behavior. I was able to chat with them about 4 months ago.

  96. astute

    astute LI Guru Member

    Lol @ "if you can ftp"

    But for serious, you can download the "RESTORE" app (if you run Windows XP (Do not try on Vista, I had my fair share of bricking on VISTA)) and run that app. Running that app will restore your router back to 1.0.12

    I know, it's not the first version, but its the best one there is (No FTP problems and okay-stable)

  97. DocLarge

    DocLarge Super Moderator Staff Member Member

    I'm suprised to see that the firmware is still now working at this point. Reason being, I've been able to use FTP from the initial firmware version up to 1.1.03 since receiving my WRVS4400N about a year ago (to include site-to-site vpn connectivity).

    I took the plunge and loaded 1.1.06 last night; I'll know more later...
  98. rhody401

    rhody401 LI Guru Member


    How did you make out? Did you see any of the behaviors folks are reporting?

    I reset and factory defaulted one of mine yesterday 5x in a row, and set it up again. (just to see if that might help)

    We have a mixture of 10, 100, and 1000 speed devices plugged in, if that could be a potential factor.

    I'm hopeful that someone is indeed working on a solution for everyone.

    I appreciate all that you do for this forum,

  99. _Dejan_

    _Dejan_ LI Guru Member

    This is my current uptime :D

    But I must clear IPS log table after few days if not then router is slow(If I have 300-1000 logs). One computer is 24h/7 online and have:
    -Mail server(POP3, SMTP & WEB)
    -HTTP&FTP Server
    -eMule(limit to 100 connections) otherwise router work only 7 days...

    Firmware is 1.1.03
  100. rhody401

    rhody401 LI Guru Member

    Ill try disabling the logs. That may very well be where the memory is going.

    Ours here is 1.1.06x (beta)

    It will stay up 30 days if I let it, but starts getting flaky after about 1 day.

    For example, i'll use pcanywhere and notice severe lag or video display problems. Once I reboot the router, it'll be fine again for 1-3 days.

    I also notice that I can only pcanywhere within my internal network (directly to the ip) for the first day or so. After that, the router has to be rebooted or I get a timeout error when I try to get in. All of my pc's are set up with static ip's, except laptops. I have it all in the range

    I picked up a Linksys 10/100/1000 switch last night and plugged my primary pc's into that, then plugged the switch into port 1. This didn't change any of the behavior.

    Can you FTP? I cannot.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice