Two problems with Wrvs4400n, please help me.

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Dinon, Dec 3, 2007.

  1. DocLarge

    DocLarge Super Moderator Staff Member Member

    The first couple of days have been tricky...

    I noticed when I manually set the mtu to 1500 the vpn tunnels stopped working (my guess due to packet size) so I'm going to do a readjust in a minute. The wireless was "iffy" to say the least for the first day but it seems to have settled down for now. Overall, it seems to be behaving itself for the time. I'm going to have Toxic to try ftping over to one of my servers later to see if he's able to get in.

    Now that I'm back in the States, I'm running my 4400N on a cable modem connection (Cox High Speed Internet) but I'm having a DSL line installed also for testing purposes.

    Something will be figured out here :)

  2. rhody401

    rhody401 LI Guru Member

    Thanks Jay!

    Both of mine are also on Cox 20M cable connections.

    For me, wireless has been good. We use N and G. In fact, it's much more stable and quicker than the previous version in mid 2007.

    I look forward to hear if you are able to FTP out from yours. I tried about 5 different ftp clients. They usually time out right after connecting to a server, while it is downloading a directory. It's almost as if the router is treating that activity as if it was an intrusion or attack.

  3. fight

    fight Guest

    Has anyone heard of a new fw?
  4. jeru

    jeru LI Guru Member

    Nope, nobody has heard anything. All anybody has heard so far from Linksys is that the router has no known issues. And we all know that isn't true.
  5. darwinmach

    darwinmach Addicted to LI Member

    I notice that your firmware version as "ETSI" appended to it... Mine is just plain 1.1.03. Do you remember when and where you obtained your firmware?

    Yes, I'm experiencing the FTP issue too. Called Linksys and they are aware of the issue, BUT all they are able to say is that the new firmware should be coming out "soon".

    I found a post in another forum about enabling Telnet access into this router but couldn't get it to work because it couldn't FTP his cross-compiled binaries. I might have to go do some source code diving to find out what's going on.

    // Update #1

    If you guys look the linksys germany site (according to there is indeed a hardware version 1.1 option.

    Darwin Mach, CCNA
  6. DocLarge

    DocLarge Super Moderator Staff Member Member

    I can now confirm the ftp problem exists. I tried using FTP just recently on a Verizon PPPoE connection I have and although I may be able to connect to the router, it won't do any file transfers.

    I'm going to take my cisco 871w off of my Cox connection and try the 4400n on that connection to see if I get the same thing.

    The problem does appear to exist, at least, here in the U.S. I did not have this problem using my 4400n on an ADSL (PPPoA) connection with a ethernet adsl modem from adslnation ( I'd almost think this is a packet translation problem because now I'm torked!

    More to follow...
  7. rhody401

    rhody401 LI Guru Member

    Has there been any word from the company? Do they admit there is a problem and do they plan to fix this?

    We're days away from the 6 month mark, since the last broken version.

    I hate to give up, and hope someone at the company is at least concerned about this.
  8. darwinmach

    darwinmach Addicted to LI Member

    According to the case manager assigned to my incident, they are indeed aware of this issue and are working on it.

    If you can obtain any debugging output / logs / verbose feedback and forward it to them, it would probably help.
  9. versprite

    versprite Addicted to LI Member

    FTP probs on WRVS 4400N v1.1.03

    Just got off the phone with India. After 30 minutes of talking to L1 support and bouncing around techs, a L2 support person sad that they are aware of this issue and a case manager will contact me within the next 8 business hours. I upgraded firmware roughly a week ago (yes, I was late) but now I wish i never did. My wifi wasn't that bad (given the reported probs on the last firmware) and ftp worked great. I spent 4 hours troubleshooting everything else and was even cursing my ISP towards the end when I thought that they were throttling down certain communication protocols. I realized it was the router once I hooked my puter up directly to the modem. Linksys (or Cisco) better get their stuff together as this level of abuse is totally contrary to the image I had of them. Seems like they have outsourced QA efforts over there as well b/c no one ever decided to test case the ftp functionality. DOH!

    More to come hopefully in 8 hours.....:mad:
  10. rhody401

    rhody401 LI Guru Member

    Please let us know if you get any more info. The last official release has been almost 6 months (next week). I'm running a December beta, but most problems are still the same. (including the lack of FTP)
  11. versprite

    versprite Addicted to LI Member

    Firmware Update to WRVS 4400N

    Ok I received a beta firmware version from Cisco from the support rep with whom I spoke with late last week. I have not tried the beta version received since the .img file was not digitally signed by CISCO. I asked the rep prior to him sending it to me if the file would be signed by Cisco/ Linksys and he said 'yes,you are calling Cisco'. I didn't want to waste my breath on explaing the concept of spoofing emails, PBXs, etc, especially in an outsourced support world so i simply waited to see what the file would be. For those that use and download, feel free to post the results. I even asked him if there were release notes with the firmware and he said, 'no, that's why its beta', which told me i should just hang up and not waste any more time.

    I tried to upload, but there is a size restraint via post with attachments. Those interested can email me at versprite [at] yahoo [dot] com.
  12. blake_

    blake_ LI Guru Member

    Hey, just tried to upload the FW you sent...

    Upgrade file is not the correct type or version for this device.
    Upgrade failed.

    Please obtain the correct file and try again.
  13. versprite

    versprite Addicted to LI Member

    Ok, I replied back to the support rep who sent me this FW. I hope to have a response soon. I'll let you know what their response is. He may have renamed the extension in order to circumvent a IDS/ IPS device during the email exchange, but I'll double check. THanks for letting me know.
  14. darwinmach

    darwinmach Addicted to LI Member

    I have tried the beta firmware (1.1.06X) and here's what I noticed:

    - Speed improvements in transfers
    - Speed improvement of VPN

    - FTP still doesn't work
    - Breaks LAN communication! (Can't access server CIFS/SMB shares, Altiris traffic blocked, no remote desktop traffic allowed).

    There were far too many functionality problems that cropped up in the beta so I have reverted back to the stable version (1.1.03).

    I did notice something interesting, however. With both the beta and the stable firmware (where the FTP issues exist), if I VPN into the network (I have a VPN server set up on the LAN, not using QuickVPN), I can then FTP using that router's internet connection as usual. I haven't tried with QuickVPN.

    My guess is that only Port 21 traffic is allowed, without consideration that FTP is an OOB (out of band) protocol. Port 21 is only the connection control port; the data port (usually 20 in active mode, can be different in passive mode) in this scenario is probably being blocked and treated as "bad" traffic. This theory needs a little bit more testing.
  15. blake_

    blake_ LI Guru Member

    I'm also running 1.1.06X, not sure if this is the same FW versprite emailed through.
  16. versprite

    versprite Addicted to LI Member

    I am using FW V1.1.03
  17. DocLarge

    DocLarge Super Moderator Staff Member Member


    as I'd mentioned before, I was using my WRVS4400N's ftp capability "without incident" while I was in London. Since coming back and putting it on Cox cable high speed internet, I am now without FTP.

    Oh yes, the boys at the firmware division are hearing about this :)
  18. astute

    astute LI Guru Member

    Ya, it has been quiet around here. I haven't been posted as much as before. I stopped caring about wireless and just use the routers 1.1.03 firmware.

    Still I am so angry about this. It should have been fixed ages ago. Let Cisco put a real team on making firmware.

    Firmware team, you guys should get your act together and get this fixed up. Or at least release a new temporary firmware that is derived from 03 and that has some updates and no FTP problems.

    Making a new firmware that does more bad then good should be a no-go in every company.
  19. DocLarge

    DocLarge Super Moderator Staff Member Member

    Since I was overseas when the WRVS440N came out, can anyone tell me if FTP on this unit ever worked here in the states? While I was in England, I was running my WRVS4400N on a "PPPoA" connection and FTP worked fine. Now that I'm back in the states running it on a COX HSI connection, FTP doesn work at all :(
  20. astute

    astute LI Guru Member

    Well, on the newer firmwares it never worked as I heard from friends in the US as well in Asia.

    I have used the unit here in the Netherlands on ADSL, cable (DOCSIS2) and on ETTH networks and all have the same FTP issue.

    I am not sure why for you it changed, all of these providers didnt use any dial in connections or what ever. All modems are plug and play and bridge connections.

    It might be that, but I can hardly imagine.
  21. Dinon

    Dinon LI Guru Member

    Linksys sent me v1.1.06X beta firmware too but it is a head ache. Speed was a little improved but at high speeds it is terrible unstable. I have a new 100Mbit internet provider and the router with this beta firmware cannot stable handle this speed on WAN port (v1.1.03 is ok). Port range triggering is not functional and the router freezes when I try to use it. Port range triggering is only partly functional with firmware v1.1.03.

    I cannot use IPS Function with any firmware because speed degradation is terrific, 100Mbit connection goes to 12-14 Mbit.:thumbdown:

    FTP problem also is not resolved with new beta firmware but it is very strange problem. With my old ISP FTP is not functional but with the new one all is OK. All settings on router are the same, only ISP's static IPs were changed. I tryed FTP on many ISPs at my frieds and at my work and it is sometimes functional and sometemes no. I do not know, why. Older firmware v1.0.16 has functional FTP in every situation.

    I owned four WRVS4400N and I returned two of them, the third one I've sold. This last router I will return too.

    I think I never buy any product from Linksys in the future. It is a big disappointment.:mad:
  22. rhody401

    rhody401 LI Guru Member

    Yes it worked fine with COX HSI before the October 2007 version.

    I have one of these on Cox business internet, and one on Cox residential internet.

  23. goozerin

    goozerin LI Guru Member

    Any News??

    are there any news about the new fw for the 4400??

    the ftp problem and dhcp problem are annoying.

    what do you think about the new belkin n1 vision router?

  24. blake_

    blake_ LI Guru Member

    I recently gave up on Linksys and bought a 2nd hand Cisco wireless router off ebay for half the price I paid for my 4400N. Faster than ever, no dropouts.

    Now my 4400 has a life as an access point for my AppleTV, about the only thing this piece of **** is worthy of.
  25. versprite

    versprite Addicted to LI Member

    You know that Linksys and Cisco are one in the same now...hopefully the apple does fall from from the tree in your new purchase however. Lets just hope that both divisionsdo not use the same QA methodology and resources.
  26. darwinmach

    darwinmach Addicted to LI Member

    thats kind of... odd? it shouldn't be happening

    and the thing is that any ordinary router would allow this traffic :(
  27. DocLarge

    DocLarge Super Moderator Staff Member Member


    it "shouldn't" be happening, but for some friggin' reason it is. I can't recall whether or not I have it working on my xDSL connection (I have both a Cox HSI connection and a Verizon xDSL connection). I'm going to check this out again when I'm home in a few hours...
  28. ChristianJ

    ChristianJ Guest

    I dropped back to v1.00.15 firmware on mine and the router is working wonderfully. I think I downloaded the firmware from here, but as of today, I can not find it listed.
  29. VipeTecH

    VipeTecH Addicted to LI Member

    When i got this router my router also display it as a -ESTI firmware version. But have been recover it back and now again to a firmware 1.1.03 but now out the "-ESTI"

    how can i get this back ?

    can u send the firmware to my mail?


  30. finnvid

    finnvid Guest

    WRVS4400N problem disabling IPS


    In order to get proper troughput (I have a 100MB connection) i am trying to disable IPS. When doing this it is not possible to access any http-siter anylonger (dns still works).

    Running 1.01.03
  31. Tetra

    Tetra Network Guru Member

    I bought a wrvs4400n recently because I was giving away my old router to a relative who needed one, and this one seemed pretty nice. What's more it actually had the Cisco logo on the box unlike the wrt160n I was getting rid of. I'm appalled at all the problems with this router given how long it's been out. I'm even more upset by the fact that my call to the business division at linksys for support on this thing I asked if "this model was flakey", "if it had a buggy firmware", and "if [the lack of working dhcp] was some kind of known issue"... all three questions were met with a firm no and that it was probably just a setup configuration problem.

    I humored the tech and accepted that answer... but I'm sure everyone can imagine my surprise at what the holy hell could have been wrong with the router to seemingly not work, after manually setting up dns on my local machine and being able to access the management page but not anything else. I was even more confused at what was wrong when I suddenly got an IM from someone and was able to converse with them even though I still couldn't browse anything over http aside from, the router's management page.

    When I called tech support, despite being told this was very unusual... not a known issue... these routers were very good models... and quite a bit of stress starting to show when i started asking about the terrible reviews I found on amazon & newegg or the various forums where I was seeing people posting about these same sort of problems I was experiencing, the rep explained that it had a lot of features and people sometimes set them up wrong. Needless to say, despite the lack of any known issues on this router, the first thing he has me do after resetting the thing is to connect my laptop to it with a network cable instead of wireless and magically my other computer was getting an IP as well... must have just been a bad setting or something left over that the reset fixed.

    I took him at his word and just kind of shrugged, went back to setting up wireless security and whatnot, then the thing doesn't work in the morning when I wake up and try to use it. Another reset and it's still not happy... connect it with the cable and suddenly it works.

    I'm not sure which is worse, the fact that it really is a known issue that despite the age of this router DHCP doesn't work without a client being connected through one of the network cable ports... or the fact that the tech rep said nothing was wrong and didn't bother to even mention what was clearly a known issue that he quickly worked around during my call even when I asked about it directly. I hadn't even realized FTP didn't work until I got around to testing it, that would have been another fun call I'm sure. I'm incredibly disappointed that evidently Cisco deciding to put their logo & name on a linksys box doesn't actually imply that the thing inside is even functional.
  32. ne1r

    ne1r Network Guru Member

    DHCP again

    Did the upgrade to 1.103 craps out. Did the 1.1.06x, worked for 2 days, then stopped issuing on WLAN. I have very little time to trouble shoot this as there are 11 clients on this router. Calls to support is worse than going to the DMV. It's been, what 6 months and still no stable version for this router. I reset back to 1.0.16 and keep my fingers crossed. There are some great features on the 1.1.03 but I can not swap out any more clients and have them live with downtime.
  33. Meth0d

    Meth0d LI Guru Member

    I am currently running the 1.1.06X fw, dhcp works for me but i also got some more or less random Wireless dropouts (wlan just disapears and will eventuelly come back up without doing anything 15-20 min later). Most of the time im to annoyed to bother waiting so i restart the router wich most of the time fixes the problem.
    I do not have heavy traffic over wlan.

    I still got sort of random hangups / hickups when the router is running for more then 24h and random hangups when doing heavy traffic or high number of connections over lan.

    My setup right now is to kill power to this box of junk every night in order to have a functioning router when i need it the next day.
    Not to mention that VPN with quickvpn is still not working and trying to use it leads to a router hangup.

    Way to go linksys! especially if you take a look at the pricetag, then at the release date and if you bother back at the pricetag to fully realise what amount of money you wasted.

    Oh yeah PS: I also have the high pitching sound if this thing gets warm (5 minutes after turning it on).
  34. CarlosNiebla

    CarlosNiebla Addicted to LI Member

    Same problem as Tetra

    Last week I bought 3 WRVS4400N routers and a WPC4400N wireless-N notebook adapter. After a week of having the same problems that Tetra mentions, I found this message thread and I would like to know if there is already a solution for the unstable wireless network and the problems with the DHCP with wireless connections.

    So far I have only opened one of the three boxes I bought, but if there is no solution so far I am going to return the three routers.

    I feel very disappointed from Linksys, knowing for a long time that this router has problems and haven't a fixed the problem yet and continuing to sell it. I thought I was buying a solution, not a problem!

    Does any one knows any other router with wireless and security that works fine?


  35. darwinmach

    darwinmach Addicted to LI Member

    hey guys

    new firmware update from linksys support v1.1.08

    supposed to fix wireless lan DHCP and the FTP problem... i just got it haven't tried

    its uploaded so you guys can test it out too

    let me know ( i kno i will) :D


    Hey Carlos, when you mean security you mean a configurable firewall and/or an IPS solution correct?
  36. rhody401

    rhody401 LI Guru Member

    I don't see any mention of that new version on the website.

    Is this another beta?

    Can anyone confirm that this link and code are legit?


    Anxious for some good news!
  37. Dinon

    Dinon LI Guru Member

  38. darwinmach

    darwinmach Addicted to LI Member

    It's legit... i got it from my linksys case manager


    Had a small wireless trouble however (where my laptop wouldn't associate with the wifi, but I can't confirm this as an issue with the router because when I rebooted my computer, wifi worked again)...

    Can someone else test the firmware and post your results? Doc? :)

    In the meantime, thanks linksys! :biggrin:


    You may notice they added a few new features & changed a few things around:

    - TrendMicro ProtectLink Gateway support (needs to be paid for to work though :thumbdown:)
    - SIP Application Layer Gateway Support for your VoIP Phones, etc
    - Default RSTP System priority is no longer 0
    - Cosmetic touch ups on the IP ACLs page
  39. rhody401

    rhody401 LI Guru Member

    Thank you so much for sharing the link to this temporary fix/beta firmware. :thumbups:

    I am now able to FTP! It seems noticeably faster too, but it may be a bit premature. (less than 30 minutes of use) I could live with the other issues, but the FTP was killing us.

    Thanks to you and to the developers for sharing this.
  40. darwinmach

    darwinmach Addicted to LI Member

    sure :)

    ETSI or non-ETSI shouldn't matter... ETSI is supposedly european model

    but now with the 1.1.08 firmware... ya kno everythings fixed... so far...

    post any issues u guys have so i can report it
  41. CarlosNiebla

    CarlosNiebla Addicted to LI Member

    Yes Darwin, I meant that.

    I am considering SMC SMCWGBR14-N that seems to be similar in characteristics.

    Any other suggestions?


  42. darwinmach

    darwinmach Addicted to LI Member

    there's the ASUS WL-500W and the NETGEAR WNR854T as well (not sure if they have customizable ACLs however)

    of course, the WRVS4400n with the new firmware works very well too... and it has the ACL customization

    for a true IPS, i don't really recommend an embedded solution as the regex's (signatures) are often
    - incomplete (lack of protection)
    - uneditable (can't remove extra entries to optimize performance or if a rule breaks something then u can't fix it yourself),
    - updated very slowly (you don't get the latest protection)

    it's probably best to set up a network like this if you want a real, basic IPS solution:

    ---- = wire
    [box] = some component, described inside

    {WAN/ISP}------[Snort IPS]-------[Router/Gateway]-----{LAN}

    the [Snort IPS] would be a linux PC with 2 NICs, running your favorite distro stripped down (i recommend FC, cuz i had the least issues with it), with Snort ( installed.

    Snort is the open source IDS/IPS solution with editable signatures, free frequent updates, etc.

    its quite a mouthful, but only if you need a true "free" IPS solution...

    if you (or your clients if any) are ok with the built in IPS on a router, (good for SOHO & personal)... then its probably more feasible for the "fake" IPS
  43. darwinmach

    darwinmach Addicted to LI Member

    anyone else try the new firmware yet?
  44. rhody401

    rhody401 LI Guru Member

    It's still doing OK for me, and a huge step in the right direction.

    I'm once again able to pcanywhere into pc's on the same LAN, using direct internal IPs. This is one of the things broken by the current production version.

    I can also FTP
  45. bigred072

    bigred072 LI Guru Member

  46. darwinmach

    darwinmach Addicted to LI Member

  47. bigred072

    bigred072 LI Guru Member

    Whoops...I must have missed that. So is everything working properly then?
  48. darwinmach

    darwinmach Addicted to LI Member

    so far so good :D

    i just need more people to test it out and confirm it before i tell linksys to close my ticket :p
  49. bigred072

    bigred072 LI Guru Member

    Ok, well I'll hook mine up again tomorrow or Friday and let you know how it goes (it's currently functioning as an expensive access point).
  50. tail

    tail LI Guru Member

    wrvs4400n with FW1.1.08 fully functional

    hey guys,

    I too have a WRVS4400n Router working at my home and since I upgraded my device to the newest Firmware (1.1.08) 10 days ago, I can really say: It is working.

    Before I had the WLan DHCP Problem which means I could not connect to the WLan-Router via a Wireless Device without having a Wired Device already connected and running.
    Also I had to keep the IPS function disabled for it throttled my maximum downloadspeed down to 13-14Mbit/sec.

    But now with the 1.1.08 Firmware running on my Device the Wlan DHCP Problem is gone and even with IPS function enabled I get the speeds I supposed to have (> 20Mbit/sec.)
    FTP is working (but I never had FTP Problems with any other Firmware)

    Nevertheless there is one thing I've noticed.
    Every few days I have log messages like this:

    device br0 left promiscuous mode
    device eth1 left promiscuous mode
    [VPN Log]: shutting down
    IPSEC EVENT: KLIPS device ipsec0 shut down.
    [VPN Log]: Starting Pluto (Openswan Version cvs2006Jan12_11:29:56 X.509-1.5.4 PLUTO_SENDS_VENDORID PLUTO_USES_KEYRR; Vendor ID OE@ECqImzhFD)
    [VPN Log]: @(#) built on May 26 2008:11:28:51:
    [VPN Log]: Setting NAT-Traversal port-4500 floating to on
    [VPN Log]: port floating activation criteria nat_t=1/port_fload=1
    [VPN Log]: including NAT-Traversal patch (Version 0.6c)
    [VPN Log]: ike_alg_register_enc(): Activating OAKLEY_AES_CBC: Ok (ret=0)
    [VPN Log]: starting up 1 cryptographic helpers
    device eth1 entered promiscuous mode
    device br0 entered promiscuous mode
    [VPN Log]: started helper pid=6450 (fd:5)
    [VPN Log]: Using KLIPS IPsec interface code on 2.4.27-star
    [VPN Log]: Changing to directory '/etc/ipsec.d/cacerts'
    [VPN Log]: Changing to directory '/etc/ipsec.d/aacerts'
    [VPN Log]: Changing to directory '/etc/ipsec.d/ocspcerts'
    [VPN Log]: Changing to directory '/etc/ipsec.d/crls'
    [VPN Log]: Warning: empty directory
    ipsec0: no IPv6 routers present

    I do not really know what that means. For me it looks like the VPN is restarting for no reason.
    I have one QuickVPN Client Account listed and active but never use it because I have WinVista running on my Laptop and u all know that there are Problems with Vista - QuickVpn - Nat.
    Therefore I have a PPTP-VPN Connection through my Router to my Server on Lan which works excellent.

    I am quite happy with this device now as it is functioning like I expect it.

    Here a little Screenshot that it is running over 10 days now with FW1.1.08
  51. Sevaltio

    Sevaltio Guest


    I have two WRVS4400N now running with Firmware 1.1.08 nearly 6 days. Now wireless clients can get IP's without any trouble anymore, and furthermore, the VPN now works much more reliable than before ( QuickVPN now works every time i try to use it ( Vista + QuickVPN 1.2.8) ). I must say that I'm really pleased with this firmware.

    @ tail:
    I have these entrys in the message log of the routers too ( don't know how often although) but I think that this is a solution against some bugs in the openswan deamon. (maybe some memory leaks that occour over time?)

    It would be really nice if linksys now updates the Openswan version, kill some of the minor bugs and maybe make it possible to select another encryption algorithm than 3DES?
    I really don't understand why they haven't implemented AES as an option in the http Interface.
  52. VipeTecH

    VipeTecH Addicted to LI Member

    Yeah my router is a european version. And thanks for share the info that its doesn't matters about the "-ESTI" and the new firmware :)
  53. goozerin

    goozerin LI Guru Member

    Where can i download this new FW??

    On the Linksys FTP i couldnt find it?

  54. bigred072

    bigred072 LI Guru Member

    It's posted in this thread, just read to find it.
  55. darwinmach

    darwinmach Addicted to LI Member

  56. CarlosNiebla

    CarlosNiebla Addicted to LI Member

    Unstable wireless connection with firmware 1.1.08

    Hi Darwin,

    I haven't been in the forum for a few days.

    Thank you very much for your detailed suggestions for a true IPS. I have taken note in the case that I need it. I bought this router for protecting the network at my home and to connect with my office where I have a RVS4000, similar to this router but without the wireless network.

    I have been talking with the Linksys telephone support asking for an authorization to get my money back on the three WRVS4400 that I bought, but they keep me loosing my time with routers that doesn't work.

    On June 11th they tried to send me by e-mail three times the latest firmware that they had, but I never received it, so I downloaded the 1.1.08 from your site.

    In effect, the DHCP for the wireless network now works fine with out the need to have another device connected by wire first. The problem is with the wireless connection, that starts to disconnect and reconnect continuously after 1 or 2 hours of connection. I made some testing with different channels, first in automatic mode and then with each individual channel. Channel 8 and 11 are the ones which work better for me, but the problem persists.

    I am connecting with to the router with a WPC4400N PC card adapter and the problem is the same when using the software provided by Linksys: "Wireless Network Monitor" and the "Windows XP Wireless Zero Configuration Utility".

    I haven't read any comment regarding this problem. Is any body using a WPC4400N PC card? I start to wonder if also the adapter has problems!

    I have just called again to the Linksys telephone support and they keep insisting in sending me a firmware 1.1.06 for testing it before they can change me the routers. That was more than an hour ago and I haven´t received the firmware.

    Just for the record, in December 2007 I bought a RVS4000 router for my office. It had an intermittent failure due to heat problems. I complained to Linksys and after a month I got it replaced with another RVS4000 that has worked fine since then.

    In six moths I have bought 4 routers and an adapter card that supposed to be the best models of the "Business" series, so I don't think I am a bad client for Linksys, but I don't feel like buying more equipment from Linksys nor recommending it any more.


  57. darwinmach

    darwinmach Addicted to LI Member

    hey carlos

    try enabling IOT mode under advanced wireless settings (in combination with CH. 8) for the WRVS4400n... especially because you're using a linksys card

    i know netgear defaults to 11 so to minimize interference i wouldnt use that.

    by the way i had to reset my router's config when i installed the new firmware because i ran into the same wireless issue, i'm using an intel WLAN card however so the IOT mode is for users of linksys cards
  58. VipeTecH

    VipeTecH Addicted to LI Member

    I'm using a Linksys WUSB300N and have none problem to get the 300 Mbit link and connection.

    Attached Files:

  59. CarlosNiebla

    CarlosNiebla Addicted to LI Member

    Hi Darwin,

    I have enabled IOT mode. I will tell you later if this has some effect.

    You mention that you have the same wireless problem (the adapter disconnecting and reconnecting after some time). Did the config reset solved the problem or you still have it?
  60. CarlosNiebla

    CarlosNiebla Addicted to LI Member


    Apart from connecting to 300 Mbps, do you notice your card is disconnecting and reconnecting after some time?

    I am getting intermittent messages in a balloon pointing to the Windows wireless connection with this message: "Wireless Network Connection is now connected".
  61. slaver

    slaver LI Guru Member

    I have tried new firmware 3 weeks ago and everything was fine. But 2 days ago after "ipconfig /release" and "ipconfig /renew" my 3 notebooks couldn't accept IP via DHCP WiFi. Now using static IP. Any ideas?
  62. VipeTecH

    VipeTecH Addicted to LI Member

    Hmm.. okay today i have some problems with v1.1.08 firmware.

    All my wifi devices could not connect to the router.

    I look in the router under Status -> System Performance pages.

    and here i see that my Wireless LAN have 16599 Dropped Packets Received. I think that was alot and check it again, and now the hole Wireless LAN table has been reset.At this point i coun't even see my wireless on my devices.

    So i reboot the router and now it works again :confused:
  63. roofy

    roofy Guest

    Wireless still dropping connections from time to time with firmware 1.1.08
  64. slaver

    slaver LI Guru Member

    So, realy stable firmware is 1.0.16 (by using Linksys restore utility from router software CD). No problems at all. :) If you don't need new features and just want stability, use it.
  65. darwinmach

    darwinmach Addicted to LI Member

    yes the config reset fixed it... didnt have a choice

    here's how my wireless is set up (only relevant info is given):

    - Channel 10 (2.457 Ghz)
    - G/N Mixed

    - WPA2 Personal w/ AES

    - Channel Bandwidth 20mhz
    - Guard Interval, Rate Limiting, CTS Set to AUTO
    - WMM Enabled
    - IOT mode disabled (only because i don't have any linksys wireless-n cards on my network. if you have a linksys 802.11n card, ENABLE this)
    - Beacon interval 100ms
    - DTIM interval: 1
    - RTS threshold: 2346

    i have a linksys-g PCI card on a desktop, an atheros-g in a laptop, and an intel 4965 ABGN adapter in aother laptop

    signals through drywall, excellent signal from ~60ft, through 1 floor

    with regard to dropping connections, yes and no... with SSID broadcast enabled i didnt get a dropped connection... period

    with SSID disabled i do ocassionally get a dropped connection where it doesn't recognize the AP and i have to re-associate (this is on the intel n-card... the other g-cards all work fine)
  66. rhody401

    rhody401 LI Guru Member

    Im amazed that the 10.2007 version is still up on the site. I hope they're not shipping with that version, as it's a nightmare.

    1.1.08 beta has been pretty decent for me!
  67. Blommen

    Blommen Addicted to LI Member

    Do you use torrents? For me the router stalls all Internet traffic after a while if I run torrents (with all FW's I have tried...
  68. Sandokan

    Sandokan Addicted to LI Member

    I found this page in Linksys website:

    They report a v2 version of WRVS4400N (in bottom of the page).
    I know there are 1.0 and 1.1 hardware versions (the 1.1 seems not to have the high pitch noise, mine is 1.1 and it is quiet), but there will be a v2 hardware or software version? (maybe both?)
    Looking at the web page it seems there will be a v2 hardware version, for this one there will be a new firmware version with TrendMicro Protectlink Gateway hosted service, and it is planned for november 2008, but for v1.x there is only a "TBD" acronym.

    To Be Defined?
    To Be Decided?
    To De Done?
    To Be Discontinued?

    There will be no new firmware for hardware versions 1.x (like other Linksys products)?
    I must keep the buggy 1.01.03 (or the 1.01.08 beta) firmware version?
    I must buy a WRVS4400N hardware v2 in order to get a new firmware version?
    What could be the hardware changes in the v2 hardware version?

    Someone knows something more?

    Thank you.
  69. bwhatley

    bwhatley Guest

    bump for anything new...
  70. Leigh Brand

    Leigh Brand Guest

    My problem and solution

    Purchased WRVS4400N and WPC4400N 7-2008. Both worked very well for 2 months untill I had done a demo at a friend's house. PLaced everthing back as it was, did a restore on settings. Then it was hopeless. Have read many articles and have followed advice from this forum and others. Yes sometimes my laptop linked up to the router but mainly I had to hook up a LAN cable to indentify the router first. Once indentified then I could remove the LAN and remain online. My PDA also had many problems with WiFi.
    Short solution.

    1st installation 7-2008 router standing on its 2 feet.
    2nt installation 9-2008 router for one day laying flat on the floor.
    3rd installation 9-2008 router mounted on wall using 2 screws.
    4th installation 10-2008 router standing on its 2 feet.

    Problem: Standing up is the temperature on the underside of router 34 deg. C.
    Laying down/against wall temperature underside 55 deg C.+ (limit of thermometer)
  71. DocLarge

    DocLarge Super Moderator Staff Member Member

    Leigh Brand,

    so you're saying that your problem had to do with overheating?

  72. studizzle

    studizzle Addicted to LI Member

    Hey guys, im using Firmware Version: V1.1.08 and i still cant connect to my home ftp server. Keeps timing out. I did a hard reset before i upgraded to the new firmware and since then ive done another hard reset then a soft reset. Any help?

    *Edit: Quickvpn connects but still cant access resources. The remote computer is not on a domain.

    Attached Files:

  73. studizzle

    studizzle Addicted to LI Member

    Problem solved, powered down and did another hard reset then changed the ip of the ftp server and now everything works.
  74. Dobermann

    Dobermann Addicted to LI Member

    I too am a frustrated WRVS4400N version 1.0 owner. No solutions or advice provided by Linksys has proven useful. Now with version 2.0 looming in the horizon I feel very angry toward Linksys for their abandonment of us version 1.0 owners. Linksys is behaving like a cat in the cat box. You know the cat took a dump and covered it up but you still smell it. Linksys will quietly sweep the flawed version 1.0 under the rug and move on. No words can begin to describe my anger directed at Linksys. I too have no FTP support, no working VPN and have been living with this nightmare product for over a year. To add insult to injury Linksys refuses to aknowledge this product suffers from a hardware or design flaw. I for one am interested to find out if Linksys would consider an exchange program for the newer version 2.0 product. I have always been a fan of Linksys and own many of their products. But I stopped buying anything from Linksys since my troubles with the WRVS4400N. As I see it Linksys views us all as a herd of cattle. One cattle missing from the herd isn't missed. But what happens when the entire herd goes missing? What happens then Linksys?
  75. jb68

    jb68 Network Guru Member

    I opened it and inside everything is super hot. At this time is winter and room temperature is around 22 degree C. I think in the summer willl be different.
    I just added a torrent and it look like the processor went up.. so did the temperature.
    Inside there is a thin tin covering everything. I think some decent heatsink over processor and eventually for other hot sposts may help a lot. There is already some heatsink over something so that should go bigger ;)
  76. For now on "TBD" decrypted as "To Be Determined".
    But still "to be...", so there's no release date announced for new 1.x firmware :(
  77. Dobermann

    Dobermann Addicted to LI Member

    Total disregard for defective version 1.0 owners.

    There is nothing more infuriating than to see this on the Linksys website. As I posted earlier I believe that Linksys is silently sweeping the failed version 1.0 under the rug. It has become very obvious that there will be no further firmware releases for version 1.0. It is already well over a year since 1.01.03 which I am certain we will all agree was broken when released. I purchased this piece of junk because it was touted as a 'business class' product. It turned out that everything Linksys said it was - wasn't. After over a year of living with the piece of junk and waiting with anticipation for new firmware that actually works I find myself losing all hope that this product will ever perform as advertised. Still I have no working VPN solution, my main reason for buying it. I have tried in vain with third party VPN clients to make this work and still nothing. I need to use FTP almost daily to update clients websites. Still, after over a year no FTP support either! What I do not understand is why Linksys seems to ignore these many issues. They seemly are ignoring them and moving forward with a corrected/revised/modified version 2.0 WRVS4400N. I am certain that these new versions have all the major issues fixed. I guess that we version 1.0 owners are only going to be left with a beta firmware version (1.01.08). And to add insult to injury 1.01.08 still does not address my many problems with this product. I am now left with no options other than to dump my WRVS4400N into the rubbish bin and purchase another VPN router from another vendor. That makes me so angry!! Clearly Linksys does not care about customer satisfaction. How stupid do they think people are. I for one will never purchase another Linksys product EVER AGAIN! Goodbye Linksys!!

  78. Dobermann

    Dobermann Addicted to LI Member

    Extremely Curious.

    Hello all,

    I ask this question out of curiosity. Has anyone been able to purchase and test/use the newer version 2.0 WRVS4400N? And if so does it still suffer the problems that plagued the version 1.x units? It would be interesting to see if version 2.0 performs as advertised. We know that version 1.x does not.

  79. Sandokan

    Sandokan Addicted to LI Member

    I think Linksys is a not a professional brand (despite of the "Cisco" logo they show).
    His hardware products are not very good (hw version 1.0 routers are very noisy, become very hot and then they crash), and they are absolutely unable to make a good firmare.

    If you need VPN i suggest to get another brand, like Draytek (
    They have a good product: Vigor 2950G, it is not wireless-n, it's expensive, but you can do everything you want (look at the Live Web Demo).
    I have not tried it yet, but if Linksys won't release a stable firmware for 1.x hardware version soon, i'll throw it away and buy the Vigor 2950G.

    In alternative, you could try this custom firmware version:

    Many people say it is working very well, it is under development, but it's probably better than the Linksys's one, despite of there is only one developer on it.

    In any case, my opinion is: "Never more Linksys products".


    P.S. Sorry for my english...
  80. jb68

    jb68 Network Guru Member

    I fixed most of router heating issues. I have HW 1.1 but should be similar on 1.0
    I did open it, used a tin scissors and I did 2 square openings, one above the Vitese (LAN/WAN) chip and the other above the 9202 chip (main CPU). In order to do this u need to have some skills.
    Vitese chip comes with a heat-sink and this chip goes really hot. Unfortunately linksys decide do glue down this chip only over about 30% of the chip!!. What I did was to open some room and glue-down this heat-sink on the right way. A bigger one would be better.
    CPU has a thermal compound between CPU and tin but there is no real contact whatsoever to help transfer energy. Here it depend of your luck. I marked down the place of the thermal compound, removed it and then cut 2 lines from the border and bend it to open the space over the cpu. This CPU got a heat-sink from an older south bridge chip. In this way chip is not thermal connected to the rest and will stay cool.
    The 3rd chip goes under the wireless board (used for wireless encryption??) and there is not an easy way to help it to stay cool. The only thing I did here was to add a slice of sponge between the wireless board and the tin beneath to harder press down the tin over the CPU. On my box the thermal compound was in the wrong spot covering only about 75% of the surface.
    Wireless board went very hot as well. There is a small coper stripe which looks like a thermal pipe ??? he he?? and that is glue down over the Wireless board on just one small point. I added the thermal compound removed from the CPU between this thermal pipe and the board in order to transfer more heat to main board.
    After doing this I powered the main board and everything was warm except Vitesse chip which is still hot (just at the point u can't keep the finger on it) but way better then before. I think a bigger heat-sink will do the right job.
  81. DocLarge

    DocLarge Super Moderator Staff Member Member

    Hello peops...

    My apologies for having been so absent for a while. Just wanted to chime in that I'm still using my version 1.0 WRVS4400n and I (after almost 2 years of owning) have "never" suffered the fate of the majority of you (knock wood I guess...).

    My only thought is that I because I got one of the first batch prior to mass production, more attention to detail may have been paid to the construction of the device. At this time, I'm able to do vpn client connections, vpn tunnel connections between linksys, other brand (i.e., netgear, smc, cisco) routers, and ftp file uploads/downloads. To this day, there has never been the loud whining sound that most of the users here have spoken of. My firmware version is 1.1.08. I may try 1.1.13 later to see what's new...

  82. mbernie

    mbernie Guest


    I jsut registered and noticed I was not the only one with issues with my 4400...I managed to find the 1.1.08 Firmware...haven't tried yet. Now I jsut read your last post and you mentioned 1.12 and 1.13??? Where can we put our hands on 1.13?


  83. rhody401

    rhody401 LI Guru Member

    I was planning to upgrade from the 1.1.08 beta tonight to the current 1.1.13 version

    You go through the whole registration process on the cisco website, click DOWNLOAD, and it says that the file is not found.

    Did it get pulled, due to some known issue? Is anyone running the Feb 2009 version? I have a version 1 lemon. 1.1.08 has been tolerable, but still many of the advertised features don't work. At least FTP does! :)

  84. DocLarge

    DocLarge Super Moderator Staff Member Member


    stay away from "ANYTHING" except 1.1.08!! As of now, 1.1.08 is the gold standard for Ver. 1.0 WRVS4400N routers! :) All other firmware bears problems (i.e., wireless dropouts, vpn tunnel disconnects, false IPSEC tunnel reporting, etc...).

    Mess with the other firmware at your own peril, but I have to say, I went 64 days without hiccups or reboots with 1.1.08 and only had to reboot when a thunder storm knocked the power out.

    Until I get a version 2 WRVS4400n, 1.1.08 is all I'm running on my ver 1.

  85. jlorre

    jlorre Networkin' Nut Member

    I had 2 problems with my WRVS4400N (manufactured may 2007, Serial No S08107500107) firmware 1.1.13-ETSI
    - after some months of use it started making a whining noise (5700 Hz) (see also )
    - it crashed every week. it was not stable because this device appeared to have a heat management design flaw.
    The noise was effectively eliminated by gluing some silicone rubber compound between the two large coils. I solved the stability problem by adding 2 heatsinks and a fan in the box. Below you can see some pictures of my modification.
    Boo :-(( for Linksys because of not admitting this blatant thermal design error that could even be understood and solved by an amateur like me. This caused a lot of time loss and aggravation for many people that were left in the dark, while supposing the solution was in firmware patches and trying other settings etc. while it was a simple hardware-thermal problem.
    Below some pictures of my modification: recommended!
    pic1: in the lower left corner you see the coils with added silicone compound in between them. Do not add to much on top or you will not be able to refit the tin. You can also see the heatsink, cut from an aluminium L-profile and bended a bit to make contact with both hot chips (one at the front and one in the back). The heatsink is glued to the chips with a very thin layer of silicone compound. Wait for the compound to get firm (press it to the chips with something heavy during curing)
    pic2:mark and cut holes in the tin to let the heatsink through
    pic4: start reassembling the tin above the heatsink. You can also see the fan glued with silicone compound and fastened with a nylon strap.
    pic3: the daughterboard reattached above the tin and before it was shielde by it's own tin.
    pic5: the 12VDC wires of the fan can be soldered to the PCB in the corner so the fan does not need an external powersupply.
    Then close the box (mind the direction of the lid, it's difficult to see how it fits).
    After the mod my device was immediately running stable.
    I currently only use it as a switch and as a wireless access point together with a wireless Linksys WET200 bridge , i don't use its VPN- nor routing features. Now we're a year later and it is still working flawlessly. So now i'm sure i found the real cause of the stability problem in the original wrvs4400n: it was insufficient cooling!

    Attached Files:

  86. DocLarge

    DocLarge Super Moderator Staff Member Member

    Nice to know :)

    As for myself, I've still used the same one spoken of earlier "without" any of the issues many have spoken of, specifically the whining sound. I've continually used it for VPN (mostly site to site tunnels) and wireless access. Oh, the kicker; 1.1.08 is still the firmware of choice and runs flawlessly!

  87. williewiskers

    williewiskers Networkin' Nut Member

    Just registered to see these problems...

    I just registered to get info on the WRVS4400N V2 that I just bought. I was told by Cisco pre-sales support to make sure to get a hardware version 2 router.

    1.) Does anyone know if the hardware V2 has solved the heat problems?

    2.) How can I open the case?

    3.) What is the easiest way to mod the router to allow use of my own antenna?

    Ive spent over 10 hrs with Cisco support trying to find a router that has all the features of the WRVS4400N and also has a removable antenna and/or an external antenna port.

    Short answer is that they DONT make one, the WAP4400N is in the same case, BUT has removable antennas yet none of the routing or firewall functions.

    I have taken this out of the box, but not gone any further as I wont start modding this router for the antenna if its still riddled with thermal design problems

    Appreciate anyone who replies....
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice