UBER bricked router???

Discussion in 'Cisco/Linksys Wireless Routers' started by Crashmaxed, Jun 6, 2006.

  1. Crashmaxed

    Crashmaxed Network Guru Member

    I have a WRT54G v3.0 that I bricked like a year ago...but kept around in an anti-static bag in case I ever wanted to JTAG it (at the time I didn't know beans about linux so I said screw it...and bought another router). Now...I know some linux...so I pulled it out, wired up a header, made a JTAG cable...and off I went. I've backed up my nvram, cfe, kernel, and wholeflash. I would imagine that things are fine with my routers hardware because a) my broadcom CPU is detected correctly, b) my flash is detected correctly, c) JTAG (flash, erase, and backup) all seem to work just fine. My CFE.BIN seems to be intact as I cat'ed the file and piped it to "grep <mymachere>"...basically searched the file for my MAC of my router....and it found it. So I assume that the CFE.BIN is fine. The problem is that regardless of what I do I can't seem to unbrick it (The power/dmz lights still blink repeatedly). Here's what I've done so far:
    1) wireup passive JTAG and compile wrt54g flash util - props to hairydairymaid
    2) get laptop parport0 running
    3) backup nvram, cfe, kernel, wholeflash
    4) ERASE nvram
    5) test router - still blinking
    6) suspected firmware corruption (router bricked because failed web-install of firmware) - download newest default linksys firmware for the WRT54G v3 from their website. Rename to "kernel.bin". Run "./wrt54g -flash:kernel"
    8 ) reboot (unplug and replug) - lights still blinking
    9) since i'm noob at JTAGing....expect that it needs some sort of NVRAM at least??? - reflash backup'ed nvram
    10) reboot - lights still blinking
    11) erase nvram
    12) download newest build of thibor hyperwrt 15c (currently installed on my OTHER WRT54G v3.0 <<< unfortunately not JTAG capable at the moment.....not willing to risk hurting that one too)
    13) rename it to kernel.bin and run "./wrt54g -flash:kernel"
    15) reboot - lights still blinking

    Any ideas? If I missed some important step please tell me as I've never managed to resurrect a WRT54G via JTAG since this is my first time.
  2. anectine17

    anectine17 Network Guru Member

    Are you flashing the firmware via JTAG or ethernet? Ethernet is much faster....like a few minutes. I would suggest doing that if you're not already. After you get "Operation Successful", give it some time to reboot on its own. Also, try one of the firmware upgrade utilities for flashing the firmware as opposed to using the command prompt (sorry, I'm a Windows person, not sure what it's called in Linux). Also, have you tried a different/new CFE? You can create a new CFE based on the MAC on the bottom of the router.

    You can download Skynet Repair Kit here.

    Or go here and create the CFE remotely then download it to your PC.

    What worked for me on a totally dead v. 2 was, after backing things up, performing an erase:wholeflash, then a flash:cfe over JTAG (takes about 10 minutes), then flashing the firmware over ethernet using an upgrade utility.....that took about 30 seconds. The router rebooted on its own about 2 minutes later and JOILA!!

    Firmware upgrade utility found here.

    Get the utility set up, ie; router address & password entered, firmware location entered, etc. Then plug power to the router, count 1 Mississippi, 2 Mississippi, and hit enter on the utility. If it fails the first time, it will retry by default 3 more times. If those fail, hit enter again. It should go then. Again, once you get the "Operation Successful" message, wait for the router to reboot on its own......I've heard of people waiting a couple hours, but the longest iit's taken for me was about 3 minutes. Anyway, I hope I've been helpful.....I'm just learning all this myself!! Good luck!!

    Alden :thumbup:
  3. Crashmaxed

    Crashmaxed Network Guru Member


    I've done the TFTP method...but that didn't wanna work for me either. The method I was talking about (that I used) was JTAG. And I let it sti for like hours after I JTAG'ed it (was sleeping).
  4. Crashmaxed

    Crashmaxed Network Guru Member


    When I get back home from classes I'll flash the nice newly created CFE.BIN to my router and try your method *crosses fingers* - btw: thanks for you help ^_^
  5. Crashmaxed

    Crashmaxed Network Guru Member


    I erased the wholeflash and flashed the new CFE over.....now if I boot my router I at least get the failsafe mode....I can ping didn't work before I did any JTAGing. However, I've flashed the kernel via tftp (and later I tried JTAG as well), but haven't been able to fix the system.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice