Unable to access modem setup frm router..Only DD-WRT can do?

Discussion in 'HyperWRT Firmware' started by boobear, Jun 7, 2006.

  1. boobear

    boobear LI Guru Member

    Hi, can anyone help this? :) ...

    Problem:- Unable to access modem(Aztech 600E) setup page frm router(WRT54G).

    Current setting:

    modem (bridge mode;
    | to Wan port of router
    Router (pppoe;; Hyperwrt 2.1b1_tofu13c;
    | firewall script: ifconfig vlan1:0 netmask


    -Still can't access from IE
    -Accessing both and leads to router setup. :cry:

    -I read from other post saying that they've done it with dd-wrt.

    Can anyone provide some help for hyper users?

  2. Thibor

    Thibor Super Moderator Staff Member Member

    i'm currently doing it using the same setup you've described. i can't state for sure what you're doing wrong, but it's working just fine at my end.
  3. boobear

    boobear LI Guru Member

    :( Hi 'Thibor",
    I do hv some startup script as follow but dou think it somehow affects....

    echo 4096 > /proc/sys/net/ipv4/ip_conntrack_max
    echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts
    echo 1 > /proc/sys/net/ipv4/icmp_ignore_bogus_error_responses
    echo 512 > /proc/sys/net/ipv4/neigh/default/gc_thresh1
    echo 2048 > /proc/sys/net/ipv4/neigh/default/gc_thresh2
    echo 4096 > /proc/sys/net/ipv4/neigh/default/gc_thresh3
    echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts

    I=`nvram get wl0_ifname`
    while sleep 1; do
    if [ "`wl assoclist`" != "" ]; then
    XFER=`ifconfig $I|grep bytes`
    if [ "$XFER" != "$PXFER" ]; then
    LED="am on wh on"
    LED="am on wh of"
    LED="am of wh of"
    if [ "$LED" != "$PLED" ]; then
    led $LED

    - Do u think upgrading to 'thibor' will help?

  4. grcore

    grcore Network Guru Member

    Try adding this to your firewall.

    iptables -I POSTROUTING -t nat -o vlan1 -d -j MASQUERADE 
    ip addr add dev vlan1 brd +
  5. cgondo

    cgondo Network Guru Member

    thanks.....that works
  6. boobear

    boobear LI Guru Member

    Hi grcore, tried yr codes but still no luck...anyone pls help!

  7. grcore

    grcore Network Guru Member

    what version WRT54G do you have? I believe the v1.0 and 1.1 use eth1 as the wan IF
  8. boobear

    boobear LI Guru Member

    Hi Everybody,
    It works just fine now, :thumbup: special thx to Thibor & grcore...

    It was my silly mistake...I didn't save my modem ip when exit...hehe :thumbdown:

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice