unable to ping the router, but internet ...

Discussion in 'Cisco/Linksys Wireless Routers' started by FooL12, Sep 22, 2007.

  1. FooL12

    FooL12 LI Guru Member


    I have got a linksys WRT54G router (no firmware modifications).

    Since yesterday, I didn't have any wireless access from my laptop.

    I so tried to access the local web based utility of my router on from my desktop pc
    Doesn't work, even after resetting the router

    What is really strange is that I can get throug the internet, but cannot ping

    My IP adress is "automatically" in windows on my desktop which is linked to my router (which is linked to a dsl modem).
    My IP in ipconfig is not 192.168.1.xxx but looks like the scheme of my ISP ...
    As if my desktop was directly plugged to my modem ...

    Have you any idea ?

    Thanks a lot and sorry in advance for any english mistake ...
  2. mstombs

    mstombs Network Guru Member

    It seems as though the WRT54G has been put into "router" mode rather than "gateway" - I think that is right - it always seems the wrong way round!

    If you manually set the IP address on your PC to the local range of the router - us for example, you should be able to access the router on

    If that doesn't work there's always the reset button on the back!
  3. FooL12

    FooL12 LI Guru Member

    Thanks for your reply, but I have already tried both manually setting the IP and resetting the router ....
  4. HennieM

    HennieM Network Guru Member

    Assume you are using Windows on your desktop? If so, in a DOS prompt, type
    ipconfig -all
    From the display, you should be able to tell where your PC got its address from (DHCP server), etc., which might help with troubleshooting.

    If your IP address is 169.254.x.x, it means your PC self-assigned an IP address, and you will not be able to reach, as you are not on that subnet. However, your WRT may still be routing internet packets to/from your PC. If so, in the same DOS prompt, type
    ipconfig -renew
    from which you should get some information.
  5. FooL12

    FooL12 LI Guru Member

    No, my IP adress is given by my ISP gateway (smthg in 82.225.xxx.xx).
    As I said, exactly as if there were no router between my modem and my pc.
    Tried with another PC (laptop) and same thing.
  6. Toxic

    Toxic Administrator Staff Member

    do you have any proxy cache setup in your browser? this can have the same effect you are experiencing. other thing is to reboot the router just incase the httpd has crashed.
  7. HennieM

    HennieM Network Guru Member

    It seems your modem and/or WRT might be passing your PC's DHCP request on to your ISP
    Try (i) disconnecting (pulling the cable) your internet---modem connection, and renewing your IP address on the PC. If you still don't get a 192.168.x.x address, (ii) disconnect modem---WRT, and then retry. If you still don't get a 192... address, (iii) press and hold the WRT's reset button for 30 seconds, which should reset the WRT to defaults.

    Once you have a 192... address you should be able to get into your WRT to check things over. If you want NAT to happen on the WRT - this means the WRT is in charge of the internet connection, the WRT should be set to gateway, not router, and it's DHCP server should be on.

    Also perhaps see if you can get into the modem, and make sure those settings are correct. If you want the WRT to be "in charge" of the internet connection, the modem should be set to "dumb" mode; i.e. the modem should NOT have a DHCP server, should not do NAT, etc., and the setting on the WRT for the WRT---modem connection should probably be PPPoE or some other protocol where you can specify a username/password on the WRT.
  8. FooL12

    FooL12 LI Guru Member

    Thanks a lot for your help.

    Unfortunately, I already tried all that and more.

    When I try ipconfig /renew not plugged to my modem, it didn't work (smthg like "connexion timeout")
    And a ipconfig /all tell me that I am in 169.254.xxx.xx

    Even after power down or reset the modem, it doesn't change.

    I really don't understand anything ....

    re-plug in the internet connexion to the modem and then it work.
  9. ifican

    ifican Network Guru Member

    One thing thats not been mentioned is make sure your modem is connected to the wan port on the wrt and not the lan. If need be connected wired to your wrt and make sure you get a 192 address. The only thing that makes sense is you are not cabled correctly or you are forwarding your dhcp requests. I suppose on the way out side someone could have gotten into your router and changed the lan ip to the range you are getting but that is really way out on a limb.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice