Unable to ping wireless router running wpa tkip

Discussion in 'Networking Issues' started by rockbeth, Feb 4, 2007.

  1. rockbeth

    rockbeth LI Guru Member

    I am working on a small network for a local business.

    I previously installed a AP linksys wireless router with 4 port LAN (wrt54g I believe). The access point is connected to the internet by its internet port.
    The original installation had 2 wired PC’s to the AP and one wireless dell laptop using WEP encryption connecting through the wireless. All worked well.

    All of the PC’s where XP machines with SP2.

    All PCs have their own assigned IP Addresses:
    AP Wireless router with 4 ports LAN
    PC1 Personal Computer, XP, SP2 Hard Wired to LAN Port 1
    PC2 Personal Computer, XP, SP2 Hard Wired to LAN Port 2
    Laptop Wireless WEP

    Recently the customer wanted an older PC connected to the network for Internet browsing.
    It is and older dell machine using Millennium OS.

    I installed in one of its USB ports a Belkin wireless adapter.
    During setup of the belkin USB adapter it did not allow for WEP encryption, only WPA. So I had to reset the AP router to WPA, I assigned it an encryption key and set it to use the TKIP.
    I then set the Millennium Box to the same encryption type and so forth to match that of the AP. I also did the same to the Wireless Laptop.

    The problem that I am having now is that I cannot reach the internet through the Wireless machines; they both are able to connect to the wireless AP and have a good connection using the WPA encryption. I did a ping from them to the AP to know avail. I cannot get through. The other two PC’s that are hard wired are reaching the AP and the internet.
    I have done all that I can think of, I need your help. Please reply.
  2. RTSAnime

    RTSAnime Network Guru Member

    Are the wireless computers getting an ip address? If not then you must have messed up while typing the WPA keys
  3. rockbeth

    rockbeth LI Guru Member

    yes, I have thier IPs asigned manually and not by the DHCP from the AP. If the Keys where messed up would I still be able to connect to the AP? I'm showing that I am connected to the AP in the wireless connection screens on both client machines.
  4. ifican

    ifican Network Guru Member

    A couple thoughts, tkip can have issues at least in my experience. I have used it quite a bit but ended up on AES as it is much more stable for me. Second, you say you can access the AP but cannot ping it, that does not make sense at least from a networking stand point. Yes there are reasons that can create such a scenario but on a basic level should not be affecting you.

    And i would recheck your keys, you will still see the AP and the signal for it even if you have the incorrect key.
  5. rockbeth

    rockbeth LI Guru Member

    Ill try the AES and see if that helps.
    Let me go deeper into how I setup the wireless client connections.
    The AP's broadcast is shut down, so I manually configured the ID and set the key and protocol for the WPA on the 2 client PC's. then I was able to see the ID of the AP. I then clicked on connect. In both client PC's, each one started to make a connection and then they said they did in fact make thier connections to the AP. So I tried to access a web site to no avail. I then ran the ipconfig utility and checked my settings, all agreed to what I had manualy set them to including my dns numbers as given by my ISP. then I ran the dos Ping and aimed it at the which is my AP. and it told me that the connections could not be made. ~shrugs~
    Should I turn on the broadcast ID of the AP and the DHCP and see if I can get it to work instead of the manual config? does WAP require the broadcast ID to be seen in order to initiate its initial connection?? If I had the wrong Keys would they have shown that they connected?
    Im Lost lol.
  6. ifican

    ifican Network Guru Member

    You know those are all very good questions. I used to hide my ssid and to be honest that is when i was using tkip the most and having the most issues. I have since become less anal and just make sure i have a strong key and find i have far less issues with reliability when broadcasting vice not broadcasting the ssid. There is never any harm in testing everything to see what the issue might be, yes i would turn broadcasting on and see if that works, and then very meticulously work through all the details until you find the one thats giving you the grief.

    Does wpa need the ssid broadcast, no.
    It should work via static but one piece at a time.
    Wrong keys should not have produced a connected however we are not sure it really is connected.
  7. crawdaddy

    crawdaddy Network Guru Member

    I know with WEP encryption, if you enter an incorrect key on the client, it will appear in windows that you have connected, but you will not get an IP or hav access to the network. This has tripped me up a couple times myself. I've also noticed that trying to run stronger encryptions on longer links doesn't work too well... Hope this helps
  8. Neo_Giles24285

    Neo_Giles24285 LI Guru Member

    i've found the same as crawdaddy and how more secure connections seem to not work over the same distance as say a WEP encryted connection would.

    i'd also set ssid broadcast to on and dhcp on and start with no encrytion and work upto wpa, trying wep and the like and static ip's to make sure you connect ok, then work through it slowly.

    also i think windows would show as connected but you'd get no actual connection cause the ip wasn't registered within the router as authenticated, hence not being able to ping the router ;)
  9. rockbeth

    rockbeth LI Guru Member

    Thanks to everyone that posted to this thread, I was able to get the laptop to work with the WPA by reentering the key in both the AP and the Laptop but the desktops usb wireless to no avail, Im thinking that I am missing some files in the old millenium system, I went ahead and tested the hard wired ethernet port on the Millenium system by bridgeing th laptops wirless port to its ethernet port and used a crosover cable to connect them. The Millenium machine is working so I recomended to the customer that since it was just a short run to the AP that we could hard wire it cheaper instead of reloading the OS in the old Mellenium Machine. Thank you all again for the help and the info.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice