Unbrick a WRTSL54GS

Discussion in 'HyperWRT Firmware' started by tcsdoc, Jan 22, 2007.

  1. tcsdoc

    tcsdoc Network Guru Member

    Something went wrong with my flashing of the router and now the power light flashes constantly. I've tried the usual Linksys recommended revival tips but to no avail. I can't ping the router, I've setup the half-duplex, 10mbit connection, and the power button/reset button. Any other tricks I can try? I haven't opened the router and don't know of any posted instructions on unbricking the router by shorting pins.

    Need some help and all inputs are welcome..
  2. Thibor

    Thibor Super Moderator Staff Member Member

    shorting pins is not necessary, at least i have NEVER needed to do it, and i've bricked mine a lot.
    1. set a static ip on your pc,
    2. copy replacement firmware to c drive and name it code.bin(not really necessary, but keeps things simple)
    3. open a cmd window, start>run>cmd<enter>
    4. type "cd c:\", this will put you at the root of c drive
    5. type "tftp -i put code.bin" but don't press enter yet
    6. plug in your SL and then press enter, the ethernet light on the sl will start blinking rapidly as the firmware is transferred over.
    7. now just wait for it to restart when it's done, don't pull the plug out or anything, just wait.

    if this doesn't work, you didn't time it right; so try it again, and again until it works because it will eventually. i've found through time with these routers, that the SL is actually the easiest of all of them to debrick, they always get revived and never need any pin thingy done to them.
  3. tcsdoc

    tcsdoc Network Guru Member

    Reviving WRTLSGS

    I followed your instructions and understand about the timing. I setup the ip as, gateway

    I plugged the Ethernet cable into port 1.

    I entered the command in the command prompt, plugged in the power cord, then pressed enter.

    I run DUMeter to monitor the transfer and can see some type transfer ( .2kbps) but I get a timeout error message. Given the size of the file (almost 8mb) I know the upload is not taking place.

    I will keep trying and hope I can hit the 'window' for the router to accept the tftp transfer. Please let me know if I'm doing anything incorrectly.

    Thanks for your quick reply to my previous message!
  4. Thibor

    Thibor Super Moderator Staff Member Member

    try hitting enter, and then 1 sec later plug it in
  5. tcsdoc

    tcsdoc Network Guru Member


    I have tried so many combinations, both before and after plugging in the router. I have double-checked my settings. Everything is as it should be. But it's not working....

    I cannot get the router to accept the transfer. Timeout errors. I even tried using my Mac to establish the connection but the results were the same.

    Now I'm desperate.....

    I read one post that stated shorting pins 5 and 6 would allow the tftp connection but then read another post stating I should short pin 16 to ground. I can't find verification of the proper pins to short on the WRTSL54GS. There's just not a lot of info out there that I can find.

    I really appreciate your help, Thibor. If you can think of anything else please let me know.

    If anyone else can provide additional insight, I would appreciate it.
  6. shadow2k6

    shadow2k6 LI Guru Member

    Thibor's instructions are excellent (he certainly has a lot more experience than I do on this). The only other thing I'd add is that in my minor bricked router experiences, the router would respond to ping briefly before going unresponsive again. To get the timing right, I would open 1 window with a ping -t and then in the other window the tftp command. As soon as the router starts to respond to ping immediately hit enter on the tftp command. This worked like a charm for me. When I did mine, I also used the latest linksys firmware and then reverted back to Thibor's firmware. I'm sure there are better ways to do this, but this worked for me.
  7. Thibor

    Thibor Super Moderator Staff Member Member

    i'm not sure if you will find verification on what pins are shorted, like i said; i've never done it, never needed to. tftp has always worked.
  8. tcsdoc

    tcsdoc Network Guru Member

    I tried your suggestion, shadow2k6, but no luck. The router never responds to a ping. I let it run continuous, even unplugging/plugging in the router during the ping sequence, but no acknowledgment.

    I think the pin shorting trick will be my final option if I can get the correct pins to deal with.

    But I'm still open to any/all suggestions!

    Thanks to everyone for their help.
  9. shadow2k6

    shadow2k6 LI Guru Member

    Ouch, you're over my head on this one then... You'll need to wait for someone else to post on this one.
  10. tcsdoc

    tcsdoc Network Guru Member


    YEAH! Router 0: Me 1

    I read a post stating to short pins 5 and 6 while applying power. Once done, start your transfer with tftp.

    Worked like a charm. Router is back online and working great. Thanks to Thibor for his great assistance and the feedback from others.

    Thanks everyone!
  11. Thibor

    Thibor Super Moderator Staff Member Member

    you're welcome, pleased you got it back :)
  12. 1998chevy1500

    1998chevy1500 LI Guru Member

    You wouldn't happen to have a link to what pins are 5 and 6 would you?? Are they the main pins on the Broadcom chip or something else?

    Thank you,
  13. tcsdoc

    tcsdoc Network Guru Member

    Pins 5 and 6 on the Intel Flash memory chip

    On my router, the Intel chip is the plain looking chip with a sticker on top. It's a TE28F640 chip located in the middle of the board next to the rf shield. Pin 1 is next to the small circle indention on the top of the chip. I placed a paperclip across pins 5 and 6, plugged up the router, removed the paperclip, then started the tftp per Thibor instructions.
    I monitored the transfer with DU Meter and it's a very quick download (Thibor 16b). The router is in service as I type..... ;)
  14. 1998chevy1500

    1998chevy1500 LI Guru Member

    Thank you for the help.

    Also I have read in a few other locations about shorting pins 15-16 and also 16-17, is this a variation depending on the version of the router? Is there anything to loose by choosing the wrong pair of pins?
  15. 1998chevy1500

    1998chevy1500 LI Guru Member

    Never mind I think that I found the answer.

    If it is a WRT54G with a 4MB flash (Intel/AMD) then you need to short pins 15-16

    However for a GS with a 8MB flash (Intel) then you short pins 5-6

    link to where I found the info http://forum.openwrt.org/viewtopic.php?id=580&p=1

    If anyone has any other suggestions or ideas post them up.
  16. stangri

    stangri LI Guru Member

    Thanks alot, another WRTSL54GS unbricked by shortening the pins. Couldn't revive it for about two months, almost sent it back!
  17. Bird333

    Bird333 Network Guru Member

    My router is still bricked even after jtag. I think I need a new CFE. :(
  18. fishmanchina

    fishmanchina LI Guru Member

    Help! I am having the same problem with tcsdoc, the power led is shining intervally, and the USB led is constantly light, if I pulg the lan wire, that led will light constantly. I tried all the solutions previous mentioned to retrive it back, but failed. even the pin 5,6 and pin 15,16, and pin 16,17. the hardware I am using is WRTSL54GS v.1.1. The worse thing is, I just bought it two hour ago, and after flashing the dd-wrt, v24, v23. I got the problem.

    Help! I really need your people`s help!!!
  19. Thibor

    Thibor Super Moderator Staff Member Member

    if the dmz light is lit, you can tftp stock firmware back onto it. download the firmware from linksys and tftp it over.
  20. fishmanchina

    fishmanchina LI Guru Member

    Thanks for the reply, the thing is , I can not ping the, it is not reachable. I have already set the local ip, and the netmask
  21. Thibor

    Thibor Super Moderator Staff Member Member

    then if you've tried the pin short trick(voiding your 2 hour old warranty in the process), and it didn't work; i guess you're screwed unless somebody in the DD-WRT forum can help. also, you could try connecting your cable into each port, including WAN to see if you get a response from any of them.
  22. fishmanchina

    fishmanchina LI Guru Member

    I read many posts, but still not quite sure about that I found the right pins. can anyone give me some directions? thank you very much~!
  23. Bird333

    Bird333 Network Guru Member

    Good luck with yours. I think my problem would be solved if I could find a working CFE for this thing. My jtag works but I can't get this thing revived.
  24. fishmanchina

    fishmanchina LI Guru Member

    Hi Bird333, what is your suggestions about my situation?

    I flashed the v24, then again flashed v23. and the router dead.
    Now the power led is shining frequently, the USB led is light constantly, other led works as normal. my hardware is WRTSL54GS v1.1 I tried everyting to ping through the router, but failed.

    Any suggestions?

    Thank you for replying!
  25. Bird333

    Bird333 Network Guru Member

  26. fishmanchina

    fishmanchina LI Guru Member

    I dont know how to JTAG. There is no other solutions?
  27. Bird333

    Bird333 Network Guru Member

    Here are the jtag points for the wrtsl54gs http://wiki.openwrt.org/OpenWrtDocs/Hardware/Linksys/WRTSL54GS

    Here is some info on jtaggin http://wiki.openwrt.org/OpenWrtDocs/Customizing/Hardware/JTAG_Cable

    If have tried to hard reset it, and tried to time the tftp transfer, I would jtag it. You could try a serial interface recovery, but that also requires a hardware mod. You could try shorting pins, but I wouldn't do that you may permanently fry the router. Unfortunately, you will probably have to jtag it, but atleast you have a cfe you can use.
  28. K1nslayer

    K1nslayer LI Guru Member

    Unbrick WRTSL54GS by shorting pins 5,6

    Just wanted to make a note here for future generations. I was able to successfully un-brick my WRTSL54GS using this method! This saved me from having to make a JTAG cable and finding a computer with a parallel port. I had screwed up the NVram and the standard methods were not working.

    There is a good guide to the standard tftp flashing methods here:

    In my case I needed two extra bits of information to get things working correctly.
    1. I was using a MAC and the Ethernet connection kept going down every time I unplugged the router, so I needed to connect up through a hub to get it working.
    2. Once I shorted the pins and could successfully ping the router, it wouldn't accept a standard version of Tomato (1.28) so I needed to get a special version from the dd-wrt site here:

    The basic procedure is to setup your PC in the standard way (static IP, gateway) and start a looping ping to the router at that same address.
    Then unplug the router, short pins 5&6 on the Intel chip with a wire and plug the router back in. Keep shorting the pins until you see the pings start to be successful. Then just start your tftp as normal.

    Here is an image of the guts, the correct chip has a red sticker on it in this image. As stated above pin 1 can be found by looking for the small indent is the corner of the chip.

    Attached Files:

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice