Unbricking a wrt54g v1.1. - unsuccessfull

Discussion in 'Cisco/Linksys Wireless Routers' started by ryley, Oct 7, 2008.

  1. ryley

    ryley Guest

    I couldn't get a VPN connection through the linksys firmware so I did this:

    Loaded Tomato - still couldn't get VPN.
    Loaded DD-WRT on top of tomato - when trying to set up the service for vpn in DD-WRT i lost the wireless connection.

    To get back the wireless connection I loaded Tomato back - at this point the router was bricked.

    I tried to unbrick it with the reset method, with the 15-16 pin connection while powering up method, with grounding pin 16 method, nothing worked.

    The problem I'm having si that while I am getting three pings from the router during a power cycle, I am not getting any more after that. Anything I tried during the period when I can ping the router didn't work - tried to use linksys firmware with the linksys utility, or just load the linksys firmware with tftp, or load DD-WRT with tftp. I am getting the following message while running tftp - request timed out.

    Is there anything left I can try? Beside buying another router I mean :)
  2. mstombs

    mstombs Network Guru Member

    Clearing the nvram via JTAG is a known solution in some cases. But this will not fix a hardware fault and flash pin touching is risky! Have you check the PSU and/ or tried another?
  3. gixxum

    gixxum Addicted to LI Member

    i have a wrt54g that i bricked a few times. the only way i could get it back was to ground out 15-16 pin with a copper wire grounded on the antenna connector (earth).

    to use the tftp method you have to set your ping timer with "ping 192.168.xxx.xxx -t -w 10" and just let that run
    also have open another command line or your tftp software.
    if using command line, navigate to where the firmware file is you want to upload. type in "tftp -i 192.168.xxx.xxx PUT name_of_firmware_file.bin" to the command line, but dont execute it yet.

    then you will proceed to do the unplug/ground procedure.

    the second you see your pings reply, hit enter on the tftp/ tftp command line...you have a very small window to catch it when it will accept this connection. if it works, you will see the tftp say "successfully uploaded in 6 seconds" or something...you might need to try this a few times....

    i kept missing that window due to not having the ping timer set with -w 10 ....which sets the time out faster...

    hope this helps

    edit: the only weird problem i seem to have (for a long time now) is i can upload my rom via tftp mentioned above as I am plugged into a LAN port....but when the router is up and running, my lan/wan ports dont respond ..iif i ping, the light blinks for activity, but no reply...cant log in via web gui. over wireless i can do all that..i think its funny. i have no clue why....i just use this box now as a repeater
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice