Uninstall OpenWRT and Flash with DD-WRT

Discussion in 'DD-WRT Firmware' started by freddy123, Sep 28, 2007.

  1. freddy123

    freddy123 LI Guru Member

    I have bought WRT54G v2.0 router from eBay. It comes with a very old Openwrt firmware as shown below. How can I reflash with DD-WRT or original Linksys firmware? I have tried TFTP but always time out. Very frustrated.
    I have very basic Web GUI for Openwrt but it does not have firmware upgrade page. I don't even know what Web GUI is that one as there is no name or ABOUT in Web GUI.
    I have set my router IP to

    I have tried WinXP tftp command and Linksys tftp.exe tool. Nothing works always time out.

    I have tried to reset router with below methods before I flash, but nothing seems to work out:
    1. I have tried reset the router by holding reset button (30s) while router is still power on.
    2. Tried power on router wait for DMZ light turn on then hold the reset button (2s) but DMZ light does not flash 3 times per sec. It just turned off

    Please HELP!!!

    BusyBox v1.00 (2004.11.23-09:18+0000) Built-in shell (ash)
    Enter 'help' for a list of built-in commands.

    _______ ________ __
    | |.-----.-----.-----.| | | |.----.| |_
    | - || _ | -__| || | | || _|| _|
    |_______|| __|_____|__|__||________||__| |____|
    |__| W I R E L E S S F R E E D O M

  2. freddy123

    freddy123 LI Guru Member

    Got it to work finally. Set PC and default gateway to

    Open 2 CMD windows (WinXP)
    one use to ping the router all the time.
    Second one use to tftp -i PUT firmware.bin

    Turn the router power off, then first CMD windows will show no reply hardware error etc. Turn the router on. As soon as you see the CMD window with reply. Start tftp on second CMD ASAP.

    Hope this help!!!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice