[Updated] Freezing downloads with dd-wrt v22R2

Discussion in 'DD-WRT Firmware' started by Chyper, Aug 17, 2005.

  1. Chyper

    Chyper Network Guru Member

    Hi there,

    i'm using DD-WRT #22 R2 on an WRT54GS v1.1 and have some problems downloading some files. For example freeze the download of the .exe file of Google Earth exactly at 81,4 kb. Regardless if i download the file directly over http from the Google Earth website (http://kh.google.com/download/earth/index.html) or try downloading it from a friends ftp server. The same phenomenon is with some other files. (with different filesizes/filetypes and a different "freeze-points")
    The non-working files are rare. Mostly i have no problems downloading something, but then there are these exceptions :-(
    (the problem existed with prefinal4 also)

    Does somebody know the problem and have maybe a solution for it?


    I just installed the original Linksys Firmware (v4.70.6) and the problems are solved. So i think it must be a bug inside of ddwrt.
    Too bad that i must sick now with the original firmware :/
  2. hchady

    hchady Network Guru Member

    install the dd-wrt v23
    or simply set the cpu frequency to 216
    telnet your router, then type :

    nvram set clkfreq=216 [enter]
    nvram commit [enter]

    latest linksys firmwares are running on 216 MHz
  3. Chyper

    Chyper Network Guru Member

    Thx for your post, but i will stick to the org. linksys fw until the final version of dd-wrt v23 is released.

    Hm what exactly has the cpu-freq. with the problem to do?
  4. devil-strike

    devil-strike Network Guru Member

    in some cases the router died if you set the cpu clock higer, i have don e it with 3 v 2.2 and al 3 routers died whene i set ce cpu to 216, the only way to fix it is go to the shop for a replacement.
  5. Chyper

    Chyper Network Guru Member

    yes, but i dont think that the problem with the freezing downloads has anything to do with the cpu clock rate. I had never changed the clock rate (and dont plan to do it anyway).
  6. Thrasher

    Thrasher Network Guru Member

    v22 R2 is a great firmware. Never had any problems with it over wired connection.

    The post about increasing cpu speed on router is stupid, ignore it. The only time you might want to do that is if you are using your WRT on a VERY busy network. In which case save up and buy a router more suitable to the job ;)

    I would reflash back to v22R2 cos it is a very stable firmware and shouldn't cause you any problems.

    Download freezes can be caused if your ISP uses an invisible proxy. If you get it again try doing CTRL+F5 in IE to force a fresh copy to be pulled from web site. F5 alone will only cause proxy to give you what it has again.

    i get it now & again with NTL here in UK.
  7. Chyper

    Chyper Network Guru Member

    yes, the firmware is great, but it is useless to me, if i cant download some files because the firmware can't stand the CRC or whatever of th e file and stop transfering it :)

    I doubt that it's a problem with my ISP. I tried it over two different ISP's with the same result. And i tried various ways to transfer the file too. (http, ftp, dcc) Always the freezes at the same "transferpoint".

    I think v23 uses the new linksys sources, so maybe the bug is fixed in v23. I will try it again as soon as the v23 final is released.

  8. Thrasher

    Thrasher Network Guru Member

    You've got a long wait mate, it isn't even in beta format yet.

    For the sake of 10 minutes I would give v22R2 a 2nd chance, if you need the extra features of it over the Linksys original firmware of course. The current version of which works really well too :)
  9. will792

    will792 Network Guru Member

    I downloaded Google Earth with WRT 54G v.2.0 running 22r2 without any problems. Did not have a single problem downloading files in 4 weeks since installing DD-WRT. Cannot think what would cause the freeze for you.

    P.S. By the way I do not recommend overclocking a router since it creates big problems for some hardware versions (apparently 2.2 and 3.0 are OK but 2.0 is not)
  10. Jeffrccar

    Jeffrccar Network Guru Member

    I have a WRT54G 1.1 running DD-WRT #22 R2.
    I have had problems with this to fix this you must go to Administration and find the IP Filter Settings sections. Put the Max ports to 512, TCP Timeout to 1800, and the UDP Timeout to 1800.

    On the topic of overclocking, i believe Brainslayer disabled it in the DD-wrt #22 R2.
  11. JohnSK

    JohnSK Network Guru Member

    Overclocking is not disabled in v22r2. I am running at 240MHz and get no more lock-ups when transferring files over WLAN. I also have a Zalman passive heatsink fitted on the Broadcom chipset just to make things cooler.
  12. Chyper

    Chyper Network Guru Member

    its not a problem with overclocking. Either the transfer over WLAN (the freezes were on hardwired LAN too). Use the org. Linksys FW now since a few days without any problems.
  13. WirelessOverSand

    WirelessOverSand LI Guru Member

    UNDER Clocking!

    Hi, new to this game but finally took the step and loaded 23SP1 onto my v1.1 54GS.

    The router is located on the roof, in full glare of the desert sun. I have installed it in a reasonably well ventilated weather-proof box, and stuck a fan on the outside of the router (with extra holes in the WRT to let the air circulate)

    I wanted to increase the TX power as the WRE "range extender" on the system had gone t1tsup, to help a neighbour get access (yes, I know he can't increase his power, but I normally have the power set below standard, to avoid cooking things at 45 degrees in the shade - and there ain't no shade!).

    As I have done with a number of computers here in this hot climate, I decided to under-clock the WRT to 192 MHz, to "give things a chance". But that caused a problem - I couldn't access the web. Fortunately I was still able to web-access the router and switched back to DD-WRT's default of 216.

    Doesn't the 54GS v1.1 like underclocking?
  14. Chyper

    Chyper Network Guru Member

    Can't say much about the underclocking topic, i change the clock speed from 216 to 200mhz without problems.

    About the main topic, i updated to V23 SP1, and until now, i havn't encounterd an transfer "freeze". So i hope it stays that way - maybe the new linksys sources which are used in v23 solved my strange problem.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice