"Upgrade are failed!" Linksys router refusing to upgrade firmware

Discussion in 'Cisco/Linksys Wireless Routers' started by Mjolnir1134, Aug 21, 2006.

  1. Mjolnir1134

    Mjolnir1134 LI Guru Member

    Today, I went to Circuit city to buy a linksys router. It was that one that was selling for $50 that I was planning on getting for a while.

    Now that I have it, its been having a problem keeping me connected to the Internet. After a while, the router will drop my connection going to the modem, yet I can access the router's settings without a hitch.

    To temporarily remedy this, I had to unplug the router or reset it, yet it the dropping connections still persist.

    I went to the linksys support site and downloaded a firmware upgrade. (v4.30.5)

    After extracting the upgrade file from the ZIP folder, I went to the firmware upgrade page in the router's settings. After selecting the .bin firmware upgrade file, the router immediately brings me to a page going "Upgrade are failed!" with a Continue button that leads me back to the firmware upgrade page.

    Despite the error message, I can see progress going in the firmware upgrade progress bar going up to 3/4's the way, and after that, a pop-up appears giving me the blasted "Upgrade are failed!" message.

    Anyone have any idea on how to upgrade this router so it can upgrade its firmware and hopefully fix my disconnecting problem?

    Router: Linksys WRT54G
    Current Firmware version: v1.00.6
  2. Thibor

    Thibor Super Moderator Staff Member Member

    your problem is that you have a v5+, you can't easily load linux based(4.30.5) firmware on it. check the dd-wrt forums for some tips for vxkiller, they will help
  3. Mjolnir1134

    Mjolnir1134 LI Guru Member

    Ok wait, I accidently downloaded the WRONG FIRMWARE from the linksys site.

    I thought the versions of WRT54G routers meant to be for firmware, and I downloaded the firmware from v1. So I went ahead and checked the version number on my linksys router and it said v5, so I downloaded the version 5 firmware and my router updated its firmware successfully.

    That was a good thing, but the bad part is that my connection still drops every now and then, still remedized by a power cycle.. :(

    anyone have a solution?
  4. Toxic

    Toxic Administrator Staff Member

  5. Mjolnir1134

    Mjolnir1134 LI Guru Member

    sorry for not responding sooner, but the problem was solved in the cleanest way possible:

    I still kept the 1.00.9 official linksys firmware, and then i disconnected the power from the modem and the router. I then turned my pc off.

    I waited for about a minute...

    And then I plugged in the power to my modem FIRST...waited for it to detect internet connection....success.

    Plugged power back into router...success in detecting connection.

    Turned my PC on...the Internet connection hasn't dropped and/or failed since. I played counter strike and WoW without disconnecting... let alone no lag :biggrin:

    So yeah, this problem here was first fixed by downloading the correct firmware, and then the internet connection problem was solved by no more than a clean reboot of everything.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice