Upgrade are failed WRT54G and WRT54GS

Discussion in 'Sveasoft Firmware' started by AmberPrince, Mar 14, 2005.

  1. AmberPrince

    AmberPrince Network Guru Member

    I am trying to upgrade the firmaware on several wireless routers. I was able to do it on the first router I tried, WRT54G. The next two routers will not upgrade at all. The WRT54GS is version 3.371, WRT54G is 3.036.

    No matter what I try I get the same error message, Upgrade are failed.

    Tried different computers. Disabling all Antivirus and Internet security software. Tried the upgrade from a computer that was newly loaded with Windows XP Pro and no other software. Tried multiple router resets to factory defaults.

    Can't understand how I got it to work once but not again. There doesn't seem to be any thread working directly with this issue, so I started a new one.

    Any and all help would be appreciated.
  2. jagboy

    jagboy Network Guru Member

    due to the fact that you have the lastest firmware linksys wrote in the firmware that you can not downgrade. so try using satori. for some reason this always works for me when i want to downgrade. or bick the router

    first i flash with satori then flash with what ever you want.
  3. AmberPrince

    AmberPrince Network Guru Member

    I'm sorry but I don't understand what you are suggesting. Is there something different you flash with other then the built in firmware upgrade through the administration tab?

    How do I flash the units?
  4. jagboy

    jagboy Network Guru Member


    click on this link and it will take you to the download section of linksysinfo. and click on a link wrt54g or wrt54gs depending on what router you have. download and unzip the files you just downloaded.now go to the routers setup page and go to the admin tab>firmware upgrade and flash with the binary file in the file you just unziped.

    now download a firmware that you like. and just flash using the web interface by going to administration tab>firmware upgrade page and that hould work.

    i really hope this helps!!!!
  5. jagboy

    jagboy Network Guru Member

    by the way what firmware are you upgrading to?
  6. AmberPrince

    AmberPrince Network Guru Member

    OK, thats where I wasn't clear. I am trying to upgrade to the Satori firmware. Thats where I am getting the error. I thought I had made that clear by posting in this particular forum, sorry for the miscommunication.

    I am going to try the Hyperwrt upgrade to see if the error is the same.

    Am I the only one having this error message on the Satori Frimware upgrade?
  7. jagboy

    jagboy Network Guru Member

    what router version do u have because satori dores not support certain router versions like wrt54g v2.2
  8. AmberPrince

    AmberPrince Network Guru Member

    They are both updated/current versions, I listed them at the beginning of this thread.

    I downloaded and was able to upgrade the frimware with HyperWRT. But I still cannot get hte Satori to load on the routers.
  9. jagboy

    jagboy Network Guru Member

    you were taking about the firmware version. i am talking about the router version.
  10. AmberPrince

    AmberPrince Network Guru Member

    Sorry, thought they were the same. I found the version number on the bottom of the WRT54GS is Ver. 1.1
  11. jagboy

    jagboy Network Guru Member

    i think that it should be supported. if you arent happy with hyperwrt then try dd-wrt it is a fork of alchemy firmware(in other words it is better that satori
    here is the link for th download

  12. chazcone

    chazcone Guest

    You are NOT alone with "Upgrade are Failed"

    I have a WRT54GS. According to the serial number it is v1.0, my LinkSys firmware is 3.37.6. I downloaded Satori 4.0, unzipped and tried to upgrade the firmware and got the Linksys equivalent of "All Your Bases Are Belong To Us"; that is, "Upgrade Are Failed".

    Looking for ideas as I really would love to tune my external antennae.
  13. rl096

    rl096 Guest

    Same problem here.

    I have same router version and same firmware as original poster. Cannot upgrade to Satori.
  14. AmberPrince

    AmberPrince Network Guru Member

    I guess there just isn't going to be a resolve to this issue. There doesn't seem to be much enthusiasm from the Techies here, or Satori. Guess the problem is limited to just a couple of us with no hope for a fix......
  15. dnarobber

    dnarobber Network Guru Member

    Satori : only for V1.0

    below the "features" of Satori as described in the download page.

    THIS IS FOR THE WRT54GS v1.0 (NOT FOR v1.1 or v2.0)

    GRTZ from impatient V2.2 owner.
  16. gnerd

    gnerd Network Guru Member

    ok, really stupid question but how do you locate the router version? There is a plate on the bottom of my WRT54GS that states model number WRT54GS, then the serial number and MAC address. There is no line that says router version. Is the version in the serial number? Mine is CGN10D605299.
  17. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    You have a wrt54gs v 1.0
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice