Upgrade are failed ... Yikes! don't give up!

Discussion in 'Tomato Firmware' started by najevi, Dec 6, 2007.

  1. najevi

    najevi LI Guru Member

    I just bought a second WRT54 style router via ebay with a view to participating in my region's wireless MESH network. The recent purchase is a WRT54G v2.0 with original Linksys firmware v4.00.7 installed. My pre-existing and very stable router is a WRT54GL v1.0 running Tomato v1.11.1217

    You may recognize the following from the Tomato firmware README file:
    Well, I was disappointed when the above procedure resulted in a web page with the message:
    Upgrade are failed

    within about 60 seconds of starting the upgrade to Tomato v1.11
    ... So I waited the full 2 minutes before clicking Continue to see if anything would develop and nothing did.

    After clicking Continue I was surprised/relieved to see the original Linksys firmware Upgrade.asp web page displayed; moreover it continued to show progress bar activity ... so I waited another 2 minutes only to find the same error message but this time it was displayed in a windows-style pop-up dialog box instead of on a web page:
    Upgrade are failed
    Being ultra-paranoid of bricking my recent purchase, I waited yet another 2 minutes to see if anything would develop and of course nothing did so I clicked OK and was once again relieved to find that the original Linksys firmware was running and I could verify that original version at the Status page:- v4.00.7

    So at this point there was evidence of a failed upgrade but the router was not bricked. The browser was using and not

    On a whim I tried installing DD-WRT v23 mini version for this WRT54G model and you guessed it the same sequence of error messages - first on a web page in red font and subsequently in a dialog box in black font. Still the router appeared to have preserved it's original Linksys v4.00.7 firmware.


    I may or may not have needed to close and relaunch the browser but I know that I did this because in the process of debugging this problem I wanted to reconnect to my trusted and stable WRT54GL v1.0 for internet connectivity and to search for help from this forum and via google. I was careful to never have both routers with IP address connected at the same time. Even so I think that my WinXP PC was getting confused by the switch overs and so I found myself "ipconfig /release, ipconfig /renew, ipconfig /flushdns"-ing and ultimately what appeared to work was to close and relaunch the (firefox) browser.

    Eventually the stroke of luck came. I pressed and held the reset button at back of the WRT54G v2.0 router for about 10 seconds. Then reconnected to that router, pointed my browser to and was presented with the username/password challenge. Well, blank/admin failed and that was TRULY bizarre because I was expecting to be returned to the original Linksys firmware.

    With baited breath I tried root/admin and was pleasantly surprised to find Tomato firmware v1.11.1217 running on this recently purchased WRT54G v2.0

    This account is long-winded but if some other newbie runs into the same situation I want to assure you that all is not lost. Wait for the SECOND error message - the one that appears as a dialog box with an [OK] button; then click OK and after being returned to the original firmware web page THEN try the reset button for 10 seconds.

    You might be as pleasantly surprised as I was.
    If some expert reading this can explain what happened that would be nice. The drama has passed for me. I pity the next poor soul who runs into this and ends up bricking their router for want of an experience-based guide out of the quagmire.

    If the "Upgrade are fail" message is something that the Tomato firmware produces then adding something to identify it would be nice. Of course if it is Linksys firmware generated then we just have to live with it.
  2. Macskeeball

    Macskeeball LI Guru Member

    An error message with a grammatical error. How very professional of Linksys. They should have thrown in an "All your base are belong to us" while they were at it.

    Interesting story. I never had such a problem on my WRT54G v2.0. Maybe there was a bug in the version of the Linksys firmware you were using? For future reference, there's at least one "WRT54G revival guide" out there that you can download in case you ever brick your router. Google it and you should find it; it may be on this site, and another may be on the DD-WRT wiki.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice