"Upgrade are failed"

Discussion in 'HyperWRT Firmware' started by popwireless, Dec 17, 2004.

  1. popwireless

    popwireless Network Guru Member

    When I try to upgrademy WRT54GS using the latest HyperWRT .bin file the upgrade fails immediately. The router's configuration is not damaged. Everythging still works so it appears that the upgrade never started.

    I have done one Linksys upgrade to to the 3.37.2 version. That worked OK.

    I'm confused. Any idea what I can do to make the upgrade work?
  2. Avenger20

    Avenger20 Network Guru Member

    I'm not sure, you may want to try resetting to defaults (holding reset button for 10 seconds) and then try flashing again.
  3. popwireless

    popwireless Network Guru Member

    I finally got this to work in 03, (but can't remember what I did) as I recall the upgrade required either a specific .bin file name or the file had to be in a specific directory. I'm getting the same "Upgrade are failed" message tring to upgrade to 04 from 03.

    I tried changing the name of the .bin file to HyperWRT.bin and that didn't work. I have tried moving the file to my PC root, to a directory called HyperWRT. Seems now wherever I put it I can't get the router to upgrade.

    I unzipped to c:\HyperWRT_2.0b4_G\HyperWRT_2.0b4_G.bin and selected the file in this location from the router upgrade window and I get "Upgrade are failed"

    There must be some kind of file authenticity test in the upgrade procedure that is failing and causing the upgrade to bomb.
  4. popwireless

    popwireless Network Guru Member

    I'm still stuck. I have done the following attempting to upgrade from .03 to .04:

    1) I first rest the router with the reset button in the back, then "upgrade are failed."

    2) Disconnected all router cables except the one to my PC, reset, "Upgrade are failed."

    3) In the router I RESET to Factory Defaults, with all cables disconnected, "Upgrade are failed"

    I cannot upgrade from 0.3 to .04. I am assuming that when the upgrade routine was written certain tests were inserted to make sure everything is perfect before the upgrade begins. Given that is the case then maybe a cause for this error message being displayed could be determined. What internal tests fail to produce the message? What is the program logic?

    I'm really bummed I can't stay up with the latest fixes.

    When I select the upgrade file does the upgrade file need to be renamed to a another name? Does the router upgrade routine expect it to found in a certain directory?

    I've pretty much done all I can unless someone ele has any other ideas.

  5. john12

    john12 Network Guru Member

    A few suggestions: check your bin file is 3,650,560 bytes in size, also check your browsers security settings as they may be blocking the upload of the file, should also check the firewall/security settings on your client. I have not had any trouble using Firefox so you may wish to try that... failing everything else you may wish to reset the settings on the router as it could be there is a firewall rules blocking the upload.
  6. Toxic

    Toxic Administrator Staff Member

    your did exact the binary file from the archive yes?

    make sure that proxy caches are disabled for any local IP addresses (ie the router)
  7. popwireless

    popwireless Network Guru Member

    Binary file

    Yes. I am selecting the .bin file extracted from the archive and attempting to upload that file. I had IE set to have the IP for the router as trused. I'll try firefox and see what happens.
  8. popwireless

    popwireless Network Guru Member

    Another attempt....


    Using the above file I still get "Upgrade are failed." This file name doesn't need to changed to something else or need to be in another directory does it?
  9. popwireless

    popwireless Network Guru Member

    I'm not even sure what a proxy cach is. Never set any. I tried from a factory default reset. I'll go look at the menus and see what I see.
  10. popwireless

    popwireless Network Guru Member


    Disconnected cable modem, stopped firewall in router. No luck. Used FireFox no change. Stopped PC firewall (MCAfee) as well, no change. I get two bars in the completion window then the error message, Upgrade are failed.

    I have -got- to be doing something or not doing something the experienced folks all take for granted. The binary file question above was an excellent choice ;) Got any more? You guys are on the right track. Thanks very much for the attempts to help me with this. I'm in no hurry, the router works under 03.

    The reason I changed to Hyper was so I could use the logging software I -thought-I had purchased. Used it for 2 months with the old wired router but apparently when I changed hardware I was required to buy a new version or install the free one every two weeks. Nope. Already paid for the full version in my mind, not gonna do that. So now it's just a matter of staying up with bug fixes.

    What kind of information could I give you about the router set up screens that would help?
  11. bengalih

    bengalih Network Guru Member


    Back up your settings. Reflash with the latest Linksys firware. Reset the router. Then, try to flash with the latest HyperWRT. Restore your settings, or at worst, re-enter them manually (might want to record them).
  12. popwireless

    popwireless Network Guru Member


    Oh yes, I did try reflashing with the latest Linksys firmware. Also got Upgrade are failed. Makes me think the upgrade mechanism is hosed in the hardware.
  13. popwireless

    popwireless Network Guru Member

    Ok, here is news. There is a 1/3/05 firmware upgrade for the WRT54GS router. I put the .bin file here:


    I selected this file and the upgrade completed! Now I'm back to Linksys firmware.

    Go figure. Will .04 work on top of this linksys firmware? See how they have the word "code" in the file name? That isn't requried is it?

    HyperWRT_2.0b4_G.bin << This file name is shorter.
  14. popwireless

    popwireless Network Guru Member

    Notice Linksys instructions are wrong in their readme

    Regarding the file EXTENSION. WOnder what .rmt is?

    Linksys, A Division of Cisco Systems Inc.

    Document: Readme.txt
    Subject: Firmware upgrade instructions


    1) Before you start, be sure you are using a PC that is connected to the WRT54GS via a wired (Ethernet) connection.
    2) Open your web browser (e.g., Internet Explorer, Netscape, etc.)
    3) In the Address bar, type in the IP address of your router. The default IP address is
    4) Leave the username blank and enter your password. The default password is "admin", all lower case.
    5) Click on the Administration tab.
    6) Click on Firmware Upgrade.

    7) Browse for the firmware file that you have just extracted. The file name should end in .rmt

    8) Click the Upgrade button.
    9) The router will begin its upgrade routine. Do not power off or unplug the router until the process is completed. This process may take up to 5 minutes to complete.
  15. popwireless

    popwireless Network Guru Member

    I still get "Upgrade are failed" with the .04 Hyper file after reflashing with the latest Linksys 3.37.6
  16. popwireless

    popwireless Network Guru Member

    John my .bin file is 3,383,296 bytes after extraction. I'll go download a new one and try that....
  17. popwireless

    popwireless Network Guru Member

    I had the wrong file. I needed the GS version. See, dopie router newbie strikes again.


    So is there any issue applying this to the 1/28 release of Linksys firmware now in my router?
  18. Dangerous

    Dangerous Network Guru Member

    Hi everyone, I thought I would add my two cents worth :lol:
    I'm struggling with my WRT54GS .just got it to make it into a hot spot. I intend to change the firmware to one that has "catsplash". Everytime I try to upgrade using an firmware other than a LinkSys offical version above the one I have installed I get the infamous "Upgrade are failed" message.
    Now I also have a WAP56G which I also upgraded I was getting a
    different message on that one, but the solution was to type a URL something like this
    HTTP:// and you can turn of the check version parameter.
    Does anybody know how we can solve this???

    My config is as follows
    using HTTP://

    Firmware Version:v3.37.6 , Dec 29 2004
    Boot Version:v3.4.2

    RF Status:enabled
    RF Firmware Version:v3.37.6
    RF Domain:US (channel 1~11)
    RF Channel:11
    RF SSID:linksys

    -----Dynamic Information
    RF Mac Address:00:12:17:DF:B1:20
    LAN Mac Address:00:12:17:DF:B1:1E
    WAN Mac Address:00:12:17:DF:B1:1F
    Hardware Version:2.0

    Thanks people...
  19. popwireless

    popwireless Network Guru Member

    My issue was

    I believe the reason I was getting this message was becuase I was trying to upload the wrong upgrade into the router. Once I realized it and downloaded the right version there was no error.

    I suggest the readme.txt have a line in it regarding this. Once I did upgrade the latest Linksys version with HyPerwrt the Linksys version dipslay was not correct. The new HyperWrt version seemed to be OK. No problems afterward.
  20. MattStandage

    MattStandage Network Guru Member

    Hi there - when I upgraded a WRT54GS to the newest HyperWRT firmware, it did the same thing - "Upgrade are failed". After saying OK to that message and waiting about 10 seconds, the screen changed and said "Upgrade Completed" and the router rebooted. I checked the version of the firmware and it was the latest, greatest version. Don't know if that helps you guys out any or not. The only reason I waited around for 10 seconds after I got that message was to get another beer because I couldn't figure out what I was doing wrong.

    PS - This firmware kick a$$. I'll never go back to the Linksys firmware unless I have to.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice