upgraded the wrong firmware-the power LED flashes-what now??

Discussion in 'Cisco/Linksys Wireless Routers' started by urosh, Oct 22, 2005.

  1. urosh

    urosh Network Guru Member


    I accidently upgraded the firmware for the wrt54G on my WRT54gS. What now? The power Led flashes all the time - the reset doesn't help. I saw that i neddes some TFT program, whitch should i download at the linksys.com site. But i can't find it! What can i do? Can somebody please help me? What can i do now? How can i upgrade the firmware now???

  2. crawdaddy

    crawdaddy Network Guru Member

    there is a tftp client built into windows. the syntax is:
    tftp -i PUT c:\image.bin

    you have to open up a command prompt to do it. good luck
  3. Toxic

    Toxic Administrator Staff Member

  4. urosh

    urosh Network Guru Member

    It is the version 1.1

    It works fine as a switch, but as a router it doesn't work. At the adress it can not be found... I searched the whole through .254 but (with IP scanner) but i didn't found it. So the TFT program doesn't help me, because i dont know the IP. The power led flashes all the time :(

    what can i do??? i am affraid that nothing... or am i wrong???

  5. BeHappy

    BeHappy Network Guru Member

    I agree. It could be hard, but which firmware version fra wrt54g you tried to upgrade to wrt54gs? From Tofu, DDWRT or 3. firmware ? What was the status after upgrading; failed or succed?
    If failed-status then do a hard reset will help.
    First of all try do a hard reset; hold reset button down when unplug the power in 30 sec. Plug the power while reset button still holds down. Wait until all four LAN LEDS flash the 2. time and release the reset button-> the router will go back to the previous state.
    If succed-status then download the Linksys ..code.exe (firmware with ftp access). Set your PC with static IP, unplug the core power, start code.exe to listen on connection then plug the power again. Good luck
  6. Aq_lynch

    Aq_lynch Network Guru Member

    same happned to me

    I flashed my versio 2 and the power blinks and won't connect. You can do an online chat with a tech support. They will issue a RMA and you can get a replacement. That is what I did. Linksys has a 3 yeary warranty on the routers.

    Hi there is a problem until upgrading firmware when it hang on,the WRT54G is not responding and work only as a switch.
    I have broth it back to life, You have to do exactly like that:

    Your router have now a IP adress

    My router's red Diag light (or Power light) is blinking. How do I fix this?

    This is caused by the firmware not loading correctly. Follow the steps below to fix this:
    Note: This process must be done on a computer plugged into the router directly.

    1. You first need to establish a connection to the Internet and download firmware for your router. To get
    online, bypass the router and plug directly into your Cable or DSL modem.
    2. Download the latest firmware upgrade for your router from http://www.linksys.com/download. Be sure to
    select the WRT54G and the correct version number that matches your router. Look on the bottom of
    the router to verify the model and version (no version number means version 1.0).
    3. Click on Downloads for this Product. When the Downloads page loads, click on the Firmware button.
    4. Download the firmware Auto Upgrade Utility .exe file from this page.
    5. Before performing the upgrade, we recommend that you do the following:

    · Assign your computer a static IP address. For more information, please see Article Answer ID 534 for information on setting up a static IP address in Windows.

    · If using a 10/100 network adapter, change its speed to 10Mb, half duplex. Please see the instructions below on how to do this.

    Windows 95/98/ME
    1. At the Windows desktop, click on Start then choose Settings and click on Control Panel.
    2. Double click the Network icon. This will bring up the “Network Configuration†window.
    3. Locate and highlight the icon with the green logo for your network adapter and click Properties.
    4. This will display the network adapter's Properties.
    5. Select the Advanced tab and click Connection Type (this may also appear as Media Type, Connection
    Speed, Mode, Link Speed, etc). The current default value should be set to "Auto sense" or "Auto".
    6. Change the value of this option to 10Base-t, half duplex mode (usually the lowest possible option). The wording
    of this value may also vary, depending upon the make and model of the Network Adapter. Other possibilities
    include 10T half, 10Mb half duplex, 10Mbps half, etc.
    7. Once this has been changed, click OK to return to the Network configuration screen.
    8. Click OK again and Windows will ask to restart your computer. Click “Yes†to restart.

    Windows 2000/XP
    1. Go to Start click on Run and type in control ncpa.cpl .
    2. Double click on the Local Area Connection that controls your network card.
    3. Click Properties under Local Area connection status.
    4. Click the Configure button. Then, click on the Advanced Tab.
    5. Click Connection Type (this may also appear as Media Type, Connection Speed, Mode, Link Speed, etc).
    The current default value should be set to "Auto sense" or "Auto".
    6. Change the value of this option to 10Base-t, half duplex mode (usually the lowest possible option). The wording of
    this value may also vary, depending upon the make and model of the Network Adapter. Other possibilities include
    10T half, 10Mb half duplex, 10Mbps half, etc.
    7. Click OK after you made the change then click Close.

    Reloading the firmware
    1. First, hold the reset button located on the back of the router for 30 seconds.
    2. Next, to test communication between the Router and the network card: Go to Start, and select
    Run. Type in command and press [Enter]. This will bring up the MS-DOS prompt window.
    3. Type ping and press [Enter].
    4. You should get the following results:

    Pinging with 32 bytes of data:
    Reply from bytes=32 time<10ms TTL=128
    Reply from bytes=32 time<10ms TTL=128
    Reply from bytes=32 time<10ms TTL=128
    Reply from bytes=32 time<10ms TTL=128

    5. Once you get these replies, close out of the command prompt by typing in exit and pressing [Enter].
    6. Double click on the firmware file that you downloaded in Step 2. The “Firmware Upgrade Utility†will open.
    7. Click Next and type in the routers “IP Address†( is the default address of the router) and type
    in the Router’s Password†(admin is the default password for the router).
    8. Once you confirm the settings (click Next), click Upgrade to start the firmware upgrade process. The upgrade
    will take about 1 to 2 minutes.
    9. Once the upgrade is complete, the router's Diag light (or Power light) should no longer be blinking.

    Note: Be sure to go back to your network card settings (from the steps above) and change the speed of the link back to “Auto sense†or “Auto†(the original default setting) to restore full speed to the adapter.

    If any of the steps do not work, or if you are having other difficulties, please contact Linksys Technical Support for further assistance.
    :thumbup: :thumbup: :thumbup: :thumbup: :thumbup: :cheering:
  8. Aq_lynch

    Aq_lynch Network Guru Member


    :( :sad: :sad: :sad: :sad: :cry: :sadbye: :cheerup: :eek:

    I bricked the version 4 I just purchased so I took it back to the store for a repalcement. I checked 6 stores and they only have the version 5. Looks like my dreams of customizing my home wi-fe network are over. I purchased the version 5 because I can't find another version 4 or 3 or 2. They only have version 5. Is there a way to order one and ensure that its a version before version 5. I have an old verson 2 that is bricked (green light flashing) I think I can get the RMA from linsys and send it back but I fear that I will get a version 5 as the replacement from linksys. Is there a way to safely unbrick the version 2. I tired everything and i can't ping it says destination unreachable.. I read that crossover cable will make it work is this true. Or shoudl I break the seal, open it up and try to unbrick via the linksys info page that shows how to open it up and do it. Please reply soon.
  9. crawdaddy

    crawdaddy Network Guru Member

    unless you are willing to call your router a complete loss if you can't unbrick it, I would not suggest opening it up. I went and opened mine, added a fan in, and then I decided to change firmwares, and then bricked it. While I don't have the receipt anymore, I still don't know if I could return it. I definitley could not RMA it. If I had the recepit, the store amy not notice where I had the fan modded, since I went for a stock/stealth look with the fan. In short, no :(
  10. krazyme

    krazyme Network Guru Member

    I've had a similar problem on v1.1 this week-end

    I have a v1.1 for 2 years now, and I wanted to expand the network by adding an other WRT54G connected through WDS, so I bought a v3.1

    When received v3.1, I've upgraded it with dd-wrt v23b2, no problem (mini version, then voip version)

    I wanted to do the same with v1.1, which had Satori loaded on it, for easy maitenance I wanted to switch to dd-wrt v23b2.

    After flashing this v1.1 to dd-wrt, no answer from the router anymore : same behavior, acting as a switch and wifi hotspot, but no way to access to the web interface, and no ping response.

    I looked around and have found this interesting page : WRT54G revival guide

    I've tried the first method, without great success. The ping was answering, but no flashing possible

    At that point, I've made a test : start a "ping -t" (I was under XP), and reboot the router. And in fact, the router respond, but only for 5 or 6 pings, then does not respond anymore.

    So I've decided to do a variation of this method : start a "ping -t", be ready with tftp started, and then reboot the router. At the first ping answer, I did click on the update button of tftp, and this worked !!!! TFTP had the time to flash the router.

    After power off->on, my dd-wrt firmware was ready to run !!!!

    I hope this can help you

    Crazy French Guy
  11. krazyme

    krazyme Network Guru Member

    For AQ-lynch...

    I just bought last week a v3.1 from Amazon.fr, in the description it they did say it was a v3.0, that's why I did order this one, I had the same request as you.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice