Upgraded WRT54G firmware, print server won't work

Discussion in 'Linksys Official Firmware' started by RexD125, Oct 17, 2006.

  1. RexD125

    RexD125 Guest

    Today I upgraded the firmware of my WRT54G v5 router to v1.01.0 and I cannot connect to my WPS54GU2 print server! When I try to print, an error message says the connection failed. The Print Server Utility driver setup can't find it. Inputting the possible IP addresses of the server in Internet Explorer didn't work either.

    Neither a wireless nor ethernet connection works. The LAN lights on the print server did turn on when I tried, however. Tried holding the reset button for 30 seconds, still no luck. Oddly, the IP address the server printed was, which is out of the default DHCP range that I have the router set to. Inputting that in IE was unsuccessful as well.

    The first thing I do after a firmware upgrade is to restore factory defaults and input all the settings I had before. The print server worked fine under the previous settings and firmware; in fact everything worked beautifully!

    What's more, is that the DHCP Active IP Table does not show all of the clients connected to the router. Sometimes it's completely blank when I know there are several clients connected to it. Right now it's only showing my laptop, when there is another laptop, the print server, and a wired desktep connected.

    However, I WAS able to wirelessly host a LAN game on one laptop and have another connect to it, so the clients can see each other. I think this firmware is bugged...

    Update: So I messed around with it some more today. I hard reset the router, powered it off, and connected the freshly hard reset print server via ethernet. Powered up the router, then the print server, and then the wired desktop in that order. Strangely, the desktop received the IP address of Now, when the print server was started up first it should have gotten that IP address under default DHCP conditions, and the desktop should have gotten That leads me to conclude that the new firmware isn't even giving the print server an IP address! :(

    Update 2: Well I went to the store and picked up a cross cable, connected my laptop to the print server, and configured it to connect with a static IP, and lo it works now! I guess those DHCP issues weren't completely resoved in the new firmware.

    Thanks for your time

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice