Upgraded WRT54G V2 to latest Firmware, Connection Errors after Update... Agh!

Discussion in 'Cisco/Linksys Wireless Routers' started by Scalawag, Jan 25, 2008.

  1. Scalawag

    Scalawag Guest

    Okay - Last night I realized my router firmware was way out of date. It was Version 2.0.xx ... So today I went and downloaded the latest from the Linksys site. Ran the update, it was fine. Never lost the internet or anything. However, now, when I access the configuration page and try to make any changes, such as save the changes after port forwarding, etc, I get a blank white page instead of the "Settings Updated" page that used to come up. And obviously, the settings didn't save. It's almost as if the browser just immediately times out.

    So I tried to reinstall the firmware, but when I click "Update", I immediately get a CONNECTION ERROR page right after, and it doesn't go through obviously.

    Help! I don't know what to do! My internet still works and everything but I need to set up my WPA and forward ports. Any ideas? I've tried unplugging, using the reset button for 30 seconds....
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice