UPnP is not working for me.. any suggestions?

Discussion in 'Tomato Firmware' started by ithrowpicks, Nov 12, 2011.

  1. ithrowpicks

    ithrowpicks Networkin' Nut Member

    I purchased a Cisco E4200 about a week and a half ago. When initially set it up I installed the latest Cisco firmware 1.0.3 and configured UPnP for my 3 Xboxes that need to connect to Xbox live simultaneously. All showed "Open NAT" and everything worked perfectly.

    On Wednesday of this week I decided to try TomatoUSB so I downloaded Toastman's build tomato-E4200USB-NVRAM60K-1.28.0407.1MIPSR2-Toastman-VLAN-RT-Ext.bin and installed via the stock firmware and made sure to complete the "Erase all data in NVRAM" after Tomato was installed.

    When that was complete I configured static DHCP addresses for my 3 Xboxes, NAS, printer, etc. I verified UPnP was enabled and attempted to connect to Xbox live with the Xboxes and all reported Moderate NAT. I did NOT configure any port forwarding or port triggering rules because I understand those would possibly conflict with the UPnP forwarding.

    Why is this not working for me?

    Just in case matters to anyone I use AT&T UVerse 2Wire 3800HGV-B modem that configured for DMZ+ mode so the E4200 should not be double NAT'ed or anything. Tomato shows my WAN IP correctly and not some non routable address (192.168.x.x, 10.x.x.x).

    Previously I owned a D-Link Gaming router (DGL-4300) for five years that I configured the same way (static dhcp address and UPnP) that worked properly as well so I am not sure what I need to do differently with the Tomato firmware to get it working.

    I really don't want to go back to the stock Cisco firmware but if I can't get this work it could be a deal breaker for me.
  2. ithrowpicks

    ithrowpicks Networkin' Nut Member

    I never got this build working so I installed the following and everything appears to work properly now. Hopefully this helps someone else who is using the E4200.

    tomato-E4200USB-NVRAM60K-1.28.0488MIPSR2-Toastman- RT-N-Ext.bin
  3. teaman

    teaman LI Guru Member

    Please notice that on VLAN-GUI-enabled builds, when enabling/activating (turning 'on') some features, you must also select/choose on which LAN bridges a particular service/functionality should be 'active' (i.e. for uPnP, which interfaces it should be 'listening', even if you have only one LAN bridge configured/defined on basic-network.asp and/or advanced-vlan.asp).

    Please have a look at forward_upnp.png (attached to this post) and notice the areas marked in red: besides enabling the UPnP service, you must also ensure on which of your LAN interfaces the miniupnp daemon will be actually listenining/available (again: even if you have only one LAN bridge set/configured). Therefore... if you wish to try again... I'd suggest double-checking/reviewing that specific setting/quirk ;)
    In any case, here's a few pages that might contain/handle features/services that might require additional attention regarding config/settings (such as the caveat mentioned above):
    • advanced-firewall.asp (multicast)
    • advanced-routing.asp (static routes, RIP)
    • forward-upnp.asp (uPnP, NAT-PMP)
    Please notice this is a non-exhaustive (and most likely, incomplete) list, but it's a start ;)

    BTW - if you do get a chance to try this again, please let us know how things go - thanks!

    Best of luck!
  4. ithrowpicks

    ithrowpicks Networkin' Nut Member

    Actually I don't need VLAN capabilities so I really should not have downloaded the version that I did. However thanks for the tip

    On a side note is there an automated way to find out when Toastman releases a new firmware update for the E4200? An RSS feed or something?
    How is everyone else keeping up with updates?
  5. gutsman7

    gutsman7 Networkin' Nut Member

  6. ithrowpicks

    ithrowpicks Networkin' Nut Member

    OK guys, I have been reading a lot of the "Common Tomato Topics (Help & Info)" thread and I see that in order to setup a guest wireless only network that does not have access to my private network I would have to use the VLAN builds.

    In a nutshell I downloaded the firmware installed it and made the changes Teaman suggested to get UPnP working properly (Thanks Teaman)

    Then I created the guest network with DHCP on 10.0.0.x subnet since I want to know at a glance if someone is connected via my main network with an address of 192.168.1.x or the guest 10.0.0.x. Everything seems to be working fine so far.
    I WILL be making a donation to the project via the "About" page. This is good stuff
  7. ithrowpicks

    ithrowpicks Networkin' Nut Member

    So I made the donation and I received an email from PayPal indicating the payment was made to Jonathan Zarate so I decided to Google his name to get some background on if he does this as a hobby or if he gets paid for doing this type of thing.

    The guy that shows up at the top of the search result is infamous in New Jersey for all the wrong reasons... so for a brief moment I was thinking "wait a minute, was that a bad link"... lol
  8. Toastman

    Toastman Super Moderator Staff Member Member

    Jon has net been heard from for a very long time now. We are all wondering whether he's still around. If his Paypal account is still active, presumably that means he is ??
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice