upnp stops working after a few days.

Discussion in 'Cisco/Linksys Wireless Routers' started by dankim831, Nov 1, 2004.

  1. dankim831

    dankim831 Network Guru Member


    i have this problem with upnp where it stops working after about a few days.

    basically the internet gateway icon disappears, msn stops recognizing upnp and other programs such as azureus stops recognizing upnp.

    the only way to fix the problem is to reset the router. once the router resets upnp is redected on all programs.

    i've had this problem with wi-fi box firmware, hyperwrt firmware, sveasoft alchmey firmware and even with official linksys firmware.

    i've tried two different routers, wrt54g v1.0 and a wrt54g v2.0

    i'm getting pretty frustrated, anyone have similar problems? or does anyone have any ideas or solutions?

    any help would be greatly appricated.

  2. Toxic

    Toxic Administrator Staff Member

    I dont use upnp and azureus works fine with just port forwarding.

    what OS do you use? may it is that that doesn't work correctly.

    alot of people have reported the new msn doesn't seem to handle upnp correctly. (whether u have a router or not)

    is upnp enabled in your OS?
  3. dankim831

    dankim831 Network Guru Member

    i am using windows xp pro sp2

    when you say that there have been reports that msn hasn't been working well with upnp would you mean that msn is breaking upnp on the router casuing it to crash or something liek that?

    i have 4 computers on the network and upnp fails for all of them when it does and then works again after a reset.

    as a note tho msn does report that it is connected to a upnp port restricted NAT when the service is working.

    any more insights would be really helpful.

  4. Esquire

    Esquire Mesquire Staff Member Member

    My MSN is on practically 24/7 and it works fine with UPnP - at least I think it is since file transfer works great when the same with Windows Messenger does not.

    Presumably you have enabled UPnP under Exception in Windows Firewall and that you have installed the UPnP User Interface Windows component, yes?

    Have you done anything else other than a router reset to redetect UPnP when the Internet Connection icon disappears? For example, disconnect the network connection and reconnect? This works for me.

    If you older discussions here on this topic, you would have seen my comments since I've been after definitive answers to my UPnP issues for a long time. UPnP appears to be stable on my network, but every now and then things would go haywire.
  5. dankim831

    dankim831 Network Guru Member

    yea i've checked almost everything. just reconnecting my connection doens't work, and yes i have installed upnp user interface as well as the gateway discovery service.

    its starting to frustrate me

    its not my computer because 4 other computers experiece the same problem.

    i dunno yet if its the router cause i've gone through 2.

    so its definate very weird.

    does anyone know what the problems with msn messenger's upnp is? is it that it doesn't detect upnp well or that it breaks upnp on routers because of some issue?

  6. dcorban

    dcorban Network Guru Member

    I have this exact same issue. UPNP on the router just plain stops working. I have the WRT54G 2.2, using firmware v3.03.6.

    Everything will be working fine. Azureus UPNP detects the router. WinXP detects the router and shows the gateway icon in the network connections. All UPNP programs are able to open ports at will. Then randomly, the UPNP will stop working on the router. It is easy for me to tell when this happens by looking at the Azureus UPNP log.

    So far, the way I fix it is to go to the router's admin page and click "save settings". That's it. I don't change any settings, I simply click save. Immediately, the router will appear in WinXP network connections, Azureus UPNP starts working and everything is fine.

    I have no idea what causes UPNP to stop working on the router, but is is damn annoying.
  7. mjl

    mjl Guest

    I’m having the same problem and it happens hen you exit Azureus, and it removes the ports that where mapped by UPNP.
  8. wrt54gs

    wrt54gs Network Guru Member

    me too.
    WRT54G V2.2
    HyperWRT V2.1b1

    1 Desktop (DWL-G520+) XP Pro+SP2
    2 Laptop (DWL-G650+) XP home

    Both PC enable UPNP in XP system.

    If Desktop started alone , can see internet gateway and status is active .
    But if Laptop started , UPNP will automatic disable ,then Desktop can't see the status. If Now Desktop restart , can't see the gateway.

    If this occured one way to solve ,just reboot or Power off and on. Then desktop will get icon again . but if lattop started then ........again and agin .

    What's problem ?
  9. wrt54gs

    wrt54gs Network Guru Member

    I got it As I installed SP2 on Laptop, So problem was solved.
    and transfer speed is improved.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice