USB HDD Question

Discussion in 'Cisco/Linksys Network Storage Devices' started by pmiller056, Jun 23, 2007.

  1. pmiller056

    pmiller056 LI Guru Member


    I have a NSLU2 running R63 firmware. I have a USB to IDE disk drive enclosure which will operate 2 IDE disk drives in a Master/Slave configuration - as would be the case if used within a PC, but using only one USB port. Windows XP will detect and mount these 2 disk drives correctly if connected by the USB connector.

    Will the NSLU2 be able to use these 2 disks correctly and reliably if connected to either of the USB ports on the NSLU2? There is no USB hub involved - I appreciate that some users have had problems if USB hubs are used when trying to do something similar.


  2. d__l

    d__l Network Guru Member

    Are you sure there isn't a USB hub integrated into the USB to IDE chipset? Windows device manager might tell you if the hub is there when the drive enclosure is attached to your computer.

    The reason I suggested a hub integrated into the enclosure is that there are other devices that have integated hubs - multifunction devices that combine a scanner, printer, and memory card reader come to mind. Each of those is a separate USB device that is connected to and functions through an integrated USB hub in the multifunction box.
  3. pmiller056

    pmiller056 LI Guru Member

    I'm sorry I haven't replied sooner - I've been on a short vacation.

    When the USB/IDE controller is plugged into a Windows XP machine, it appears as 1 mass storage device in the USB device list. No extra hubs appear in the USB device list. The 2 disks appear correctly in the disk drive list.

    The chip in the USB/IDE controller is a Myson-Century ( CS8818. USB vendor 04CF, device 8818. There is outline data on the manufacturers website, but no detail available for public use.

  4. u3gyxap

    u3gyxap Network Guru Member

    You can't have more than one drive per USB port on the NSLU2, not even if USB hub is used. It's a firmware limitation. At least with the manufacturer's firmware.
  5. pmiller056

    pmiller056 LI Guru Member

    Yes - Having found the time to do some testing, I can confirm that it doesn't work. Given the name given to the plugged in disk(s) the NSLU2 knows that there there is more than one there, but it can't see it.

    Oh well.

    It would have been a nice easy way of getting some older, smaller disks back into use doing something useful...

    Thanks for your help

  6. d__l

    d__l Network Guru Member

    Did you try both USB ports on the NSLU2? Even though a hub isn't reported out of the enclosure, the NSLU2 might still act as though there is one in there.

    Only one port, Port 1, allows the use of a hub with R63 (R72 switches the port the hub is allowed on) and only then with NTFS/FAT32 formatted drives.
  7. pmiller056

    pmiller056 LI Guru Member

    It was port 1 I was using (R63 firmware) - I didn't try port 2 because I want to keep it generally unused so that I can temporarily plug things into the NSLU2 as I need.

    I tried a pair of NTFS drives - The second drive was known about, but not usable. I let the NSLU2 format the disk(s) on port 1 to the native filesystem format and the second drive was unseen and unusable. If I get time I'll see what it does with a pair of natively formatted disks on port 1......

    I haven't seen the R72 firmware available so I haven't tried it.

  8. d__l

    d__l Network Guru Member

    From what you have said, I don't think it would have worked on Port 2 either. That is strange that it would recognize the second drive on Port 1, but not be able to use it in NTFS format.

    The undocumented "rules" for the use of a hub on Port 1 were quirky. Then the R73 mystery firmware appeared on some factory shipped NSLU2s and switched the way Port 1 and 2 operated.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice