USB key format problems with Unslung 6.8beta

Discussion in 'Cisco/Linksys Network Storage Devices' started by Shumway, Sep 21, 2006.

  1. Shumway

    Shumway LI Guru Member


    I don't know if this is the right forum to ask this kind of question, but I'll try anyway :)

    I have upgraded my NSLU2 to Unslung 6.8beta, and followed the installation guide from the site to the point.
    But now I've reached the point where I should format my USB-key via the slug in order to be able to unsling to it.
    The USB-key is recognized by the slug as formatted FAT/FAT32, and when I try to format it via the web interface it just says "Formatting..." for about 3-5 minutes, and then returns with either as "unformatted" or "FAT/FAT32" again.
    In the slug disk log it says "Disk 1: Format failed" or "Disk 2: Format failed" depending on which USB plug I use.
    I've tried to google this issue like crazy, but it seems I'm the only one in the world having this problem :frown:

    Does anybody in this forum have any idea what might be the problem?

    Before installing unslung 6.8 the slug was running Linksys firmware V2.3R63.
    The USB-key is a 1 GB Transcend JetFlash V30. It works fine in windows (when formatted fat/fat32), and was also working after the slug upgrade.

  2. Mark Voss

    Mark Voss LI Guru Member

    I've had this problem with a 256MB USB Key but not with anything 512MB or above.

    I let the original firmware format my key to ext3 (in port 2) and then upgraded my firmware and uNSLUng the slug.
  3. Shumway

    Shumway LI Guru Member

    Hi Mark,
    Thanks for your input.
    That leads me to believe that maybe there's something wrong with my slug, because I couldn't actually format it with the orig. Linksys firmware.
    It said that it wasn't a HDD.
    I then read somewhere that I could do it when the slug was upgraded to unslung. So I just thought that the orig firmware wasn't able to format usb-keys.
  4. d__l

    d__l Network Guru Member

    You can't format any drive smaller than 10 MB with any version of the stock firmware. Any drive that size or smaller is only recognized as flash drive. Even a small HD will still show as a flash drive and NSLU2 will expect it to be formatted as FAT32.
  5. Ramage

    Ramage LI Guru Member

    Can't Format USB Keys

    I have the same problem running Linksys firmware V2.3R63.

    It refuses to format USB keys with message "Not a HDD". I have tried 1G and 2G keys.

    Any other ideas how to fix this?? Is there an earlier firmware version which will work?
  6. d__l

    d__l Network Guru Member

    I had a stupid typo in my previous post. Bah! The NSLU2 only recognizes 10 GB or larger drives as a formatable HDD, not 10 MB.
  7. Ramage

    Ramage LI Guru Member

    Not many 10Gig USB keys about!
    Is this for real? Many users of UnSlung seem to make it work!
  8. d__l

    d__l Network Guru Member

    Unslung isn't stock firmware and even then they have to go through contortions to format a small flash drive? There is a whole page worth of instructions on just how to do this. Unslung also has a limit of only 1 GB before it treats the drive as a flash drive.
  9. Ramage

    Ramage LI Guru Member

    Thanks for info. I'll try to format the key using linux and unslung instructions.
  10. Ramage

    Ramage LI Guru Member

    Format Success

    Managed to format and unsling to a 2G USB flash key, using the unslung firmware. Process of unslinging worked without a hitch - brilliant FW - well done the NSLU-linux project team.
  11. xpat

    xpat LI Guru Member

    so are you saying that we need to use a 2gb+ usb key on the slug? that would really piss me off, i just bought a new 1gb usb key because all documentation i read said you need anything larger than 256mb. all i want to run is asterisk with some space for voicemail.

    i'm having exactly the same problem. got any suggestions?? thanks. if i can't figure this out, i think i'm gonna whip this pos against the wall and use a normal PC for asterisk. sorry for the anger, it's really frustrating me.
  12. jksmurf

    jksmurf Network Guru Member

    No, I believe it means that:

    (i) If you want to format a drive using Linksys F/W ON teh slug, you need a drive (USB or Other) > 10GB.

    (ii) If you want to format a drive < 10GB on teh SLUG you can do so only AFTER you have installed the unslung F/W and by following unslungs directions to do so, PROVIDED the USB Key Drive is > 256 MB.

    This is my understanding.

  13. xpat

    xpat LI Guru Member

    OK ... i've followed the directions included with the f/w exactly as stated, but I still can't get the drive to format and I can't unsling the device until I get the drive formatted. maybe i'm having some kind of freak incident? i will try posting to the nslu2-general group on yahoo.

    now i formatted the drive as fat32 on my mac (osX) and it shows up as such on the nslu2. however whenever it tries to format, it fails. it continues showing up as a fat32 drive. ><

    thanks for the advice.
  14. jksmurf

    jksmurf Network Guru Member

    Hmm, I really don't know what else to say. When you get it going, come back and jot down a note how you did, for the next hapless user :)


  15. Ramage

    Ramage LI Guru Member

    Are you able to format the USB key to any other format on the MAC eg ext2/3?

    BTW I used a 2GB key because that is what I had available - I don't know whether a smaller key would work. I tested the key on a linux box by formatting in linux formats to make sure they worked.

    I tried the same using a 1GB SD card with USB adapter and that would not format on the linux box, but stayed as FAT. So it may be that the type of USB key is significant!
  16. aximbigfan

    aximbigfan LI Guru Member

    i am going to get a 256mb stick tomarrow for my unslung nslu2. ahould i get a 512mb one? this the first day (actully hour) that my nslu2 has been runnign unslung so bear with me.... i really want to keep this as cheap as possible and i will not be installing any packages on my slug.

  17. jksmurf

    jksmurf Network Guru Member

    Is there any reason to unsling it if no packages are installed? (this is a real question, not a smarty-pants one, although it may look like it :) )

  18. coupeborgward

    coupeborgward Addicted to LI Member

    I have got exactly the same issue. My USB Stick is 2GB and the V2.3R63-uNSLUng-6.10-beta won't format it ? The log states format failed and that's it.

    Any ideas ?
  19. coupeborgward

    coupeborgward Addicted to LI Member

    Just to spread my wisdom. After hours of trying I figured out a way. First I downloaded Partitioning Manager and formatted (Ext3) the USB drive on my windows machine. After that I reformatted it in the Slug and after that it was working.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice