USB port not working

Discussion in 'Tomato Firmware' started by Mango, Jan 31, 2010.

  1. Mango

    Mango LI Guru Member

    I am using Teddy-Bear's USB mod and today I discover the router does not recognize the USB drive. I tried the USB drive in a computer and it worked. But, the drive does not appear in the Attached Devices list. Perhaps the USB port is not working.

    Before the issue occurred, the router had brief periods of extreme slowness. For example, it took several minutes for a directory listing. I rebooted the router and all returned to normal, except the USB drive.

    How should I troubleshoot this? I tried lsusb but that command apparently does not exist.

    Edit: After another reboot, I was able to mount the drive. But, the router slowed to a crawl again.

    Edit: Another reboot, and things are absolutely back to normal. I have no idea what happend. I noticed kupdated was using a lot of CPU when I first mounted the USB drive. It settled down after a few minutes though. Any suggestions would still be appreciated in case this happens again.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice