usb stick not recognized on nslu2

Discussion in 'Cisco/Linksys Network Storage Devices' started by rvanderh, Apr 23, 2006.

  1. rvanderh

    rvanderh LI Guru Member


    I've got a new nslu2 and a paradigit usbstick (1024 MB)

    I'm working on a debian (sarge) system and am unable to run the windows setup program for the stick. Don't know what this setup is ment for anyway, because stick is recognized out of the box if I put it straight into my system.

    If I put the stick in disk 2 port of the nslu2 the hd light is lighting and the HD should be ON if I understand the manual correctly. If I go to the admin pages of the linksys it says 'Not Formatted', which also looks like the disk is recognized. But if i unplug the stick and refresh the adminpages it still says 'Not Formatted' in stead of 'Not installed' If I push the button (with or without a stick plugged) 'format disk 2'
    it says 'Formatting...' for a few seconds and then 'Not Formatted' again and the log says '04/25 21:02:32 Disk 2: Format failed'.

    Experiment 1: I made one ext3 partition on it and formatted it -> no new insights.
    Experiment 2: I made one W95 FAT32 partition and formatted it -> no new insights.
    Experiment 3: I plugged my digital camera with usb-storage (FAT16 <32M) on the linksys. -> Disk 2 status changed in 'not installed'. If I plug the usb stick back it stays on 'not installed'.

    Anybody here have any good suggestions to get my usb-stick recognized on my nslu2 ?

    Thanks in advance, Rik
  2. d__l

    d__l Network Guru Member

    What firmware version are you using on the NSLU2? Some of the latest beta versions may have swapped the allowed drive types for the USB ports?

    Can you format the USB stick as FAT32 with a WinXP system? Anyone's WinXP system so that it is recognizable by a WinXP system as FAT32?

    At the USB stick's size (less than 10 GB), the NSLU2 will only recognize it formatted as a FAT32 drive. The NSLU2 will not format a drive smaller than 10 GB to ext3 either.

    So if you stick it in the NSLU2 formatted as NTFS or ext3, I think the NSLU2 will just say it is unformatted and not report the available space. In those formats, your stick is effectively unusable.
  3. rvanderh

    rvanderh LI Guru Member

    Thanks for replying.


    My neighbour was not glad with me. He lost quite some money on his pokergame while formatting my stick ;( Anyway I now have a 'properly' formatted FAT32 partition on my stick. And the NSLU2 still finds it 'not formatted'
  4. sufrano63

    sufrano63 Network Guru Member

    latest firmware is V2.3R63
  5. d__l

    d__l Network Guru Member

    R24 is an old firmware version, but I don't think it would make a difference as far as FAT32 recognition or not. The newer firmwares have added NFTS for HDs and FAT32 to both USB ports. There has been some swapping of which USB port would do which type of drives though.

    Have you tried the USB stick in each USB port to see if there is any difference?

    Can you get/borrow another different USB flash drive (specifically a smaller one) to try in both ports to see if there might be something about your particular USB stick or brand that is not recognized. For this test, all you would want to do is have the NSLU2 read the size of the flash drive and recognize any directories or files on it.

    If the second USB flash drive isn't recognized, then there might be a problem with your NSLU2 itself.
  6. rvanderh

    rvanderh LI Guru Member

    In drive 1 it doesn't even light on on the device itself. But that is in accordance with the manual which states that drive 1 is only ment for hard drives.

    I borrowed a kingston traveler II, 128MB
    I put a fat32 via linux on it and it is recognized without any trouble. Now I know the nlus2 is working and don't have to return it.

    So now I have to return this paradigit usb stick for one that will work on the nslu2. If anybody has good suggestions for a nslu2 compatible 1 GB usb stick, I really like to hear from you.

    Thanks, Rik
  7. sufrano63

    sufrano63 Network Guru Member

    I have a 1GB and 2GB Kanguru Micro Drive from Kanguru and both works fine with the NSLU2
  8. rvanderh

    rvanderh LI Guru Member

    continuing horror

    Well as they don't sell kanguru sticks in my neigbourhood, I did another wild guess and bought myself a Corsair Flash Voyager 512 MB.

    There was a FAT16 formatted partition on it and it was ..... recognized ! I can click on 'DISK 2(Public Data)' and it shows me a testfile which I put on it. But alas if i do administrator/advanced/disks it says under disk2 'not installed'.

    I formatted the stick to FAT32, but that didn't give me new input. If i try to change the user password it tells me "Warning, no HDD installed".
  9. d__l

    d__l Network Guru Member

    You won't be able to change the user password without an ext3-formatted drive installed.

    Maybe your old firmware is causing your flash drive not to be recognized as Formatted (FAT16/32)? I'm surprised that your pre-installed test file can be read though. Is there any reason that you haven't flashed to a newer firmware?
  10. rvanderh

    rvanderh LI Guru Member

    New experiment. I removed the partition on the disk via my desktop and returned the disk to the nslu2. In the admin pages it says now 'not formatted'. I pushed 'format disk2' and it says 'formatting..' for a long time, and then ....... 'not formatted' again, but in the log it says
    '04/30 02:14:47 Disk 2: Format succeeded'. But at home disk2 is not clickable. Oh, and the stick itself is flickering every 5 seconds. Is the formatting process probably still going on ? After 15 minutes I removed and checked the stick on my linux system: there are two ext3 partitions and 1 linux swap / solaris partition made on it.

    Now I don't understand anymore. Thought the nslu2 needed a FAT32 ?

    On part1 there is an empty dir public. On part2 there is a whole xmas tree
    backup_sh.conf group passwd smbpasswd upgrade config lost+found share smb.conf tmp

    It looks like the formattig process on the nslu2 puts a backup on the disk and I disturbed this process. Started the formatting process again. How long does this process normally take ?
  11. rvanderh

    rvanderh LI Guru Member

    because somebody told me

    I don't like to run two kinds of 'trial and error' at a time.
  12. d__l

    d__l Network Guru Member

    Ah, but I'm running out of suggestions short of saying that there is something wrong with your NSLU2. :D

    You lost me. That was a format of the USB stick that you tried above, right? I don't think it should have written anything new to it during the format. As I understood it, any drive stuck into it that is less than 10 GB should be recognized as a Flash drive and is supposed to be in the FAT 16/32 format.

    I've tried to format a flash drive to ext3 once and it refused to do anything to it. I've also tried formatting a 512 MB partition on a larger HD to ext3 . That worked just fine. Then I tried to do an exact disk copy of the pratition to a 512 MB flash drive. The copy worked or said it did, but my NSLU2 refused to recognize that the flash drive had ext3 format (or any format) on it.

    Do you happen to have a USB HD that you can attach to the NSLU2 and see if it will work correctly formatted as FAT 32 and then will format the HD properly to ext3? The point of this test would be to see if your NSLU2 will operate correctly with a HD.
  13. rvanderh

    rvanderh LI Guru Member

    Okay, i finally uploaded to R63. Now the disk is recognized. In home there is a link to 'USB Port 2(Public Data)' and in the admin section it says 'Formatted (FAT16/32)'.

  14. d__l

    d__l Network Guru Member

    Well it should have been recognized by R24, but sometime these NSLU2's don't know what they should be doing. :eek:

    Also now you should be able to use the memory stick in either USB port too. If you have that paradigit usbstick, I'd be willing to bet that there is a good chance it will work now too. :)

    Now that I've thought about it, the only use I made of R24 was to have a way to flash to R25. So I never tried to use a USB stick or anything else with R24.
  15. rvanderh

    rvanderh LI Guru Member

    Problem solved

    Well I moved to a new communitie:nslu2 for linux
    nslu2 is running great. After flashing unslung I was finally able to format my usb disk. And now it's running my webserver !

    Thanks for helping me on.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice