Using HyperWRT but torrents still slow down network

Discussion in 'HyperWRT Firmware' started by hyolee, Nov 14, 2006.

  1. hyolee

    hyolee LI Guru Member

    Hey guys,

    I've been using HyperWRT Thibor 15c for quite some time now... and recently... i have no idea WHY but, whenever i am downloading torrents, it is slowing down my network like CRAZY! When i first flashed to this firmware, i was able to browse the net smoothly and play online games while using uTorrent. Now everything has gone poopy. Anyone know why? could this be a setting-specific related problem?
  2. mstombs

    mstombs Network Guru Member

    Do you also use Firefox with the FasterFox plug-in? This killed my PC internet access when used with uTorrent until I patched tcpip.sys to remove the window XP SP2 low limit of maximum open connections.
  3. hyolee

    hyolee LI Guru Member

    No, I just use IE7 Final. Does it have anything to do with uTorrent? or do i have to patch tcpip.sys?

    I'm confused :s
  4. hyolee

    hyolee LI Guru Member

    Help anyone? please?
  5. lechuck1

    lechuck1 LI Guru Member

    Do you use sw like a Peerguardian?

    For some unknown reason, when I have one PC connected on router
    running utorrent and Peerguardian everything is fine.
    But when I plug the second PC connection stops. ?!?
    If I close Peerguardian before pluging the second PC, everything is fine.

    Don't know why. Maybe you have similar problem.
  6. hyolee

    hyolee LI Guru Member

    No, i don't have peerguardian
  7. Esquire

    Esquire Mesquire Staff Member Member

    The TCPIP.sys patch refers to the connection limit on the said TCP/IP protocol system driver implemented with Windows XP SP2. It needs to be repatched with a new version every time this system driver is updated by Microsoft (through Windows Update, Microsoft Update, or otherwise). More info available using Google.

    Have you tried running uTorrent's SpeedGuide to adjust your uTorrent's network settings? Do bear in mind the speed being referred to is your broadband upload bandwidths.
  8. AmyGrrl

    AmyGrrl Network Guru Member

    What you should do is make sure nothing is running on all the PC's on your network so their is not network activity. Then run the uTorrent Speed Guide (CTRL+G) and click the run speed test button. You need to find out your max upload rate. As an example my max upload is rate is 95 kb/s so I set uTorrent to only upload at 80kb/s so that I have at least 15kb/s left for the other people on my network. I only use one computer for downloading torrents, but if I did, I would set uTorrent on each computer to only upload at 40kb/s. I used to use this my full upload rate but I learned doing that would kill the network. Also if you plan to do some online gaming via XBOX Live as an example you can lower the upload rate from 80kb/s to 40kb/s and that give you 55kb/s for gaming then after your done playing set back to 80kb/s. I hope this gives you an idea of how you need to set uTorrent up for your own network.

    You can setup you upload limit under Preferances, Connection, Bandwidth Limiting.
  9. caffiendo

    caffiendo Guest

    I just installed DD-WRT on my WRT54G V2.0. It is running extremely slow whenever I run Azureus or jus the bittorrent command on the linux command line... Before when I ran the Linksys 4.30 Firmware, it ran great. Now it is hard to get above 25-30 KBs. before i was getting 170-250.. I am using the port forwarding setup the same as before. Wireless is disabled.

    Now if I run bittorrent, I might as well stop surfing! I even tried setting up QoS but all that did was make my router lock up and I had to reset it every time.

    Any suggestions?
  10. hyolee

    hyolee LI Guru Member

    Hmmm, i'll see if any of your suggestions solves my problem. More suggestions would be greatly appreciated though :D
  11. cvmiller

    cvmiller LI Guru Member

    Are you using PPPoE to access your ISP? I have found that PPPoE access with this firmware to be quite slow (too slow to use, actually).
  12. Patf

    Patf Guest

    I got the same problem..
    I have a linksys WGT54GS, When I first got the router torrentts ran like crap and would crash the router thus requiring a reboot, so I downloaded DD-WRT Firmware, still same deal except if I stop the BT downloads I can continue to surf, ect...

    Linksys WGTv.4 - firmware 1.0.5 or something... stock firmware, ever upgraded
    DD-WRT - Firmware v23 Sp2

    Ive read on az wiki site that reducing the connections to under 200 will stop this, but no luck. I have installed two routers on my network to prevent downtime. Netgear router also experiences the same problems.
  13. petch01

    petch01 LI Guru Member

    I'm just a newbie so I can't proof by knowledge that this is the perfect setting/configuration, but like to post my settings/configuration as my bittorrents runs flawless. I'm on a South East Asian ADSL 1024/512 connection.

    - WRT54GL 1.1 + Hyper-WRT 2.1b1 Thibor 15C and Dare Global DB120 modem/router in Bridge-mode.
    - Bittorrent client: BitComet 0.70
    - Peerguardian 2 (all client IP-filters settings disabled)
    - Sygate firewall
    - AVG Virus scanner
    - FF 2.0 and IE 7

    - Conntrack setting 600/4096
    - QOS: http-dns-skype-msn-yahoo = highest and Bittorrent = low

    Uptime : 8 days, 12:13:55
    System Load : 0.21 / 0.14 / 0.13
    LAN (rx/tx) : 17.67 G (24.84 K/s) 50.00 G (95.51 K/s)
    WLAN (rx/tx) : 36.32 M (0.00 K/s) 1.46 G (0.00 K/s)
    WAN (rx/tx) : 49.94 G (90.62 K/s) 19.17 G (26.95 K/s)
    (keep in mind that I only have a 125 K/s connection with a maximum of about 100 K/s)

  14. erAser_crAsh

    erAser_crAsh Network Guru Member

    I've had the exact same problem with Torrents (Azureus, ABC and Basic client) and eMule/eDonkey when I flashed to DDWRT. I tried with HyperWRT and it was the same. I rolled back to Linksys' official firmware, and everything went smooth again. Reflashed to 3rd party...went all wrong. At the moment, I'm sticking with the standard firmware for this reason, but it sux...
    Maybe I'll try with an older Sveasoft firmware.
  15. JWolf

    JWolf LI Guru Member

    Wrong forum section this is not the DD-WRT section.
  16. JWolf

    JWolf LI Guru Member

    When you flashed to 3rd party firmware, did you clear the nvram and not load saved settings from any other firmware?
  17. mstombs

    mstombs Network Guru Member

    I have no problem with uTorrent and Thibor on WRT54GS, try a properly seeded/tracked commercial download such as the 150Mb trial version of nero, linked from this page, should easily get more than 100kB/s
  18. hyolee

    hyolee LI Guru Member

    Yes, I am using PPPoE to access my ISP. Is there anything I can do?
  19. hyolee

    hyolee LI Guru Member

    That's not the problem, I get max speeds on bittorrent downloads but it slows down my network like CRAZY!!! With these firmware, supposedly... it's suppose to be able to allow the user to download torrents and also resume normal network activity without lag right?
  20. bob332

    bob332 Network Guru Member

    here is what i have been using for a long time on my wrt54g v2 - v4.30.1, HyperWRT 2.1b1 +tofu13c

    no issues whatsoever with anything, including torrents, emule, and me serving about a dozen websites and hosting games (bf2 and coh) - 3machines connected 2via cat5 and 1 via wifi

    here are the stats from the router:
    Uptime : 231 days, 14:43:48
    System Load : 0.00 / 0.00 / 0.00
    LAN (rx/tx) :71.90 G (1.14 K/s) 122.30 G(3.55 K/s)
    WLAN (rx/tx) :3.26 G (0.00 K/s) 12.88 G (0.01 K/s)
    WAN (rx/tx) :123.33 G (3.57 K/s) 74.33 G (1.21 K/s)
  21. hyolee

    hyolee LI Guru Member

    Hmmmm, do you guys think that re-flashing my router with the same firmware could fix the problem?
  22. frenchy2k1

    frenchy2k1 LI Guru Member

    Do you have QoS set? You need bittorrent/emule at lowest priority.
    Did you clear the NVRAM after you flashed to the new firmware? Not clearing can lead to funky behavior.

    If you do not remember if you had cleared the NVRAM, you can clear it, reflash the firmware, clear again, configure the router (including QoS) and report again.
  23. serioustommy

    serioustommy Network Guru Member

    I had the same problem before, and it seemed to be solved by setting the Max Connections to 4096 under the Conntrack Settings.
  24. davexnet

    davexnet LI Guru Member

    Check the event viewer.
    (eventvwr.msc from the RUN box) Click on system on the left and peruse
    the events on the right. If you see events with a yellow warning !
    and the source is tcpip, double click the event and see if it is the relevant
    event "TCP/IP has reached the security limit imposed on the number of concurrent TCP connect attempts."

    If you don't see any of these in the time frame in question, this is not the
    problem and can be discounted.
  25. sirsquishy

    sirsquishy LI Guru Member

    Personally, it just sounds like you are maxing out your connection tables in the router...which is Quite common for SOHO devices.

    Try adjusting the Global amount of connections allowed in your BT client, then Connections per torrent. Start with 10 Global, and 2-3 per torrent. If this helps, that that is definitely the problem.

    Linksys routers cap at 80 Connections Total. But Depending on the Hardware Rev of your router it could be severely less....

    *Edit*, To my knowledge there is no way to "View" the current connections in your router, as you can with a PIX or a Linux Based Firewall/router. So you cannot "test" the connection table from the router itself.
  26. Thibor

    Thibor Super Moderator Staff Member Member

    hmm, i thought it actually IS a linux based firewall/router. i personally check these connections with "cat /proc/net/ip_conntrack | grep ESTAB" to see the current established connections. is this method incorrect or inaccurate?
  27. sirsquishy

    sirsquishy LI Guru Member

    Sorry, I was referring to the Linksys Firmware ( he was swtiching between Custom and Factory )

    But, as long as he is using Linksys's Firmware he will have that connection table limit....
  28. Thibor

    Thibor Super Moderator Staff Member Member

    very true. Linksys set the default conn table limit at 2048 by default but hold the record in the table for 5 days, which if not closed out properly is known to cause issues.
  29. hyolee

    hyolee LI Guru Member

    Yes, it does say that! What do I do?
  30. kop48

    kop48 Network Guru Member

    By following the instructions:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice