Using jffs2

Discussion in 'DD-WRT Firmware' started by Mr_X, Aug 14, 2005.

  1. Mr_X

    Mr_X Network Guru Member

    I installed DD-WRT 22 R2 but I got a problem with jffs2.
    First I installed full package but I read that when using a WRT54G, to use jffs2, I have to use basic version.
    That what I done. I enabled jffs2 from the web but it didn't worked.
    I read this: and typed the 3 commands under a ssh session:
    nvram set sys_enable_jffs2=1
    nvram commit

    I waited some time then tried the ipkg update command but it didn't worked :(
    When i say it didn't worked, I got this with ipkg update:
    mkdir: Cannot create directory `//jffs/usr/': Read-only file system

    Here some more info (can be usefull but I'm not sure):
    ~ # mount
    /dev/root on / type squashfs (ro)
    none on /dev type devfs (rw)
    proc on /proc type proc (rw)
    ramfs on /tmp type ramfs (rw)
    ~ # df -h
    Filesystem Size Used Available Use% Mounted on
    /dev/root 2.0M 2.0M 0 100% /

    Can someone tell me what I done wrong?
  2. BrainSlayer

    BrainSlayer Network Guru Member

    enable jffs2 and select also clean jffs2. this should work
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice