Using Ushare on Tomato Linksys WRTSL54GS

Discussion in 'Tomato Firmware' started by Aquafire, Apr 5, 2009.

  1. Aquafire

    Aquafire LI Guru Member


    I have been able to successfully install UShare (DLNA Media Server) on Tomato Mod ND 1.23 USB mod (teddy_bear). I installed it from the from the feeds and repository available for DD-WRT.

    I have installed it to an external USB flash drive connected to the router and upon mounting it is automatically binded with the internal /opt directory (as guided in a number of threads).

    It is run automatically via giving the command in the startup scripts section and run after mount section in the tomato firmware.

    I am able to see the DLNA shares via PS3 and my mobile phones, however there are 2 queries I wanted to ask :

    1. Everytime Ushare is started it needs to be refresehd to enlist the media files in the attached USB harddisk and it is lost again upon restart, thus no files are shown when browsing the Ushare server on PS3.

    Any idea how to command Ushare to automatically refresh the shares list and the files everytime it starts and keep standby for any new files added to the media library.

    2. I have also mounted a SAMBA CIFS share for a shared folder on my local Windows XP PC. It is mounted correctly (with the username/password) in the routers internal /cifs1 folder. I also have some file on my Windows XP PC.

    So I was wondering that if I gave the path of /cifs1/<mounted windows share> in the ushare.conf file of the ushare configuration , then it would be able to see and share the files on the PC as well.

    I have tried adding the line "/cifs1/<mounted windows share>" to the usahre.conf file as follows :

    However on PS3 I am still not able to see any files stored locally on the PC and available via the CIFS share.

    Only the files on the USB Harddisk (connected to the router's USB port ) are shown and are able to played. They are loaded as 2 partitions as shown the in above statement

    All USB connected harddisk are added and loaded in the mount point under /tmp/mnt on the router.

    Any idea about how to make it work so I can make any CIFS share files available to the Ushare server.

    Also please guide me to a more active forum for using Ushare with Tomato so maybe I can get some guidance from the individuals who are expertimenting with this sort of setup.

  2. Aquafire

    Aquafire LI Guru Member

    Problem 2 is solved. Needed a cold boot of the router.

    Thus remains only problem no. 1
  3. hunter2606

    hunter2606 Guest


    I am a complete Linux noob. I am running WRT54G with tomato 1.25 and have a NAS. Now I would like to use the router as a media server. Can uShare be installed directly on the router?

    How much configuration would this be? Would I need to install other packages as well?

    Thanks for some guidance
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice