v23-SP1 Final comments and issues

Discussion in 'DD-WRT Firmware' started by vincentfox, May 16, 2006.

  1. vincentfox

    vincentfox Network Guru Member

    Well SP1-Final is out, add comments and issues to this thread.
  2. sufrano63

    sufrano63 Network Guru Member

    two routers (wrt54g and wr850gp) upgraded successfully to sp1 final. Couldn't ping dns name of wr850gp router. Checked both routers have diff Internet IP addresses. wrt54g works fine. Wonder if this is a problem with wr850gp router or the fw?

  3. lore

    lore Network Guru Member

    Between the alpha version dated 5/2/06 and the SP1 release, was the DHCP server modified or changed? I was able to get leases very quickly with the alpha version but the release takes a lot longer again.
  4. blackcobra85

    blackcobra85 Network Guru Member


    it's the first time that I use a 3rd party firmware, so please excuse the "newbeeness" questions:

    The SPI Firewall :
    1- does it come already with predefined rules ? Or I have to create my own with "Firewall Builder - iptables". I have read on the forum that this is the program that people use.
    2- I'm not in front of the configuration pages, so the term may not be the good one : in the Firewall page, i enabled the "filter javascript" or something similar and hotmail.com stopped working (the javascript actually stopped working not hotmail.com access, ie: click on junk folder/inbox...) Is this normal if I enable filter javascript in the SPI Firewall configuration page ?

    I have a WRT54G v4 with v23.sp1.final.std firmware.

    I'm asking these question because in my dsl modem (SpeedStream) it have by default like 25-50 rules to block certain type of traffic

    Thank you !

  5. vincentfox

    vincentfox Network Guru Member

    1) The builtin firewall is fairly complete

    2) Yes, if enable the optional extras like filter javascript it may cause some sites not to work. This is your choice as to whether you desire the additional protection, sacrificing convenience.
  6. DidierKAD

    DidierKAD LI Guru Member

    Hi Vincentfox

    I have just updated my device with v23-SP1 (dd-wrt.V23_mini_generic.bin)

    Here is the config I am using.

    Linksys WRT54GS V4 with original linksys firmware.

    The flashing was very fast and the router looks stable for what I could do so far ;-)
    Unfortunately now that the new firmware is "in the box", the generic password provided with the linksys does not work anymore, which means that I can not access the features/settings of the router anymore.

    Anyone have an idea on what happened with the original password and what the new one could be now ?

    The original linksys procedure only ask for the generic "admin" password, no user name

    Thanks for your help

  7. ccbadd

    ccbadd Network Guru Member

    User: root
    Passwd: admin
  8. DidierKAD

    DidierKAD LI Guru Member

    Thanks ccbadd

    Just what I needed, it works fine now

    Have a nice day

  9. gotamd

    gotamd Network Guru Member

    SP1 seems very fast to me and so far it's been very stable as well. I haven't noticed any non-working features. Great release :thumb:
  10. blackcobra85

    blackcobra85 Network Guru Member

    Thank you for your response!

    One more question : Are the rules visible within the Web GUI ? Because I looked at all the pages and I did not see them ? :eek:

    Thank you!
  11. slove

    slove Network Guru Member

    Flashing was no issue on two wrt54g v4s. One flashed from Tofu 13c and the other from DD-Wrt v21

    One uses DHCP to get Wan IP no problem.

    However the other one using PPoE with Verizon seems to be an issue which I can't resolve. It just won't connect. I reset the firmware to factory defaults and entered everything. There seems to be some sort of cgi bug that won't let you change the Wan connection type, and keeps asking for the userid/password. I had to unplug it to reset it.

    My home computer which does a lot of BT, has the number of ports set to the max and the timeout to 2min as suggested in the help. That works great.

    The 1440 min DHCP defaut time is odd, and the DHCP is working oddly, as when the lease is renewed, we see XP give up 'Lan connection" messages in the balloons, which we never saw before (we leave all computers on 24/7). This also causes some bad packets with BT. We changed the lease time to 7 days.
    Interestingly the router at home defaulted to 200mHz and the other defaulted to the 'recommended' 216.....
  12. Toxic

    Toxic Administrator Staff Member

    Linksys only used the 216 rules as a quick fix. i think you'll find now the problem actually was with v2.2 units and their ram. Thibor has introduced a workaround on his newer builds to enable 200 on all models, howver if you want 216 on the v2.2 its just a matter of sending

    nvram set cpu_overdrive=1;nvram_commit

    via telnet. the large file tranfer issue was fixed afaik in the new 4.71.1 firmware build using a different method now.
  13. vincentfox

    vincentfox Network Guru Member

    I see we need a sticky about the "root" thing.....

    @blackcobra85, recommend you flash the regular "generic" firmware it has many more features.

    The "mini" version is a useful bootstrap step, but not neccessarily where you want to stay. It has many good features but is missing others. For me the lack of https support is important, I administer several of these units remotely and want traffic to be encrypted. Mini is mainly there because some factory firmware will not accept the full-sized firmware file directly. You load mini first, then the full one.

    A lot of this is detailed already in the DD-WRT Documentation Wiki, which you should definitely read.
  14. vincentfox

    vincentfox Network Guru Member

    No. Login using ssh or telnet. This is Linux with a pretty front-end. If you are Linux-literate then this command works fine:

    iptables -L -v

    It's a fairly standard NAT/SPI firewall setup.

    You can easily enough test the firewall with one of the many websites that claims to test your firewall. Just punch in the IP address the WRT unit is using for it's WAN interface and you will see.
  15. blackcobra85

    blackcobra85 Network Guru Member

    Hi, I did flash both firmware because that is what the people are saying on this forum. If the original Linksys firmware did not have the size limit I would have flashed directly to the std firmware. But, is was said here that we have to start with the mini then the one we want, in my case the std version because I did not need voip or the other one.

    I started with dd-wrt.v23_mini_generic.bin and then dd-wrt.v23_generic.bin, both been from the SP1 Final release.
  16. biggerboy

    biggerboy Guest

    Setting Wireless Security with Firefox

    I just flashed a V4 WRT54GS -- so far so good, except there was one nit. I use Firefox mostly, and when I tried to change wireless security from Disabled to WEP, I was greeted with a blank page. I had to go to IE to change the setting.

    Anyone else notice this?
  17. murasame

    murasame Network Guru Member

    Flashed my Ver. 2 WRT54G. I noticed that the DHCP client table didn't list any clients. Just to be sure, I release and renewed my IP and checked the client list and nothing showed up. The wireless client listing shows up in it's corresponding table but wired clients did not.

    Anybody else have this issue? Or am I forgetting/missing something? Thanks.
  18. jinjimbob

    jinjimbob Network Guru Member

    I too had to use IE to flash the WRT54GS v4, firefox wouldn't work, blank page.

    I did have a problem with the clientBridge, until I reset the 3 routers several times, works great now.
  19. ivo_1985

    ivo_1985 LI Guru Member

    It works great(WRT54G 1.1) from a week. But I use it only for AP and wireless connections. The only problem is an unknow MAC in WDS after flashing with SP1. Maybe hard reset will be good, but the AP is highly on the one roof.

    With 2.3. I saw one wireless network, now even when I'm, running on 100 mW I see it very rarely. Any ideas ?

    I don't understand why some people says that router die after 1-2 weeks? Is that true and what is the reason ? :(
  20. Davido

    Davido Network Guru Member

    Which .bin?

    WRT54G v2.2

    There are 4 .bin files: wrt54g, wrt54gs, generic and wrt54gsv4. I already tried flashing with the "wrt54g". My issue is that although it worked for about 10 minutes, I was suddenly disconnected and could not connect again thereafter. What's wrong?
  21. ceevee

    ceevee Guest

    My WRT54GS v2.1 with DD-WRT v23 Final (12/25/05) used to need reboots around every 5-7 days when I ran torrents, emule, and other P2P networks, but v23 SP1 Final (5/16/06) is very stable. I've been up for 12 days straight with P2P programs using full bandwidth, which is a record for me.

    Goodjob on DD-WRT v23 SP1 Final (5/16/06)!
  22. BitNix

    BitNix Network Guru Member

    Wireless connection problems with Orinoco/Proxim Classic Gold 11b - WPA + TKIP on WRT54GS v. 1.1

    Win XP is unable to connect to AP when V23-SP1 version is loaded (Intel 2200BG is able to connect - Orinoco/Proxim is unable to connect)

    When same AP is loaded with Hyperwrt_G_Thibor15c there is no problems connecting to AP with WPA+TKIP.

    There seems to be some differences in the WPA implementation.
  23. Coolpplse

    Coolpplse Guest

    Speed loss through BitTorrent.... seems like it is flaky with its connection tables or something cause BitComet has a real hard time connecting to 100 peers with SP1 Final while it did not break a sweat with the December 12 2005 Final

    Status Page with the assigned DHCP address are here for awhile and gone for a bit... constantly just unreliable

    The Routers transfer rate is also flaky on wireless.. constantly switching speeds from 2mbps - 28mbps.. even though set at 54mbps showing some instability

    When Static DHCP addresses are assigned through computer name and MAC, there are still computers not being assigned with the correct Static DHCP IP Address I set it to.

    Keep up the good work with DD-WRT!
  24. Spacejam

    Spacejam LI Guru Member

    it is a great firmware and it is very stable :thumbup: but i miss one function to add speedlimits to a ip or mac adres is. I hope hou can add this to the firmware i think that many people can usi this option.
  25. YARDofSTUF

    YARDofSTUF LI Guru Member

    Hi, I flashed the SP1 firmware a few days ago and it worked fine, but then I saw the dropdown box for the cpu overclock, and I set it to 216mhz.

    After that the power led continuely flashed, but I couldnt get to the web admin or ping the router. Friend sent me a link to a WRT revival page by shorting to pins on the bios chip.

    Then I could ping it, loaded the lastest firmware from linksys, and then tried the DD firmware again but the power led would go back to flashing, only this time I could ping the router, just not access the web admin.

    I can run linksys' firmware and Hyper WRT, jsut not DD firmware.

    Is this common after the revival thing or a result from trying 216mhz?

    Reset with factory defaults and everything inbetween flashing as well.

    My router is a WRT54G version 2.0

  26. Digital4282

    Digital4282 LI Guru Member

    Problems with MRTG uptimes.

    I am not sure whether this is a DD-WRT problem, or an MRTG problem, but I figure I would drop it in here also as a possible problem. It seems that everytime the router reboots it loses it's current date and defaults back to 05/16/06 - I am using a time server (pool.ntp.org) and it still defaults back. Again, sadly I am not sure if this is a DD-WRT problem, or MRTG.

    Any help would be greatly appreciated.
  27. YARDofSTUF

    YARDofSTUF LI Guru Member

    Well I got the firmware to work after trying to flash it 20 times and having to keep redoing the revival stuff.

    Had the v23 sp1 before, this time used v23 and it worked, may try sp1 again
  28. CreativeSkillz

    CreativeSkillz Network Guru Member

    Hmm, I just flashed my router WRT54G v2 with the dd-wrt.v23_mini_generic.bin firmware.

    Everything worked as it should, though I had to guess the login and password, which took a few tires. After getting in, everything appeared to work fine, and it still does, my only problem is I can't get back in.

    Not sure why, I am wired currently, as that's how I had my router set up in the first place, that you had to be connected to the router via wire to access the ACP.

    I was messing around with the blocking URLs page. I blocked google.com, just to test how well it would work. The settings took place almost instantly, though now that I think about it, it could have been that the router was restarting. I then removed the URL and hit submit again, guessing that the router was still restarting, or just booted back up, not sure which. However, now I am unable to connect to the router.
  29. CreativeSkillz

    CreativeSkillz Network Guru Member

    Hmm, powered the router off for a few seconds then pluged it back in. Let me in this time.
  30. Kamui1407

    Kamui1407 Network Guru Member

    Hi All ,

    I install DD-WRT V23SP1 and I can't have video and audio when I'm behind my WRT54GS rev 1.1 , and It's work perfectly when I connect my computer directly to my ISP Modem .

    I try to enable upnp and forward msn port on my router like that
    but it didn't work.

    THx for your help.
  31. erAser_crAsh

    erAser_crAsh Network Guru Member

    I was using some other firmware before trying DD-WRT's. I now can say it has everything I want (v23 SP1 mini version), with a fresh look, and a wide array of possibilities and personalization.
    No bugs to mention on my WRT54G V2.
    Good job on that one and many thanks :)
    EDIT : the Wiki info page was very useful (root/admin), and clear enough for a complete newbie like my father to flash his without any problem ! The one who did it deserves a warm bunch of thanks.
  32. n3tfury

    n3tfury LI Guru Member

    some of you that are getting blank pages when trying to edit settings using firefox - make sure you check your extensions (noscript, etc). i have no problems using the latest stable and beta2 versions of firefox.

    that being said i'm using the WRT54GL with v23 sp1 final and get fairly constant drops via wireless Airlink AWLC4030.

    i didn't have any wireless issues before flashing (the unit is two weeks old and i flashed maybe a week ago).

    other than that, this firmware is exceptional in every way and a huge thanks to the person(s) involved for developing.
  33. erAser_crAsh

    erAser_crAsh Network Guru Member

    I upgraded to V23 SP2 mini WRT54G through TFTP, as asked on the wiki. No trouble so far, everything is running good, and I think it is even a little bit more stable than the SP1. Configuration with Firefox is somewhat buggy : I've had a few troubles on saving some informations, no trouble for others. Weird. I dunno if it's due to my computer or if it's really Firefox. I'll try some deeper tests as I've experienced no problem at all with IE.
    Anyway, great release.
  34. Bas Horneman

    Bas Horneman Guest

    I did the same. SP1 worked great on my v2.2 changed all sorts of settings...like bringing the output back to 10mW (still had great comms) but then I changed to overclock..only I did not overclock but underclock. After that blinking power led of death!!!! The pin16 thing did not work so now my WRT54G is bricked... :( After trying pin16 many many times I just started scraping the copper wire against all the pins...and that was that...suddenly all the LAN lights lit up like a chrismas tree and that was the end of it...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice