v23 & v24 WDS no longer works past 06-27-06

Discussion in 'DD-WRT Firmware' started by dirtyclyde, Jun 30, 2006.

  1. dirtyclyde

    dirtyclyde Network Guru Member

    v23 loads past Jun 27-06 unable to connect using WDS mode
    Jun 27-06 works correctly WPA2/AES

    v23 Jun 28 on does not work WPA or WPA2 , did not try WEP.
    V24 Jun 28 & Jun 30 also does not work in WDS mode, it's split between channel 6 and channel 1, channel 1 is the one I use.
    on v24 do a "nvram show|grep chan" with wireless set to channel 1 and you will see a tup with channel 1 and two tups with channel 6, a reboot will push the channel from 1 back to channel 6.

    so I went back on all WRTs to V23 date 06-27-06 mini , WDS works great with this load.
  2. swinn

    swinn Network Guru Member

  3. dirtyclyde

    dirtyclyde Network Guru Member

    loaded the new V24 6-30-06 mini generic. Still no go!

    DD-WRT VeryBusyBox v1.1.3 (2006.06.30-15:46+0000) Built-in shell (ash)
    Enter 'help' for a list of built-in commands.

    v24 the channels are split between 6 & 1, I use channel 1.

    nvram show|grep channel


    V23 06-27-06 mini (WDS mode is OK)

    DD-WRT VeryBusyBox v1.1.3 (2006.06.27-01:06+0000) Built-in shell (ash)
    Enter 'help' for a list of built-in commands.

    nvram show|grep channel


    ** all running WDS WPA2/AES same SSID and Channel 1 **
    WRT54Gv4.0 dd-wrtv23 0627-06 mini PC
    WRT54Gv4.0 dd-wrtv23 0627-06 mini XBOX
    WRT54GSv1.0 dd-wrtv23 0627-06 mini DSL & PC
    WRT54GSv2.1 dd-wrtv23 0627-06 mini XBOX 360 & wireless Laptop
    WRT54GSv2.1 dd-wrtv23 0627-06 mini DSL & PC
    WRT54GSv2.1 dd-wrtv23 0627-06 mini DSL & PC
  4. Wikking

    Wikking Network Guru Member

    yep there's a bug in v24. changein the ssid or the channel on the primary interface won't have any effect on wl_XXX vaiables but on wl0_XXX!
    to get your wds running do the following:

    nvram set wl_channel=1
    nvram commit

    if the ssid is wrong too then (in my case it is)

    nvram set wl_ssid=desiredssid
    nvram commit

    you can check whether your settings are correct on
    this shows current channel and ssid
  5. BrainSlayer

    BrainSlayer Network Guru Member

    or you just to a full nvram reset. v24 doesnt use the old style nvram vars anymore. and pressing save at the wireless tab helps too

    wl0_ssid is used. not wl_ssid
  6. dirtyclyde

    dirtyclyde Network Guru Member

    tried v24 & v23 Jul-1-06 mini still wds does not work

    tried V23 & V24 Jul-1-06 WDS mode WPA/AES & WPA2/AES still no workee. Went back to 6-27-06.

    Yes I did do a hard reset for over 30 sec.
  7. BrainSlayer

    BrainSlayer Network Guru Member

    i'm working on this. please test mainly v23. in v24 wds has changed a little bit (driver issue). i'm fixing and catching right now all these issues. v24 can only work if you reset your router. this is just a note. maybe pressing save again in the wds tab will work too
  8. Wikking

    Wikking Network Guru Member

    well....i sure did a full reset before, after and also did mtd erase nvram but the vars STAY. also the builds i've testet 28.06 VOIP 30.06 mini DO USE the old nvram variables. and for pressing the save button...well lets just say i did press it.
    the problem is that if i change the ssid on the main interface wl0 the nvram var wl0_ssid id is updated. but still shows dd-wrt as current ssid (the default setting). and what a coincidence...thats exactly whats saved under wl_ssid. and if i change wl_ssid to lets say TEST shows it as the currently emmited ssid.

    PS: as i said on the other forum wds and repeater mode work fine for me in v24. absolutely no problems if all ssids are encrypted or all are unencrypted.
  9. BrainSlayer

    BrainSlayer Network Guru Member

    you missunderstand me. this affects future releases (starting in some minutes/hours). the current one is simply broken
    but i tested now my latest internal v24 build with wds and wpa encryption

    note that aes+tkip is not supported by the driver. just tkip and aes
  10. dirtyclyde

    dirtyclyde Network Guru Member

    I did try the Jul-1-06(2) mini V24 load today, I did get the WDS to work, Channel 1 WDS WPA/AES got it working, then changed to WPA2/AES still worked, but when you boot the WRT54GSv2.1 the channel changes from 1 to 6, before WDS will work again you have to set the channle back to 1, boot again the it's back to 6.

    Note once I get the WDS to work , connected my Wireless to the WRT54GSv2.1 --> 511T Netgear connects WPA2 (laptop). Worked OK

    Because of the boot problem I went back to the Jun-27-06 Load.

    I'll give the a try v23 Jul-01-06(2).
  11. BrainSlayer

    BrainSlayer Network Guru Member

    v24 is not ready for usage yet.
  12. dirtyclyde

    dirtyclyde Network Guru Member

    Just tried v23 Jul-1-06(2) seems to work (g-only, channel 1)
    WRT54GSv2.1 WDS WPA2/AES to four other WRT54s running Jun-27-06 mini loads. Able to connect WPA2 my 511T netgear on laptop. I run all WRTs WDS as a Switch to all parts of my house. My DSL Westell takes care of firewall and pnp.

    Loaded v23 Jul-1-06(2)
    3 WRT54GSv2.1 mini generic
    2 WRT54Gv4.0 mini generic
    1 WRT54GSv1.0 mini generic

    DHCP is turned off on all WRTs , Westell DSL is DHCP server
    Internet connection type is disabled
    Firewall is disabled on all WRTs, Westell DSL is Firewall
    Channel 1 and all WRTs have same SSID

    WDS WPA2/AES mixed mode is working OK on all 6 WRTs
    511T works any place in house, XBOX, XBOX360 and all PC's thru out the house work correctly, no problems here. (g-only)

    DSL --> Switch --> WRT54GSv2.1 WRT54GSv2.1 WRT54GSv1.0 (all WDS)

    WDS --> WRT54GSv2.1 --> XBox360
    WDS --> WRT54Gv4.0 --> PC
    WDS --> WRT54Gv4.0 -->XBOX
  13. dellsweig

    dellsweig Network Guru Member

    Update on this.

    I just reloaded 7-01 build 2 on a WRT54G V3 - upgraded from 6/27 (mini build)

    Before Upgrade

    wds signal strength 86%
    Rate: 54Mb

    After upgrade:

    WDS signal strength 6%
    Rate 11Mb

    Fell back to 6/27 build

    WDS Signal strength 85%
    Rate 54Mb

    I am not the only one seeing this performace hit.

    WPA may now be working but there is something else going on
  14. BrainSlayer

    BrainSlayer Network Guru Member

    yes your configuration. b-only etc is supported again. additionally you should wait some minutes (1-2) unil you get right signal values. this is important for all versions. since the wireless driver is responsible for all signal strength (and this driver has not changed) it is not possible that the signal quality changes unless you changed something on the txpwr settings
  15. dellsweig

    dellsweig Network Guru Member

    Well I tried the 7/02 V23 build.. It seemed to work fine - for about an hour:

    OK - The success with 7/02 was premature.

    WDS ran fine with good signal strength for about an hour. The WDS link dropped out. I could not restore.

    As before, I fell back to the 6/27 build. This time I could not restore the link. There was signal but could not ping the other node.

    I ended up doing a hard reset and re-configuring both nodes to get things working.

    Question - Does 7/02 build use different NVRAM values for WDS or WPA which the hard reset flushed out??

    Bottom line: There are WDS with WPA-TKIP problems still in V23 7/02 (post 6/27)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice