v23 + WRT54GL + SOHO77 + Static IP?

Discussion in 'DD-WRT Firmware' started by tommix, Feb 7, 2006.

  1. tommix

    tommix Network Guru Member

    I bought a WRT54GL recently and flashed it to DD-WRT v23 almost as soon as I got it out of the box. Everything went well, but I'm now having a pretty silly problem: I simply cannot get the connections to work towards internet when using static IP!..

    If I let the router get the IP from SOHO77's DHCP automaticly, everything works, but if I try to set it myself. I cant make connections to net.

    I have previously configured my SOHO77 to leave IP outside it's DHCP range, as I used it on my wired net connection (by manually defining it in the XP network connections as the IP for my machine). This works fine.

    So, could someone advice where am I going wrong with the following setup:


    Settings in WRT54GL setup:

    Internet: Static IP
    dns: (works)


    wrt54gl assigns dhcp range :

    Now, if I change the static to use SOHO's DHCP, it gives for example and this works? But my manually assigned does not :S. I've double checked and I dont have any machine connected to SOHO that might be using the .2 IP.

    I know I must have missed something, so any help would be greatly appreciated.
  2. whatsthedeal

    whatsthedeal Network Guru Member

    first let the router get an address via dhcp. now copy down the gateway and dns server ip addresses. then switch to static ip and put in both the gateway and dns addresses.

    i think that should do it. let us know how it goes.
  3. tommix

    tommix Network Guru Member

    Thanks, I've tried that but it still doesn't let me use

    If I let WRT get the IP from SOHO's DHCP, it will let me connect to the net, but the problem is the is the "default" where all traffic goes to in SOHO77. So, if I leave WRT on auto-DHCP, I will never get it the "main" IP assigned to it leaving me with lots of NAT-to-NAT issues :(

    I've now tested again and if I manually assign the IP to, while the gateway+dns are 100% correct, I can connect to SOHO using telnet via the WRT, so that means there is a connection to the SOHO, but why it's not letting me go to the net is beyond me. Can't ping anything outside or connect to sites beyond the router.
  4. Guyfromhe

    Guyfromhe Network Guru Member

    it's late and my brain is half asleep but I think the fact that you've set the LAN gateway on a different subnet than your router is causing the problem, try setting the gateway on the lan to the same IP as the router, standard linksys firmware doesn't even let you change that because theres very few situations where you'd want that to be different...
    give that a shot and see what happens...
    if that doesn't work print your routing table by sshing or telnetting in and typing in route.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice