Very frustrating problems with WRT54G (connectivity)

Discussion in 'Cisco/Linksys Wireless Routers' started by tel1jag, Feb 17, 2005.

  1. tel1jag

    tel1jag Network Guru Member

    I am having a problem with my WRT54G ver. 2.2. My wired ports work fine and my wireless is up and down. I have a laptop connected via Centrino and Intel 2200BG and also and XBOX with the MS MN-740. Both exhibit the exact same problems...not matter what channel, no matter what settings, it sees the router than doesn't, then sometimes it comes back. The wired ports continue to work, and I can no longer see the WRT54G in the available networks, at all....sometimes it comes back for a little while, sometimes not.

    I normally don't broadcast the SSID...if I do however, it reconnects, if not...bye bye seeing the router. I have used the laptop at work with Linksys and other vendors and it works great...also, at home I used to use a switch with an Apple Airport in it...NO PROBLEM...when I switched to this piece of garbase WRT54G...nothing but issues.

    I have RMA'ed the unit and am now seeing the exact same symptoms with this new one. I have used the last 2 firmwares from Linksys and then in desperation subscribed here and used the latest Alchemy rc. All exhibit the same thing.

    The craziest thing is that there seems to be a period of time (evening) when this always seems to happen...other parts of the day, not as bad. However, I have tried other channels, shutting off various electronics, and trying to determine any root cause. I was having this issue just now and decided to plug my OLD Airport into the WRT54G wired part, and bingo, 11MB I am typing to you on the old AP. As far as I know, interference for G should be affecting B as well.

    At this point, if no one can figure this out, I will need to get another brand and/or model.

    Sorry for the long message....this is driving me insane.

    Edit: Also, to mention, I increased the transmit power a few times and I test about 10-15 feet from the unit. i have even gone right next to it, there is nothing in the way that isn't in the way of the older Airport WAP and I also detect my neighbor's netgear reliably...I just can't get this WRT54G funtional (2 different units!!!)....someone tell me I am not crazy.

    I posted this on another forum (Sveasoft's) and received some suggestions to set to B or G only...I have posted my response below....

    I have now tried B only and G success. If I don't physically reboot the router, it doesn't even show up anymore.

    I have my old airport up connected to a wired port on this piece of garbage fine. The WRT, however, nothing.

    I am tempted to hit it with a sledge-hammer just for fun.


    Thank you.
  2. howardp6

    howardp6 Network Guru Member

    Not broadcasting your SSID is not a security issue, since the SSID is in the packets sent and can discovered with sniffers, Netstumber and even the hidden site survey. If you are in an eironment, where there are other Access Points broadcasting their SSID and you have Windows XP, It causes problems as you discribed. Do you have a 2,4mhz telephone, or your microwave may be part of the problem.
  3. tel1jag

    tel1jag Network Guru Member

    I do have the phone and microwave, but they have not been in use during my testing.

    The tricky thing is that my much older Aiport (802.11B) WAP is NOT having these problems. I have SSID not broadcasted and when it is connected with the WRT54G (on a different channel), I can still usually attach and work fine on the Airport.

    However, the WRT54G is no where to be found...and further, they both work on the same 2.4 frequency.

    It is driving me insane.
  4. Esquire

    Esquire Mesquire Staff Member Member

    If you are using Windows to manage your wireless connection, you should be aware of an issue with maintaining connection to a hidden SSID/router.

    Since enabling SSID Broadcast rectifies the situation, you should consider keeping the setting on.

    PS. Your cordless phone is still broadcasting whether or not it is in use - the handset too needs to maintain a connection to the base at all times.
  5. tel1jag

    tel1jag Network Guru Member

    Thanks for the information...I will put SSID broadcast back on, however, it doesn't fix the just drops and is able to reconnect most of the time.

    It should "never" drop at all, no?

    The other very crazy piece is why is the older 802.11B Airport not effected by any of this? It is not broadcasting SSID and has worked for years (at least 1 1/2 to 2 years straight). Nothing else in my environment has changed and the older Airport is still very solid.

    I would just as soon return the WRT and use the Apple Airport, but I would like to do G vrs. B and I am sort of hooked on the SVEASOFT features, but I can't do it if the router/WAP doesn't work.
  6. linksysonline

    linksysonline Network Guru Member

    So you have tried restoring to factory defaults and using just everything as is with factory defaults (channel, router name, etc) and the issue still occurs... considering its not just with the wireless laptop connection this probably won't help at all, but have you updated the drivers for the wireless card?
  7. tel1jag

    tel1jag Network Guru Member

    I have completely reset this thing...tried two firmwares from Linksys (newest and one back) and I am now using the Alchemy SVEASOFT stuff.

    Also, I have upgraded the card drivers, but the problem is only with the newer WRT and affects my XBOX-MN740 device as well....

    Both work fine with the older Airport, and the laptop works fine with other WAPs, G and B.

    Thanks for all the help so far though, it is appreciated as I am contemplating setting this thing on fire, just for a smile.
  8. Toxic

    Toxic Administrator Staff Member

  9. randy998

    randy998 Network Guru Member

    We are having the exact same problem with ours. We moved the routers and now we are having the same problem,

    1. We have a wireless router connected to our firewall server which is connected to the dsl modem

    2. we have 2 wrt54g routers 1 sitting on top of the other. one has wireless disabled , the other doesn't

    3. The wireless router is connected to firewall server

    4. My wireless users have to renable their wireless connection 2 or 3 times a day for websites to come up. Wired connections are fine.

    IT is very frustrating because I cannot figure out what is going on...

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice