Very very slow 10/100 switch

Discussion in 'Cisco/Linksys Wireless Routers' started by bokh, Jul 9, 2006.

  1. bokh

    bokh Network Guru Member

    Why oh why is the internal 10/100 switch in my WRT54GL v1.1 so t-e-r-r-i-b-l-y slow?!
    I mean: a file of app. 60MB would take 11 minutes to download from a PC connected to port1 to a PC connected to port4, where that very same setup connected previously to a Linksys 10/100 Workgroup Switch would do that in a couple of seconds...

    What or where is the problem?
    It seems hardware-related, because I had it in DD-WRT v23 SP1 and also in the freshly installed HyperWRT Thibor 15c... or can it be adjusted with QoS?
  2. Toxic

    Toxic Administrator Staff Member

    Have you reset your router since upgrading the firmware?

    I ask as the GL has a very fast switch much faster than the v1 and v2 routers.
  3. bokh

    bokh Network Guru Member

    (thanks for a quick reply!)
    No I have not done a reset after the upgrade to HyperWRT.
    Should I just push the reset button on the backside and if yes for how long?

    UPDATE: After I hold the reset-button for app. 5 seconds the router is reset to default and I have to restore the configuration. DL is 5 min for a 17MB file afterwards... :(
  4. Toxic

    Toxic Administrator Staff Member

    try pressing it for 30 seconds. you will losse you settings but it will default the router correctly.
  5. bokh

    bokh Network Guru Member

    Too bad... makes no difference at all.
    What else could I try? Or maybe the switching-part was DOA?
  6. Toxic

    Toxic Administrator Staff Member

    cables are all CAT5 or above?

    LAN ports are set at 100 Full duplex?
  7. bokh

    bokh Network Guru Member

    Yes indeed, the cables are CAT5, the NICs are set to 100baseTX FullDuplex (FreeBSD) and auto-sense (WinXP gets 100FD). I guess the Windows-box gets the 100FD by negotiating with the switch, right?
    FreeBSD's "ifconfig" tells me what speed the NIC is set to, Linux in the WRT does not... I need "mii-tool" for that. :)

    In the meantime I've changed the blue "Linksys-cable" that came with my WRT with a high-grade CAT5, but that made no difference. That blue cable was the only new kid in town in my working setup.
    With this setup communications on port 2 and 3 (LAN-2-LAN) on the switch hardly gets beyond 100KB/s (a testfile of 10MB at speed 120.5KB/s in 01m:25s).
    WAN-to-LAN-speed is as expected (app. 600KB/s). No exotic settings on the WRT, being used as an AP.

    I'd say this is a weird issue... :cry:
  8. Toxic

    Toxic Administrator Staff Member

    ifconfig should show you in wrt54gl cli

    any anti-virus checking utils running?
  9. bokh

    bokh Network Guru Member

    "ifconfig" in the CLI shows stuff like this, but not the speed as you can see:

    # ifconfig
    br0        Link encap:Ethernet  HWaddr 00:16:B6:xx:xx:xx  
              inet addr:  Bcast:  Mask:
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:8362 errors:0 dropped:0 overruns:0 frame:0
              TX packets:13836 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:1729767 (1.6 MiB)  TX bytes:14926384 (14.2 MiB)
    Anti-virus is enabled, but was never an issue before.

    However, I have enabled portforwarding to the FreeBSD-system that is connected to port2. These notifications show up in the logging (I grepped for "br0"):

    Jul  9 17:08:22 linksys kernel: br0: port 2(eth1) entering learning state
    Jul  9 17:08:22 linksys kernel: br0: port 1(vlan0) entering learning state
    Jul  9 17:08:22 linksys kernel: br0: port 2(eth1) entering forwarding state
    Jul  9 17:08:22 linksys kernel: br0: topology change detected, propagating
    Jul  9 17:08:22 linksys kernel: br0: port 1(vlan0) entering forwarding state
    Jul  9 17:08:22 linksys kernel: br0: topology change detected, propagating
    I have no idea what they mean exactly...
  10. bokh

    bokh Network Guru Member

    Slightly better performance between Ubuntu Linux 6.06 and FreeBSD with no anti-virus software in between.
    "mii-tool" on Ubuntu is positive about eth0's setting it got through negotiation:

    # mii-tool 
    eth0: negotiated 100baseTx-FD flow-control, link ok
    but DLing a 10MB testfile through Apache HTTPd gives app. 300KB/s:

    # wget ; rm 10mb.bin
    => `10mb.bin'
    Connecting to connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 10,485,760 (10M) [application/octet-stream]

    100%[====================================>] 10,485,760 274.45K/s ETA 00:00

    21:14:50 (305.47 KB/s) - `10mb.bin' saved [10485760/10485760]

    using "scp" between the 2 systems gives even less throughput...
    During the copying the system load on the WRT remains 0.00.

    In the webGUI I read Wired QoS which controls devices plugged in to the router with a Ethernet cable. Does this have anything to do with this? And if yes how do I enable wired QoS - by adding the ports through the category / Ethernet port-setting?
  11. bokh

    bokh Network Guru Member

    F-I-X-E-D (sort of)

    Better late than never...

    It turned out to be a malfunction in the switch-part of the WRT54GL itself.
    I've reflashed it and traded it in and the new one seems to be working okay.
    Still no real 100Mbps like on a real switch, but better than 100Kbps! :)

    FYI: Linksys-support told me that firmware is of no effect on the switch.
  12. Andy Mac

    Andy Mac LI Guru Member

    Switch problem

    One more thing for you to check out if you come back to read this thread. More often than not, slow file transfer is a result of a faulty cable. The wire that runs through CAT-5 & CAT-6 are continous single strands. They stress and snap very easily. A lot of the time, a stress fracture or complete breakage can still give you a connection. The the broken wire induces a magnetic field from one side of the breakage to the other. It still works but you suffer massive attenuation and wave reflections from the discontinuity. If you made the cable yourself, make sure you crimped it hard enough.

    You should at least get 10MB/s on your network as this is the nominal PATA HDD data rate. SATA drives are much faster again. Good luck :)
  13. Guyfromhe

    Guyfromhe Network Guru Member

    He already changed the cable he says...
    firmware shouldn't affect the switch chipset, just the internal port the router can talk to...
    the switching of the 5 ports is done by the chipset itself not by the OS running on it.
    You can send commands to the chipset to control the way it works from the CLI however, you could have tried forcing 100 mbit fd on both ports that may have helped or it could have just been a defective switch chipset, as long as it's fixed thats good.
  14. u3gyxap

    u3gyxap Network Guru Member

    Change your Windows setup from "Auto" to 100 Full Duplex.
    Try without the switch - plug the cable directly to both computers and see how it goes.
  15. Guyfromhe

    Guyfromhe Network Guru Member

    When you say still not 100Mbps what speeds are you actually getting?
  16. bokh

    bokh Network Guru Member

    Well... there are a couple of ways I can try to test the speed on the switch-ports. FYI: it used to be okay using a dedicated Linksys 5-port switch before.
    There is a UTP CAT5-connection between a WinXP-Home- and a FreeBSD 6.1-SECURITY-system, both with 100Mbps FD enabled cards (Intel 10/100 (fxp) and Linksys / Broadcom-type (tulip)).
    I can try Samba, SCP, FTP and HTTP. Samba is what I use the most between the two, of course.
    I'll see and try if I can give you some figures over the weekend.
  17. Guyfromhe

    Guyfromhe Network Guru Member

    I'd try all of them, you should be seeing at least 5 mbyte / sec over a 100 mbit link. 8 is pushing it, 10 is nearly impossible and 12.5 is the theoretical max but you'll never get that.
  18. u3gyxap

    u3gyxap Network Guru Member

    Well, that is what I was getting at. My laptop has a 10/100 broadcom adapter, 440x and in some cases, unless it is specificly set to work as 100Mbit Full duplex, I get the same weird results. Very low speed.
    Hardcode the 100 FD. If it persists, try with a direct cable between the two PCs.
  19. Guyfromhe

    Guyfromhe Network Guru Member

    if you have a speed or duplex mismatch there will be zillions of errors and dropped packets thus slow speed.

    You could try forcing a speed setting, try forcing 100 and 10 FD and HD see if that helps at all...

    Again those speed numbers would be nice.

    Also if you try PC to PC you need a crossover cable, a straightthrough will not work incase you weren't aware.
  20. bokh

    bokh Network Guru Member

    Speed results

    Pulling a 100mb.bin file from FreeBSD-6.1 to WinXP Home

    Best results with Sun Download Manager over HTTP!!
    Samba has always been a bit of a drag and using secure protocols things always become slower.

    Samba: No hard value, max 50% of 100MBps in taskmanager / network
    WinSCP: max. 2865 KB/s
    PuTTY scp:
      with compression: 2275.6 kB/s
      no compression:   2226.1 kB/s
    HTTP (Apache 2.0.59):
      avg. 4160 KB/s - using Firefox
      > 10794 KB/s - using Sun Download Manager (100% in taskmanager / network)
    FTP over SSL (vsftpd --> FileZilla):
      avg. 2035 Kbyte/sec
  21. Guyfromhe

    Guyfromhe Network Guru Member

    Things are going to be ALOT slower when being encrypted...
    You HTTP speed seems just a bit slow, but not awful..
    if your sun download manager is able to get 10 mbyte then theres nothing wrong with the switch...
  22. Guyfromhe

    Guyfromhe Network Guru Member

    If your encrypting it, it will be alot slower.
    Your HTTP speeds aren't awful, but your Sun download manager speeds are higher than average, so you probably don't have a switch issue.. It could be a problem with your XP machine or something...
  23. bokh

    bokh Network Guru Member


    Okay, let's clear things up...
    There is indeed nothing wrong with my current WRT, but when I started this thread I had a different WRT54GL. Because Linksys and I thought the switch was malfunctioning I traded it in for a new / different one.
  24. bokh

    bokh Network Guru Member

    And slow again

    After flashing to 3rd party firmware "Tomato" (current version 0.04) last week, I'm back on 350Kb/s using SDM over HTTP... Samba is even worse. :-(
    Linksys can say that the firmware is of no influence on the switch, but my experience is way different!
    I'll try if getting back to the original Linksys-firmware v4.30.7 solves anything later this week.
  25. bokh

    bokh Network Guru Member

    I went back to Linksys' firmware v4.30.7: no difference at all, still slow switch-performance. So after that failed too I'm back on Tomato v0.04 again.

    What I'd like to see is what the Linksys WRT54GL itself is thinking about the capabilities of it's internal (virtual?) switch-ports. "ifconfig -a" is not telling if anything connected is at 10/100Mbps full- or half-duplex. Something like "mii-tool" in Linux or OpenWRT's "robocfg"
    Is there still such a tool or command for the WRT54GL?

    "robocfg" seems to work on Tomato too. Here's what I get:
    # /cifs1/sbin/robocfg show
    Switch: enabled
    Port 0(W):  DOWN enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
    Port 1(4):  DOWN enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
    Port 2(3): 100HD enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
    Port 3(2): 100FD enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
    Port 4(1):  10HD enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
    Port 5(C): 100FD enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
    VLANs: BCM5325/535x enabled mac_check mac_hash
    vlan0: 0 1 2 3 5t
    vlan1: 4 5t
    < snip >
    BTW The Port 4(1) 10HD is the ADSL-modem (hence VLAN1 AFAIK).
  26. bokh

    bokh Network Guru Member

    [Final words]
    Last month I had a complete power-failure at home, so all electronic equipment was kinda "reset". Afterwards it turned out I had full speed again from PC to PC through the WRT54!
    My guess is there's something weird with one of the interfaces in the (PC-)hardware...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice