Discussion in 'Tomato Firmware' started by Josh Anderson, Jun 20, 2014.

  1. Josh Anderson

    Josh Anderson Network Newbie Member

    OK, I'm trying to create two separate subnets that both have access to the internet through the WAN port. This seemed like the perfect and simplest use of VLANs I could imagine so I thought it would be straightforward. I've tried to get this working on an Asus RT-N12 and a RT-N66U and I end up in the same spot.

    I create a new bridge (br1) and assign it to the 192.168.11.x range. Then I go to Advanced/VLAN and reassign the ports. I untick something (port 1 for example) from (br0) and assign it to (br1). Then I save which triggers a commit to nvram and a reboot. When I return to the VLAN page after the reboot the boxes for port 1 are ticked on (br0) and (br1). All ports return IPs in the primary range (192.168.1.x) and not in the new VLAN range (192.168.11.x).

    After reading a bunch on the internet I tried reverting to shibby 115 to get back to an earlier SDK. This produced the same result. The router also becomes unreachable once I've mucked enough with the ports on the VLANs for unknown reasons. I have to do a 30-30-30 reset to get back to a usable state.

    Is there some trick here I'm missing? Is there a tutorial that explains the basics of VLANs in tomato? For example, do I need to bridge each VLAN to the physical WAN port in order to get internet? Does the RT-N12 support the experimental trunk tagging feature? Does this actually work in Tomato or should I try and figure it out in DD-WRT?

    Thanks for any help!

  2. Josh Anderson

    Josh Anderson Network Newbie Member

    Thanks tachyon, I am using K26RT-N firmware on both of the routers. I just too another look at the download section and I see that all K26RT-N builds are based on SDK5. I assume that's what your pointing out. So, just to be more specific, I've tried build 120 (K26RT-N) on both routers and build 115 (K26RT-N) on the RT-N12.
  3. Josh Anderson

    Josh Anderson Network Newbie Member

    Thanks again tachyon, I'll give that build a try tonight and see what happens.
  4. Josh Anderson

    Josh Anderson Network Newbie Member

    OK, I got it working. I tried the AdvancedTomato build suggested above and the VLANs worked fine. However, this build seems to suffers from a bug when setting up the wireless networks so I couldn't stay with that. I tried Shibby's 120 again and got it working this time. Not totally sure why but I'm not going to complain at this point. Thanks for the help
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice