Vodafone Duplex ADSL and Linksys WAG200G - DHCP Release and Renew

Discussion in 'Other Linksys Equipment' started by flanker, Jul 22, 2008.

  1. flanker

    flanker Guest


    I decided to post this because I found out that some people are having trouble with the combination ADSL in IPoATM bridged mode (Vodafone ADSL) and linksys WAG-200G.

    A few days ago I migrated to Vodafone ADSL. Instead of using PPOE protocol as most of the ISP nowadays, it uses the IPoATM in bridged mode, ocasionaly knowned as RFC 2684 or RFC 1483. ADSL2+ VPI/VCI: 0.35 IPoATM - RFC 2684 or RFC 1483 in bridged mode

    My ADSL router is a Linksys WAG200G with the lastest firmware 1.01.06 (ETSI) (Annex A) 12/17/2007.

    I configured it as stated in the instructions of the ISP provider and everything started to work normally. I got the ADSL line syncronized, all the SNR and Attenuation values were normal and I started to browse the net without any issue. The problem come afterwards.

    After a little time of regular browsing I turned off the PC. I went out and returned a few hours later, switched on the PC and ... I was without access to the internet. I first suspected that the ADSL line was dead, but I went to the linksys router administration page and everything was apparently OK. I was still connected to the ISP Gateway with an IP and all the values were normal. Since I didn't know what the problem was at the time, I tried to repair the connection with the ISP using the "DHCP Release" and the "DHCP Renew" buttons. As soon as the connection was restablished I got internet and was browsing again.

    After a second time being away with the PC disconnected the problem reapeared. I was again without access to the internet. Once again I used the "DHCP Release" and the "DHCP Renew" buttons and once again as soon as I got line I was browsing again. I realized that this was in fact a big problem since I had to restablished the connection with the "DHCP Release" and the "DHCP Renew" combination every time I turned off the PC, so I started to dig in the internet trying to find a possible solution.

    After a while reading foruns and posts of people in the same situation the conclusion was simple - the only way to keep the connection up was to somehow keep the connection alive. In this particular mode - IPoATM - there is no option "keep ADSL Alive" like in PPOE mode, so I started to figure out a way to make that happen. The idea was to ping some data between the router and the ISP forcing the connection to stay alive.

    After a while browsing in the setup options of the Linksys router I faced the answer - the DynDNS servers. To who doesn't know what a Dinamic DNS Server is:

    "Dynamic DNS is a method, protocol, or network service that provides the capability to a networked device using the IP protocol suite, such an IP router, or computer system to notify a domain name server to change, in real time (ad-hoc), the active DNS configuration of its configured hostnames, addresses or other information stored in DNS."
    in Wikipedia

    So, basically the solution was simple. I registered an account in DynDNS, configured it in the router section "Setup->DDNS" and problem solved. The connection kept alive until now. More than 19 hours without turning on the PC and the connection stayed on. No more "DHCP Release" and "DHCP Renew".


    1. I tried an diferent firmware from the original one by linksys, hopping to solve the problem using a script that could ping some web adress from time to time keeping the ADSL connection alive like the DynDNS trick does, but this open firmware doesn't support the IPoATM - RFC 2684 or RFC 1483 in bridged mode yet. Later on, when this problem is fixed, this firmware will be a much better option than the linksys one. It has excelent extra features that worth the upgrade. The link is http://woytekm.googlepages.com/linksyswag200g-eu

    2. Although the problem has been fixed with the first solution, I had some alternative ideas to solve this. I post it here as I come aware that other different brand of routers has similar problems.
    a. As in the linksys router menu - "administration->reporting" - try to use the log/reporting option to force the router to send data to email or other destination outside the intranet and in that way keep alive the ISP connection.
    b. Use a remote computer to ping your router/IP from time to time keeping alive the ISP connection.

    If you know someone that has this kind of problem forward this post please. Help building the Internet comunity, sharing knowledge and solutions.


    thinking out of the box...because not always the solution is inside it.

    Portuguese Version


    Migrei para ADSL Vodafone Duplex Casa e tive um problema semelhante com o meu router Linksys WAG-200G.
    Para evitar quebra de ligação com o server DHCP da Vodafone encontrei uma solução que obriga a ligação a manter-se activa.
    Neste momento estou a usar a opção do DynDNS. Esta opção obriga o router a receber e a transmitir dados constantemente de forma a sincronizar o IP do router com o servidor do DynDNS.
    Anteriormente precisava de fazer “DHCP release†e “DHCP Renew†para reactivar a ligação. Neste momento posso deixar o PC desligado que a ligação mantém-se mesmo após 19 horas.
    Espero que resulte no vosso caso. Se souberem de mais alguem na mesma situação partilhem.
    Se a solução funcionar também connvosco coloquem aqui o feedback ou enviem-me um mail a relatar a vossa experiencia.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice