VOIP Bug in WAG54GP2 (V1) firmware 1.01.02 (the latest)

Discussion in 'HyperWAP Firmware' started by hrs1358, Oct 11, 2008.

  1. hrs1358

    hrs1358 Guest

    Unlike what is found on the Net about this modem, but I really like it. Here is a problem others and I have found on this box:

    The description of the problem:

    The 2nd phone port is not capable of 'detecting the hang up' and consequently it leaves the line connected and if you're not careful, you may end up with a BAD bill.
    You hang up or press the flash button, but it keeps remaining active and the LED of the line keeps flashing. If you have activated Reorder, it will start the Reorder beep but after some seconds, you'll end up with no-beep state on the line and hanging up will have no effects.
    You don't need to dial; even if you pick the phone up, it will not detect when you're hanging up.
    If you go to the web-based admin portal in this state, you'll find the line's hook state as OFF and Call State as Invalid.
    The only possibility you have to end your call or to correct the line state is to either 1. Restart the modem or 2. Call to a number with the other port (which is on another VOIP provider) and hang up after hearing the ring beep on the other side. When you hang up the 1st port, it will also hang up the 2nd port!

    I did the following steps to make sure of this bug:
    1. I thought it might have been my phone set which was on port 2 so I replaced it with my other phone, which on port 1 was working well. The result was the same and it was not detecting the hang up or the pressing of the flash button.
    2. I thought it may be my 2nd VOIP account (webcalldirect) that has problems because my first one (exetel) worked well so I re-configured the ports vice versa and interestingly saw that whatever I put on the 2nd port, remains incapable of detecting the hang up.
    3. I searched the whole web and almost read the whole ATA manual. I changed the CPC timer, Reorder Settings, Hook Flash Timers, even changed almost all the frequencies in the regional settings to the Australian ones. A long work.... even the dsconnection beep and everything. Then I set almost ALL the services on the providers to OFF. No call forwarding, no even caller IDs, almost nothing but the result is still the same.
    The interesting point is that, if it was the control timers settings, why it woks on port 1, no matter what handset you use or what VOIP account you use. Besides, why the operation of port 1 has effects on port 2?

    I am a software developer myself and this is definitely a firmware BUG.

    You can refer to these links as well:

    I hope you can solve the issue and set the users free of frequent restartings and/or having to call themselves after making calls on port 2!

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice