VOIP device keeps dropping registration with Tomato

Discussion in 'Tomato Firmware' started by Dixit, Dec 17, 2007.

  1. Dixit

    Dixit LI Guru Member

    So I have a Viatalk Linksys PAP2 device behind my Tomato WRT54GS v1. Ive noticed that almost everyday now the PAP2 drops and my line is no longer registered so therefore I cant make or take any calls. If I look at the PAP2 configuration I see it says it cannot register to the server. If I reboot the PAP2 it still doesnt fix the issue. Ive noticed the only way to fix this is to simply just reboot the WRT54GS. Ive had this problem well over 20-30 times and lately I can simply just go to the WRT54GS webpage, click reboot and the PAP2 comes back just fine.

    So this tells me something on the Tomato is blocking the PAP2 after a day or so. Ive even setup the scheduled job to reboot my WRT54GS every morning at 5am, and still Ive seen it say by 10am the PAP2 is back to registration issues.

    Ive tried to look at the Tomato logs and I see it showing that the PAP2 is attempting to make the connection to its registration servers but cant tell if its actually sending that request or just holding it. Because clearly rebooting the WRT54GS fixes it so got a feelings not sending it at all.

    I already have the QOS set to highest, 5060-5061 UDP fowarded, 10000-20000 UDP forwarded, already assigned a static IP to the PAP2, still no fix to it. Its killing me because the the VOIP phone is almost useless 50% of the time.

    Anyone seen this or have any insight?

  2. j.m.

    j.m. Network Guru Member

    If you are using the latest Tomato, try setting Advanced|Firewall|NAT Loopback to "Forwarded Only" and see if that helps.
  3. Dixit

    Dixit LI Guru Member

    Yeap using the latest firmware. Will make that change and see if it improves any.

  4. Dixit

    Dixit LI Guru Member

    Well unfortunately that didnt work, made the change at 1am last night and it dropped again at 4am. Still having issues where the PAP2 cant connect to the login server, but rebooting the WRT54GS simply kicks it back online (without touching the PAP2).

  5. JensG

    JensG Network Guru Member

  6. Dixit

    Dixit LI Guru Member

    As I stated above, already setup forward from day one for 5060-5061 UDP and 10000-20000 UDP.

  7. paped

    paped LI Guru Member

    Normally RTP has a standard port of 5004 as well which i think is like a control port, sip is port 5060 which you have. Does your VoIP carrier use STUN if yes you will need that port forwarding as well and the 10000 ports you have enabled for RTP voice traffic seems a lot normally its around 100 ports although this should not cause a problem it may not be helping and could be a security risk as you should really only open the ports you need.

    Other than that I had a similar problem with registration and it was a miss match of the udp timers on the Sipura SPA3000 and the WRT54GL that I have and I found a post on the forum that fixed it for me. I have done a searce and I think it is this one, have a read though it and try the UDP settings. Obviously you are using different kit but voip is voip no matter what you use so it may well be the same or similar issue.


    Hope this helps...
  8. Dixit

    Dixit LI Guru Member


    I got into the advanced settings of my VOIP device and the STUN is enabled on it, but doesnt show what ports its using, what is the normal port? As far as the 10000 ports, that what seems to be the norm recommended by Viatalk. But after checking the advanced settings, I noticed the RTP ports were only using a range of 98 ports, so I cut it down to that.

    I also changed the UDP timers to whats recommended on that thread, lets see what happens there.

  9. paped

    paped LI Guru Member

    Hopefully with the timer changes you might be sorted...

    Re the 10000 to 98 port forwarding reduction, the 98 ports you have opened will be fine and thats the right thing to do, it is really bad though the a voip supplier does not know even the most basic security 101's and tell their customers to open all those ports....

    Re stun, not sure if there is a standard port as such as the ports used seem to differ and depend on your voip supplier, 10000 often seems to be used but you probably need to speak to viatalk. I have had a look on their website but they don't specfically list the STUN port so I presume that it will be somewhere in the 10000 to 20000 port range that they are showing.
  10. JensG

    JensG Network Guru Member

    Sorry I missed that when I read your first post.

    Could it be the STUN that is unstable?
    Since you have already forwarded the necessary ports, you could try to disable STUN and see what happens.
  11. schweinc

    schweinc Network Guru Member

    Similar Problem with Zoom ATA


    Had a similar problem with my Zoom 5801 and Viatalk service after flashing to v1.13. ATA would not register. I flashed back to v1.11 and all was well. I posted a thread to see if anyone else had the same problem and the answer was no. I thought maybe Viatalk was having a problem at the same time as upgrading firmware, so I flashed again. All is well.

    If the PAP2 is a BYOB you could try the Voxilla.com site and go through the process to have them configure your ATA.


  12. mhe_

    mhe_ LI Guru Member

    Dixit, you need 5060 tcp forwarded aswell.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice