VPN Client Problems

Discussion in 'Tomato Firmware' started by moona, Apr 12, 2008.

  1. moona

    moona Addicted to LI Member

    I'm running Tomato 1.117.1385 on a WRT54GL. Works great, and I've experienced no problems with it thus far.

    Recently, I've been trying to connect to a network via the MS VPN client on a machine behind this device. So, the chain would be device (with VPN client), WRT54GL, Internet.

    I can log into the network via the VPN---it connects fine. I can seem to browse SOME of the network resources on the remote VPN'ed network, but I can't do things like get to websites on the VPN'ed network, or connect to an Exchange server using Outlook.

    I've tried forwarding all ports to the device, as well as putting the device in the DMZ. No luck.

    I have not done any command line configuration on the router---it's all been done through the GUI.

    Any suggestions as to what I may try? I'm trying to determine if this is a router configuration issue or device issue. I don't have another router to try it the WRT54GL's place, so I would love to get this one working.

    All other services on devices behind this router work fine---consoles, PCs, various apps, no problems.

    Any suggestions?

  2. kevanj

    kevanj LI Guru Member

    How are you trying to connect to the remote resources? By IP address or by name? If by name, what do the names resolve to from the VPN client? Do they resolve to IP addresses on the network that you are connected to via the VPN? If not, then the VPN client device will be tring to send them via the internet (unencrypted).

    Is the client a windows box? Are the remote resources resolved by DNS or WINS? Is your VPN server giving your client the correct name resoulution info? (DNS server or WINS server, if appropriate). You may have to specify DNS or WINS servers for your VPN adapter IP configuration.

    Are the resources you CAN get to in the same IP space as the ones you cannot reach. If so, this would *probably* rule out a routing problem at the client end, and would point more to a name resolution issue.
  3. moona

    moona Addicted to LI Member

    I've tried connecting both by name and by IP address. The VPN client is getting the correct DNS/WINS server addresses, and is not having any problems resolving internal addresses.

    Yes, the client is an XP box.

    I can get to a single windows server share, but nothing else, and the other machines are in the same IP space as the one I can get to.

    I'm just stumped. It appears to be doing everything it's supposed to be doing except allowing me to connect. I'm thinking a possible problem with my VPN profile on the other end?
  4. opie100

    opie100 Network Guru Member

    Hi Moona - I'm having the same problem. There's something about Tomato that MS Exchange Server authentication doesn't like. I was able to get Tarifa firmware to work - you may want to try that, in case you weren't able to get this to work. If you were, let us know what you did. Thx!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice